Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-02-2013, 12:47 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Weird noise coming from engine.

I have a question for you guys. There's a whistling/rubbing noise coming from engine when I start it up. The noise gets louder as I accelerate but goes away after 5-10 of driving.

It usually does this from a cold start up.

Also, I tried to listen if it's coming from the pulleys but it sounds like it's coming from more in the middle of the engine.



__________________
Reply With Quote
Advertisement
  #2  
Old 02-03-2013, 05:04 AM
allancharlton allancharlton is offline
Registered User
Location: england
 
Join Date: Aug 2012
Posts: 9
Mein Auto: 2003 3 series convertable
that is almost the same problem i have. but more of a rattle and now i am getting a misfire at low revs.....are you having any other problems?
Reply With Quote
  #3  
Old 02-03-2013, 10:32 AM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by allancharlton View Post
that is almost the same problem i have. but more of a rattle and now i am getting a misfire at low revs.....are you having any other problems?
No nothing else besides the noise.
__________________
Reply With Quote
  #4  
Old 02-03-2013, 03:59 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
I have The same issue on my 01 325. It's your secondary air pump. It runs only when the car is cold to warm the cats. Only runs for about 5 mins than goes away. What's happening is it's become dirty after so long and that's what causes the noise. It's not a big deal if you can deal with the whistle for 5 mins every morning. Atleast that's what my mechanic told lol.
Reply With Quote
  #5  
Old 02-03-2013, 09:36 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by 01e46sprt View Post
I have The same issue on my 01 325. It's your secondary air pump. It runs only when the car is cold to warm the cats. Only runs for about 5 mins than goes away. What's happening is it's become dirty after so long and that's what causes the noise. It's not a big deal if you can deal with the whistle for 5 mins every morning. Atleast that's what my mechanic told lol.
Did you ever change it? And would you know if it's hard to do?
__________________
Reply With Quote
  #6  
Old 02-03-2013, 09:41 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
No I didn't change it because i heard the part alone is like $600. On the other hand today I got a SES light and code p0171 is what came up when I scanned it. Do you have a SES light on ? The reason I'm asking is because it may not be the secondary air pump it could be a torn intake hose (vacuum leak) if that's the case the part is well under $100. Lmk ASAP.
Reply With Quote
  #7  
Old 02-03-2013, 09:43 PM
Fast Bob's Avatar
Fast Bob Fast Bob is online now
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,811
Mein Auto: 2004 330Ci ZHP 3 pedals
Quote:
Originally Posted by Jsmk23 View Post
Did you ever change it? And would you know if it's hard to do?
No need to change anything....that`s just the way it`s *supposed* to function....
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote
  #8  
Old 02-03-2013, 09:46 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
I can still slightly hear mine after the car is at proper running temp. Also the p0171 code is leading me to believe that there's a tear in that boot/hose which is causing the whistle and running to lean ??? May also be jsmk's problem as well
Reply With Quote
  #9  
Old 02-03-2013, 10:52 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by 01e46sprt View Post
No I didn't change it because i heard the part alone is like $600. On the other hand today I got a SES light and code p0171 is what came up when I scanned it. Do you have a SES light on ? The reason I'm asking is because it may not be the secondary air pump it could be a torn intake hose (vacuum leak) if that's the case the part is well under $100. Lmk ASAP.
Wow lol it's funny you say that because the SES actually came on earlier today on my way home.
__________________
Reply With Quote
  #10  
Old 02-03-2013, 10:54 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
Have someone scan it and find out what the code is. If its p0171 we both have same issue. Also how long has the noise been there ?
Reply With Quote
  #11  
Old 02-03-2013, 11:33 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by 01e46sprt View Post
Have someone scan it and find out what the code is. If its p0171 we both have same issue. Also how long has the noise been there ?
I had the car about a month. And it's been making that noise about 3 weeks now. It's starts on a cold startup and gets loud as I accelerate and goes away 5 mins.
__________________
Reply With Quote
  #12  
Old 02-03-2013, 11:36 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
Ya sounds like same issue as mine. Lmk what that code is ASAP.
Reply With Quote
  #13  
Old 02-03-2013, 11:38 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by 01e46sprt View Post
Ya sounds like same issue as mine. Lmk what that code is ASAP.
Will do, Thanks.
Do you happen to know what your code means?
__________________
Reply With Quote
  #14  
Old 02-03-2013, 11:53 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
Well it says system is too lean which means there's more air than fuel mixing which means there's a vacuum leak somewhere. Hopefully it's leaking from the intake boot. Have it swapped out and problem solved.
Reply With Quote
  #15  
Old 02-04-2013, 12:20 AM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by 01e46sprt View Post
Well it says system is too lean which means there's more air than fuel mixing which means there's a vacuum leak somewhere. Hopefully it's leaking from the intake boot. Have it swapped out and problem solved.
When do you plan on changing yours?

On e46 fanatics, ppl are telling me it's the pulleys/tensioners
__________________
Reply With Quote
  #16  
Old 02-04-2013, 07:01 AM
jonathan2263's Avatar
jonathan2263 jonathan2263 is offline
Cogito Ergo Zoom
Location: Far Hills , NJ
 
Join Date: Dec 2008
Posts: 3,503
Mein Auto: 325iT
Quote:
Originally Posted by Jsmk23 View Post
I had the car about a month. And it's been making that noise about 3 weeks now. It's starts on a cold startup and gets loud as I accelerate and goes away 5 mins.
The SAP doesn't get louder as you accelerate. It actually gets drowned out by other sounds. So the possible good news is, investigate for a vacuum leak. If its just a torn or loose boot, it's a lot cheaper than replacing the pump.
__________________


http://www.facebook.com/home.php?sk=...?id=1338939628
"I May Be Going To Hell In A Bucket But At Least I'm Enjoying The Ride"
Reply With Quote
  #17  
Old 02-04-2013, 11:26 AM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by jonathan2263 View Post
The SAP doesn't get louder as you accelerate. It actually gets drowned out by other sounds. So the possible good news is, investigate for a vacuum leak. If its just a torn or loose boot, it's a lot cheaper than replacing the pump.
Thanks bro. Glad to hear that.
__________________
Reply With Quote
  #18  
Old 02-05-2013, 02:39 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Just went to pepboys to get the codes because autozone couldn't do it.

And I got 2 codes.


P0430 & P0444
__________________
Reply With Quote
  #19  
Old 02-05-2013, 03:02 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
Check these 2 threads. Both from this forum. Should answer your questions.

http://forums.bimmerforums.com/forum...d.php?t=917830

http://www.bimmerfest.com/forums/sho...d.php?t=391106
Reply With Quote
  #20  
Old 02-05-2013, 03:52 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by 01e46sprt View Post
Check these 2 threads. Both from this forum. Should answer your questions.

http://forums.bimmerforums.com/forum...d.php?t=917830

http://www.bimmerfest.com/forums/sho...d.php?t=391106
Thanks man, idk where to start. Now idk if the pulleys is what's making the noise.
Reply With Quote
  #21  
Old 02-05-2013, 04:05 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
It may sound crazy but have someone check the alternator. If the bearings inside go bad they'll make the noise you posted in the video. Btw I just noticed there was a video and watched it and your noise is much different than mine. You have more of a metal to metal type jingling noise for lack of better words. Could very well be an alternator on its way out. Just seen the pic to looks like a really nice clean car.

Last edited by 01e46sprt; 02-05-2013 at 04:08 PM.
Reply With Quote
  #22  
Old 02-05-2013, 04:10 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by 01e46sprt View Post
It may sound crazy but have someone check the alternator. If the bearings inside go bad they'll make the noise you posted in the video. Btw I just noticed there was a video and watched it and your noise is much different than mine. You have more of a metal to metal type jingling noise for lack of better words. Could very well be an alternator on its way out. Just seen the pic to looks like a really nice clean car.
Yeah I know I am confused lol Others say pulleys and others say intake boot. Now with these codes it could mean also a whole other thing.

Thanks bro. You have a pic of yours?
__________________
Reply With Quote
  #23  
Old 02-05-2013, 04:16 PM
01e46sprt 01e46sprt is offline
Registered User
Location: New jersey
 
Join Date: Jan 2013
Posts: 28
Mein Auto: 2001 Bmw 325ci sport
No problem man I hope you figure it all out and everything goes well for you.

I don't have a pic yet. Everytiime I wanna get her cleaned up and snap some pics it starts to snow lol. (NJ). Ill post some up real soon.
Reply With Quote
  #24  
Old 02-05-2013, 04:21 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Quote:
Originally Posted by 01e46sprt View Post
No problem man I hope you figure it all out and everything goes well for you.

I don't have a pic yet. Everytiime I wanna get her cleaned up and snap some pics it starts to snow lol. (NJ). Ill post some up real soon.
Thanks I hope so.
For sure bro, can't wait to see some.
__________________
Reply With Quote
  #25  
Old 02-05-2013, 05:10 PM
Jsmk23 Jsmk23 is offline
Registered User
Location: Palm Springs, CA
 
Join Date: Aug 2011
Posts: 32
Mein Auto: 02 BMW 325i
Idk if this helps, but after I shut off the engine it makes this air noise.
Here's how it sounds


__________________
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms