Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)

E63 / E64 6 Series (2003 - 2013)
The E63/E64 BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-13-2013, 02:39 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
Can someone tell me more about this engine light code please?

Auto 2005 645ci
Planned on trading her in before anything came up and with my luck, the engine light came on and got these codes. Can someone tell me more please. Like how bad it Is and how much to fix. Thanks so much.
Po300 random misfire 7 &3 misfiring po303 po307

Sent from my SAMSUNG-SGH-I747 using Bimmer App
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)
Reply With Quote
Advertisement
  #2  
Old 02-13-2013, 08:51 PM
HerbP HerbP is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jul 2009
Posts: 2,691
Mein Auto: 2005 645Ci & 2007 750Li
It could be fuel related, but have you not been getting quite a bit of moisture lately? Have the plugs or coil packs been serviced lately?

Good Luck!
Reply With Quote
  #3  
Old 02-13-2013, 09:15 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
Quote:
Originally Posted by HerbP View Post
It could be fuel related, but have you not been getting quite a bit of moisture lately? Have the plugs or coil packs been serviced lately?

Good Luck!
No none of that has been serviced. And what do u mean have i not been getting moisture kately? If its fuel related what do u suggest I do? I only go to bp sunoco or shell which is where the guys on this forum recommended. Thanks for the reply!

Sent from my SAMSUNG-SGH-I747 using Bimmer App
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)

Last edited by CJ645Bern; 02-13-2013 at 09:16 PM.
Reply With Quote
  #4  
Old 02-13-2013, 09:32 PM
HerbP HerbP is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jul 2009
Posts: 2,691
Mein Auto: 2005 645Ci & 2007 750Li
I thought that your area might have been hit recently with a winter storm. The misfire could be fuel related, or spark related. If the problem is fuel, a good injector cleaner such as Techron might help. The fuel filter could be clogging, robbing fuel from the engine. If you have access to a fuel pressure gauge, check to see if your fuel pressure is up to spec.

If the problem is spark related, try moving a few of the easily accessible coil packs around. You could swap number 1 & 3, & 6 & 7. If the misfire follows the moved COP's, you found your problem. If you decide to swap the COP's, add some die-electric silicone to the inside of the springs. This will help corrosion from moisture, from forming on the plugs.

Good Luck
Reply With Quote
  #5  
Old 02-13-2013, 09:39 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
Quote:
Originally Posted by HerbP View Post
I thought that your area might have been hit recently with a winter storm. The misfire could be fuel related, or spark related. If the problem is fuel, a good injector cleaner such as Techron might help. The fuel filter could be clogging, robbing fuel from the engine. If you have access to a fuel pressure gauge, check to see if your fuel pressure is up to spec.

If the problem is spark related, try moving a few of the easily accessible coil packs around. You could swap number 1 & 3, & 6 & 7. If the misfire follows the moved COP's, you found your problem. If you decide to swap the COP's, add some die-electric silicone to the inside of the springs. This will help corrosion from moisture, from forming on the plugs.

Good Luck
Ahh yes. It snowed but it was bad. An inch or two. Its currently snowing right now. So the snow can be a possible problem too? And can I still drive it?

Sent from my SAMSUNG-SGH-I747 using Bimmer App
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)
Reply With Quote
  #6  
Old 02-14-2013, 11:10 AM
petros2r's Avatar
petros2r petros2r is offline
Ducati fills my BMW's gap
Location: Dallas, TX
 
Join Date: Jan 2010
Posts: 415
Mein Auto: '05 645ci
I would get the same codes from time to time. After resetting the "Check Engine" light and throwing a bottle of Techron cleaner into almost empty gas tank the code does not come back. In fact, I came to a service shop once right after re-setting it and they plugged in their fancy computer and said that there is not even a thread of a problem (normally it's recorded deep in the computer and the bmw service can tell that you've cleared the code)... go figure?

I have gotten a thermostat replacement twice because of the codes like that. Thankfully under warranty.
Honestly, I think is a computer glitch or something like that.

Invest in a pocket OBD-2 reader ($50 at Autozone) and re-set / clear those codes (I do once or so per year).
__________________
2005 Ducati Monster S2R 800
2005 BMW 645ci Cabriolet - SOLD
2013 Lexus RX 350 F Sport
Reply With Quote
  #7  
Old 02-14-2013, 06:01 PM
HerbP HerbP is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jul 2009
Posts: 2,691
Mein Auto: 2005 645Ci & 2007 750Li
Techron is on sale at O'reilly's for 3.99 a bottle. That is a steal!!!!!!!!!!!!!!!!!!!!!!!
Reply With Quote
  #8  
Old 02-14-2013, 06:31 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
Quote:
Originally Posted by petros2r View Post
I would get the same codes from time to time. After resetting the "Check Engine" light and throwing a bottle of Techron cleaner into almost empty gas tank the code does not come back. In fact, I came to a service shop once right after re-setting it and they plugged in their fancy computer and said that there is not even a thread of a problem (normally it's recorded deep in the computer and the bmw service can tell that you've cleared the code)... go figure?

I have gotten a thermostat replacement twice because of the codes like that. Thankfully under warranty.
Honestly, I think is a computer glitch or something like that.

Invest in a pocket OBD-2 reader ($50 at Autozone) and re-set / clear those codes (I do once or so per year).
That's what ill do then. Hoping for the best. Thanks a lot

Sent from my SAMSUNG-SGH-I747 using Bimmer App
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)
Reply With Quote
  #9  
Old 02-14-2013, 06:31 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
Quote:
Originally Posted by HerbP View Post
Techron is on sale at O'reilly's for 3.99 a bottle. That is a steal!!!!!!!!!!!!!!!!!!!!!!!
Thanks for the reply herbp. Hoping for the best

Sent from my SAMSUNG-SGH-I747 using Bimmer App
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)
Reply With Quote
  #10  
Old 02-15-2013, 07:38 AM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
Quote:
Originally Posted by petros2r View Post
I would get the same codes from time to time. After resetting the "Check Engine" light and throwing a bottle of Techron cleaner into almost empty gas tank the code does not come back. In fact, I came to a service shop once right after re-setting it and they plugged in their fancy computer and said that there is not even a thread of a problem (normally it's recorded deep in the computer and the bmw service can tell that you've cleared the code)... go figure?

I have gotten a thermostat replacement twice because of the codes like that. Thankfully under warranty.
Honestly, I think is a computer glitch or something like that.

Invest in a pocket OBD-2 reader ($50 at Autozone) and re-set / clear those codes (I do once or so per year).
Did u put the cleaner in right before putting gas or did u drive for a little longer?

Sent from my SAMSUNG-SGH-I747 using Bimmer App
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)
Reply With Quote
  #11  
Old 02-15-2013, 08:19 AM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,886
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by HerbP View Post
Techron is on sale at O'reilly's for 3.99 a bottle. That is a steal!!!!!!!!!!!!!!!!!!!!!!!
Do you have a link to this? My store doesn't show that price darn it.

I am a Techron convert, my Motorcycle (CBR 1000RR) was running rough at initial start and was getting progressively worse. Ran some through the fuel and it smoothed out and ran perfect.

Same with my Jeep Wrangler, had some periodic misfire issues, one bottle of Techron and no further issues.
Reply With Quote
  #12  
Old 02-15-2013, 08:54 AM
roseng's Avatar
roseng roseng is online now
Officially Welcomed to the 'Fest
Location: Calabasas, CA
 
Join Date: Apr 2006
Posts: 1,471
Mein Auto: 2014 528i + 2007 650 Vert
Quote:
Originally Posted by tampamark View Post
Do you have a link to this? My store doesn't show that price darn it.

I am a Techron convert, my Motorcycle (CBR 1000RR) was running rough at initial start and was getting progressively worse. Ran some through the fuel and it smoothed out and ran perfect.

Same with my Jeep Wrangler, had some periodic misfire issues, one bottle of Techron and no further issues.
I bought a case at Costco and I think it was about $3.00 a bottle.
__________________

I Love LA. It lets me ride in the winter with the top down.
07' E64/Black....14' F10/M-Sport White
Reply With Quote
  #13  
Old 02-15-2013, 08:56 AM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,886
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by roseng View Post
I bought a case at Costco and I think it was about $3.00 a bottle.
For that price I may start drinking it!
Reply With Quote
  #14  
Old 02-15-2013, 09:04 PM
Nitrogen's Avatar
Nitrogen Nitrogen is offline
Officially Welcomed to the 'Fest
Location: Central California
 
Join Date: Apr 2012
Posts: 444
Mein Auto: BMW 650i Convertible
Quote:
Originally Posted by tampamark View Post
For that price I may start drinking it!
Now that was funny, I think I will try it too my bowels are misfiring.
__________________
Sent Via iPhone using BimmerApp
Reply With Quote
  #15  
Old 02-15-2013, 09:18 PM
CJ645Bern's Avatar
CJ645Bern CJ645Bern is offline
youtube.com/lidlgangsta
Location: Deptford, NJ
 
Join Date: Sep 2011
Posts: 224
Mein Auto: 05' 645ci & 01' z3
No oreillys near me. Spent 13 at napa :/

Sent from my SAMSUNG-SGH-I747 using Bimmer App
__________________
live fast, drive faster

2010 Acura TL (daily driver)
2005 BMW 645ci Coupe (traded for TL)
2001 BMW z3 3.0i vert' (TOTALED RIP)
1991 NISSAN 300zx 2+2 (gave to brother)
2007 BMW z4 (traded for 6er)
Reply With Quote
  #16  
Old 02-15-2013, 10:04 PM
roseng's Avatar
roseng roseng is online now
Officially Welcomed to the 'Fest
Location: Calabasas, CA
 
Join Date: Apr 2006
Posts: 1,471
Mein Auto: 2014 528i + 2007 650 Vert
Quote:
Originally Posted by tampamark View Post
For that price I may start drinking it!
Techron and Jack! I'm in.
__________________

I Love LA. It lets me ride in the winter with the top down.
07' E64/Black....14' F10/M-Sport White
Reply With Quote
  #17  
Old 02-16-2013, 08:26 PM
07 E63650i's Avatar
07 E63650i 07 E63650i is online now
Living in Fast Forward
Location: Southern California, USA
 
Join Date: Jan 2013
Posts: 3,218
Mein Auto: 2007 BMW E63 650i
Quote:
Originally Posted by roseng View Post
Techron and Jack! I'm in.
Or Techron and Coke!
__________________
Once a 6'er, always a 6'er.
Reply With Quote
  #18  
Old 02-16-2013, 09:13 PM
HerbP HerbP is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jul 2009
Posts: 2,691
Mein Auto: 2005 645Ci & 2007 750Li
Quote:
Originally Posted by tampamark View Post
Do you have a link to this? My store doesn't show that price darn it.

I am a Techron convert, my Motorcycle (CBR 1000RR) was running rough at initial start and was getting progressively worse. Ran some through the fuel and it smoothed out and ran perfect.

Same with my Jeep Wrangler, had some periodic misfire issues, one bottle of Techron and no further issues.
I was just on their website yesterday, & the add was going across the top of the screen. My zip is 30907, if that makes a difference?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series > E63 / E64 6 Series (2003 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:40 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms