Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-15-2013, 06:55 PM
steezysloth steezysloth is offline
Registered User
Location: Raleigh, NC
 
Join Date: May 2012
Posts: 39
Mein Auto: 2000 323ci
Exclamation E30 No Spark ): HELP

Hey everyone, i have a 89 325is 5spd

But i am not getting spark!!!

New thermostat and housing
All new hoses and gas lines
New main relay
New fuses
New coolant sensors/switches
New flame thrower ignition coil
New battery...

But i get no spark to the ignition coil

Here is a video i made to help you understand -

PLEASE HELP!!
_________________
1989 325is
Reply With Quote
Ads by Google
  #2  
Old 02-15-2013, 09:12 PM
t2112 t2112 is offline
Registered User
Location: Michigan
 
Join Date: Jan 2012
Posts: 11
Mein Auto: 330 ci / 325e in progress
Crank position sensor good and/or plugged in.
Reply With Quote
  #3  
Old 02-15-2013, 09:22 PM
steezysloth steezysloth is offline
Registered User
Location: Raleigh, NC
 
Join Date: May 2012
Posts: 39
Mein Auto: 2000 323ci
Yeah its brand new and plugged in right, any reason why my coil wouldnt be getting power?
Reply With Quote
  #4  
Old 02-15-2013, 09:56 PM
steezysloth steezysloth is offline
Registered User
Location: Raleigh, NC
 
Join Date: May 2012
Posts: 39
Mein Auto: 2000 323ci
Maybe the immobilize? It was parkedfor 5 years and the radio is locked
Reply With Quote
  #5  
Old 02-16-2013, 02:32 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 6,980
Mein Auto: 2012 hypermotard 796
the cps gapped correctly? even though the coil is new, is it good?
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming
Reply With Quote
  #6  
Old 02-16-2013, 04:30 PM
steezysloth steezysloth is offline
Registered User
Location: Raleigh, NC
 
Join Date: May 2012
Posts: 39
Mein Auto: 2000 323ci
Hmmm didnt know that could cause the problem...

Its got a brand ew CPS but i doubt the gap would be out of measurment, its been sitting for 5 or moe years
Reply With Quote
  #7  
Old 02-16-2013, 06:57 PM
steezysloth steezysloth is offline
Registered User
Location: Raleigh, NC
 
Join Date: May 2012
Posts: 39
Mein Auto: 2000 323ci
Okay so here's what I got today..

I turned the key but the engine isn't running obviously
And I put my 2 connection testers on the positive and negative of the coil

It lit up on the positive and negative but not on the inside of the coil, the park that connects it to the distributer...

What does this mean?!?
Reply With Quote
  #8  
Old 02-16-2013, 07:44 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 6,980
Mein Auto: 2012 hypermotard 796
so you have power to the coil, just no spark to the dizzy cap?

either the ecu isnt getting the signal from the cps cause the cps is bad or has improper gap or the wiring is damaged from woodland critters, the ecu is bad, i know theres a couple more but the booze are effecting my train of thought
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming
Reply With Quote
  #9  
Old 02-16-2013, 08:28 PM
steezysloth steezysloth is offline
Registered User
Location: Raleigh, NC
 
Join Date: May 2012
Posts: 39
Mein Auto: 2000 323ci
No well I've got something that tells me of power is coming from the coil that makes a spark. So what I've concluded is no power to the coil..

Brand new CPS as well, I might just take it to BMW and let them diagnose the problem and I fix it at home..
Reply With Quote
  #10  
Old 02-17-2013, 12:28 PM
onager onager is offline
Registered User
Location: Northern VA
 
Join Date: Jan 2013
Posts: 19
Mein Auto: 87 E30 325i
If I understand correctly you have 12 volts going to the coil. If so you won't see the high voltage until shorts out at the plug and causes the spark.
I have seen carbon build up so bad in the dizzy cap that the spark was shorting out. A worn rotor would also be a problem. Five years of corrosion might be your problem?
Reply With Quote
  #11  
Old 02-17-2013, 04:24 PM
steezysloth steezysloth is offline
Registered User
Location: Raleigh, NC
 
Join Date: May 2012
Posts: 39
Mein Auto: 2000 323ci
Not sure, it turns over fine, pumps fuel but no power is sent to the ignition coil. In guessing go down the chain.. If the dizzy was bad it would still be getting power to the coil correct??

This is a pain in the butt...
Reply With Quote
  #12  
Old 02-17-2013, 05:33 PM
downhiller's Avatar
downhiller downhiller is offline
livin large
Location: des moines
 
Join Date: Oct 2007
Posts: 6,980
Mein Auto: 2012 hypermotard 796
well you said you have power to the coil, using a test light i guess. an easy test is to get a spark plug and stick it the the wire from the coil and ground the spark plug out in the motor. then have someone crank the motor as your watching for a spark. if you have a spark, change the dizzy cap and rotor.

if you dont have spark, redo the test with 2 spark plug wires. if you get spark, change wires cap and rotor

if you dont have spark, grab another coil and try that. if problem persists, there is most likely a problem with the ecu or wiring
__________________
I know a lot about cars. I can look at a car's headlights and tell you exactly which way it's coming
Reply With Quote
Reply

Bookmarks

Tags
e30 325is no spark problem


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms