Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 02-10-2013, 08:07 AM
SeanMH-6 SeanMH-6 is offline
Officially Welcomed to the 'Fest
Location: Clarksville TN
 
Join Date: Nov 2012
Posts: 115
Mein Auto: 2002 525i sport, premium
OBD 2 codes...

I'm getting 4 codes through auto-zones scanner:

P0365 - camshaft position censor B circuit (bank 1)

P0491 - secondary air injection system (bank 1)

P0492 - secondary air injection system (bank 2)

P0430 - Catalyst system efficiency below threshold (bank 2)

As for the first code, I ordered a exhaust cam sensor last night, the O.E.M. Sensor that was 1/4 the price. I believe this code is irrelevant to the others.

My secondary air pump is working, or at least making noise. I have inspected the main line and the small line connected to the valve that runs along the back of the engine. I ordered a precat o2 sensor for bank 2, I just have heard mixed things about o2 sensors relating to SAP codes. Wanted to check with you guys and make sure I'm heading in the right direction. Thanks in advance -Sean
Reply With Quote
Ads by Google
  #2  
Old 02-10-2013, 02:20 PM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 8,879
Mein Auto: '97 540i 6 speed
How do you know the pump is feeding air into the exhaust manifolds? Common failure is a frozen valve.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #3  
Old 02-10-2013, 04:18 PM
SeanMH-6 SeanMH-6 is offline
Officially Welcomed to the 'Fest
Location: Clarksville TN
 
Join Date: Nov 2012
Posts: 115
Mein Auto: 2002 525i sport, premium
Quote:
Originally Posted by edjack View Post
How do you know the pump is feeding air into the exhaust manifolds? Common failure is a frozen valve.
i suppose i don't know. that valve along with new lines is my next stop after the o2 sensor. a while back i had both catalyst efficiency below threshold codes thrown, and i was worried it was my catalytic converters. but now that it is only one, i am suspicious the o2 sensor is bad and bank 1 was just on a bad day or something. i see on youtube methods to checking the valve, but @126k im finding that valve could probably use replacement anyways.
Reply With Quote
  #4  
Old 02-17-2013, 10:39 PM
SeanMH-6 SeanMH-6 is offline
Officially Welcomed to the 'Fest
Location: Clarksville TN
 
Join Date: Nov 2012
Posts: 115
Mein Auto: 2002 525i sport, premium
replaced pre cat o2 sensor along with exhaust cam sensor. drove for a couple hours straight and just got back with no SES light. also probably put about 50 miles of in town driving on the car before the 2 hour trip. ill post if anything changes, but i had the codes reset a couple times before i came to the o2 sensor conclusion and both times the SES light came on within 5 min of driving.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms