Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-26-2013, 01:39 PM
Rev_Dynamics Rev_Dynamics is offline
Revdynamics.net
Location: Plymouth, IN
 
Join Date: Jul 2011
Posts: 14
Mein Auto: Multiple...
Coolant leak out of different weep hole.

I have some coolant coming out of the water pump weep hole sporadically and leaving a small puddle when parked. Takes a month or so for the coolant low light to come on.

I know the timing cover weep hole is a sure sign of a bad coolant pipe but any ideas on the water pumps hole?




Last edited by Rev_Dynamics; 02-17-2013 at 10:19 AM.
Reply With Quote
Ads by Google
  #2  
Old 02-17-2013, 10:18 AM
Rev_Dynamics Rev_Dynamics is offline
Revdynamics.net
Location: Plymouth, IN
 
Join Date: Jul 2011
Posts: 14
Mein Auto: Multiple...
Any one have any idea about this hole? I believe its a one way bleed off but not sure. I can pressurize the cooling system with compressed air through it. Doesn't leak when I squeeze the radiator hose but believe it is while driving or when cooling down.
Reply With Quote
  #3  
Old 02-17-2013, 12:26 PM
KaileSvick KaileSvick is offline
Officially Welcomed to the 'Fest
Location: Tampa, FL
 
Join Date: Sep 2012
Posts: 378
Mein Auto: 2003 BMW 745Li
From what I've heard it's a failing water pump. I'm not 100% sure. Maybe someone else can chime in
__________________
Reply With Quote
  #4  
Old 02-17-2013, 05:13 PM
cmpcpro cmpcpro is offline
Officially Welcomed to the 'Fest
Location: SoCal
 
Join Date: Oct 2012
Posts: 801
Mein Auto: Nothing
Wp - I have an OEM one that is in perfect shape, has 46k on it, was installed by dealer.. I thought it was bad because of a noise that everyone on here said was pump ended up being the sec. air hose.. the bearing is in perfect condition, as is the rest. You can have for $40.. is not hard at all to install.

Last edited by cmpcpro; 02-17-2013 at 05:15 PM.
Reply With Quote
  #5  
Old 02-18-2013, 09:33 AM
Rev_Dynamics Rev_Dynamics is offline
Revdynamics.net
Location: Plymouth, IN
 
Join Date: Jul 2011
Posts: 14
Mein Auto: Multiple...
Quote:
Originally Posted by cmpcpro View Post
Wp - I have an OEM one that is in perfect shape, has 46k on it, was installed by dealer.. I thought it was bad because of a noise that everyone on here said was pump ended up being the sec. air hose.. the bearing is in perfect condition, as is the rest. You can have for $40.. is not hard at all to install.
Thanks for the response guys. So that's a sure sign of a bad water pump? If so I would be interested in yours. How many miles are on it?
Reply With Quote
  #6  
Old 02-18-2013, 09:36 AM
Rev_Dynamics Rev_Dynamics is offline
Revdynamics.net
Location: Plymouth, IN
 
Join Date: Jul 2011
Posts: 14
Mein Auto: Multiple...
Just found this for anyone in the future. http://www.flowkoolerwaterpumps.com/..._failures.html
Wp is definitely the problem. Very glad its not the coolant pipe. Halleluiah
Reply With Quote
  #7  
Old 02-19-2013, 05:08 AM
wucrew wucrew is offline
Registered User
Location: Toronto
 
Join Date: Jan 2012
Posts: 27
Mein Auto: 745Li
Had the same problem, Ordered a new WP just waiting for it in the mail.
http://www.bimmerfest.com/forums/sho...540&highlight=
Reply With Quote
  #8  
Old 04-26-2013, 01:58 PM
Louiscalderon Louiscalderon is offline
Registered User
Location: Covina,ca
 
Join Date: Mar 2013
Posts: 2
Mein Auto: 745li
Weep hole issue

I have the same issue right now!!! I got freaked out because I called it in to my b,w mechanic and he said that is the "other weep hole" issue.....thank God it looks like a water pump issue. I just changed the alternator, battery, coolant hoses, expansion tank, radiator. Should had changed the water pump! So it's a water pump failure?
Reply With Quote
  #9  
Old 04-26-2013, 02:00 PM
Louiscalderon Louiscalderon is offline
Registered User
Location: Covina,ca
 
Join Date: Mar 2013
Posts: 2
Mein Auto: 745li
Do you still have the water pump, I will buy it!
Reply With Quote
  #10  
Old 04-26-2013, 02:54 PM
Rev_Dynamics Rev_Dynamics is offline
Revdynamics.net
Location: Plymouth, IN
 
Join Date: Jul 2011
Posts: 14
Mein Auto: Multiple...
Quote:
Originally Posted by Louiscalderon View Post
I have the same issue right now!!! I got freaked out because I called it in to my b,w mechanic and he said that is the "other weep hole" issue.....thank God it looks like a water pump issue. I just changed the alternator, battery, coolant hoses, expansion tank, radiator. Should had changed the water pump! So it's a water pump failure?
Bummer! I just ordered a new water pump and thermostat so we will see. It will be in next week and I will update on here. I have gotten a stuck thermostat code twice.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms