Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 02-26-2013, 10:00 AM
DK540 DK540 is offline
Registered User
Location: USA
 
Join Date: Feb 2013
Posts: 9
Mein Auto: 99 540/6
Misfires after engine cleaning

Hey guys. New to the site and posting on a phone so it's hard to search. I recently cleaned my engine(99 540/6). I followed procedure and covered all electrical connections and the alternator. I sprayed engine brite on, let stand for 15 minutes, then sparingly misted the entire compartment making sure to stay away from those connections.

I let the car dry for a day, then drove it 3 times in 2 days, with it running great. Then I came out and started it, and got rough idle, coughing, stalling and CEL. I read the codes and they are misfire codes w/ fuel cut off for cylinders 3,4,7,8.

I popped the ignition coil covers, and their was no pooled water; however everything was damp. Since they are cheap, I was going to replace the spark plugs and boots for those cylinders and see if that cures my problem. If that doesn't work I'm guessing the next logical part would be the coils. Is their anything else that could cause my issues, and is my first course of action a prudent one?

Thanks for the help!
Reply With Quote
Ads by Google
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms