Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)

E30 (1982 - 1993)
God's Chariot. The E30 was produced primarily from 1982 through 1991. The cabriolet was the one exception which was produced through 1993.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-09-2013, 01:23 PM
Afredo Afredo is offline
Registered User
Location: Albany, NY
 
Join Date: Jan 2013
Posts: 41
Mein Auto: 1989 325i, 1995 525iT
tach, mpg gauge, radio and obc not working

Just started up and drove my 89 325i coupe for the first time in a while, usually start it up once a week during the winter, everything always worked fine until today. The tach, mpg gauge, radio and obc all are not working. Everything else works. I checked fuse #10 which controls everything but the radio, fuse seemed good but when I'd plug in a new fuse into that slot with the key on it'd "spark" like there was a short or something but didn't blow.the fuse. Help!!
Reply With Quote
Advertisement
  #2  
Old 03-09-2013, 10:32 PM
Afredo Afredo is offline
Registered User
Location: Albany, NY
 
Join Date: Jan 2013
Posts: 41
Mein Auto: 1989 325i, 1995 525iT
also noticed tonight neither dome light works when you put the switch to the "on at all times" position (neither ever worked on the position that should light them up when you opens the doors though)
Reply With Quote
  #3  
Old 03-09-2013, 10:49 PM
hornhospital's Avatar
hornhospital hornhospital is offline
D'oh, You kids!
Location: In the Grumpy Chair
 
Join Date: Jan 2008
Posts: 14,346
Mein Auto: 1995 318is / 1993 325is
Quote:
Originally Posted by Afredo View Post
also noticed tonight neither dome light works when you put the switch to the "on at all times" position (neither ever worked on the position that should light them up when you opens the doors though)
Start checking all the OTHER fuses. There are multiple fuses that are interconnected and protect more than one circuit. You got one blown somewhere.
__________________
Quotes to live by:
guessing gets expensive...drivinfaster
nothing is more expensive than a cheap BMW...c4harpe13

Ken Kanne, Silverhill, AL, E36 Forum Mod/Craigslist addict/Hoarder of all sorts of stuff
BMW-CCA #441426
1995 318is "Bebe"; 1993 325is "Elvira" 1985 635CSi "Katja" 1984 633CSi "Sylvia"
HAVE I HAD MY MEDS YET?

Reply With Quote
  #4  
Old 03-12-2013, 04:02 PM
marineman2 marineman2 is offline
Registered User
Location: Tucson
 
Join Date: Aug 2011
Posts: 25
Mein Auto: 85 325e
I think it's fuse 11 or 23? Check the owners manual, and check each one individually. I went through about 25 fuses while diagnosing an electrical problem with the radio, they can really suck.
Reply With Quote
  #5  
Old 04-04-2013, 04:32 AM
QDance QDance is offline
Registered User
Location: Norway
 
Join Date: Apr 2013
Posts: 1
Mein Auto: BMW 318i E30
Hi! I have the same problem.. Have you figured it out?
Reply With Quote
  #6  
Old 04-21-2013, 07:05 PM
15Michaeljoseph 15Michaeljoseph is offline
Registered User
Location: Massachusettes, USA
 
Join Date: Sep 2012
Posts: 29
Mein Auto: 1987 325is, 1997 328is
This just happened to me tonight!!!! right before my coolant started leaking everywhere....
I feel terrible
Please tell me what happened, or what fuse needs to get checked
Reply With Quote
  #7  
Old 04-21-2013, 08:00 PM
hornhospital's Avatar
hornhospital hornhospital is offline
D'oh, You kids!
Location: In the Grumpy Chair
 
Join Date: Jan 2008
Posts: 14,346
Mein Auto: 1995 318is / 1993 325is
Fix the coolant leak first, then worry about the dome light not working. DO NOT drive the car if it's leaking coolant at any more than a drip.
__________________
Quotes to live by:
guessing gets expensive...drivinfaster
nothing is more expensive than a cheap BMW...c4harpe13

Ken Kanne, Silverhill, AL, E36 Forum Mod/Craigslist addict/Hoarder of all sorts of stuff
BMW-CCA #441426
1995 318is "Bebe"; 1993 325is "Elvira" 1985 635CSi "Katja" 1984 633CSi "Sylvia"
HAVE I HAD MY MEDS YET?

Reply With Quote
  #8  
Old 04-23-2013, 12:51 PM
BigBoy740il's Avatar
BigBoy740il BigBoy740il is online now
Officially Welcomed to the 'Fest
Location: Arizona
 
Join Date: Jan 2012
Posts: 256
Mein Auto: 1989/1991 E30; 2000 E38
Have a similar current drain problem on my 91 325i. I disconnected the battery, connected a multimeter to the positive and negative battery cables, and set the meter to the continuity setting. If there is a short the meter will beep. Simply pull each fuse until the beeping stops. My fault was on the 7.5 amp fuse which controls the obc, tach, radio, and interior/trunk lights. I found a short in the trunk light circuit.
__________________


Big Boyz with Bad Toyz.
Reply With Quote
  #9  
Old 04-23-2013, 05:20 PM
15Michaeljoseph 15Michaeljoseph is offline
Registered User
Location: Massachusettes, USA
 
Join Date: Sep 2012
Posts: 29
Mein Auto: 1987 325is, 1997 328is
now that i think about it...

I was tinkering with the trunk light before all this happened to try and make it turn on and see if i needed a new bulb....
how can i fix that?

i replaced most of the fuses, and not only did i fix everything that went wrong, but both my fog lights work now

and btw, I fixed that hose no prob. 8 bucks at autozone
Reply With Quote
  #10  
Old 04-23-2013, 05:21 PM
15Michaeljoseph 15Michaeljoseph is offline
Registered User
Location: Massachusettes, USA
 
Join Date: Sep 2012
Posts: 29
Mein Auto: 1987 325is, 1997 328is
BTW fuses 20 and 21 i think were the real culprits if that helps anyone else with this problem
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E30 (1982 - 1993)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms