Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series

6 Series
The BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-18-2013, 07:34 AM
gebhardt gebhardt is offline
Registered User
Location: UK Liverpool
 
Join Date: Jan 2010
Posts: 19
Mein Auto: BMW 645 2005
Front PDC sensor removal

Hi all,
My 2004 645ci coupe keeps giving me a PDC fault.
Using INPA I have traced the fault to the front right centre sensor (error code 9E3A)
Has anyone changed one and if so do you have to remove the front bumper?

Thanks
Neil -G-
Reply With Quote
Ads by Google
  #2  
Old 03-18-2013, 07:47 AM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,723
Mein Auto: 2006 650 convertible!!!
you might be able to get to the two center PDC's by going through the grill. But the bumper takes about 10 minutes to remove, here is a link to a previous thread. In it is some info for you along with info on how to remove the bumper should you find it necessary.

http://www.bimmerfest.com/forums/sho...d.php?t=586841
Reply With Quote
  #3  
Old 03-18-2013, 09:03 AM
gebhardt gebhardt is offline
Registered User
Location: UK Liverpool
 
Join Date: Jan 2010
Posts: 19
Mein Auto: BMW 645 2005
Thumbs up

Thanks for the speedy reply will order a new sensor today and give it a go at the weekend.
Only problem is not sure if I can live with the bong bong till then.
Once again many thanks

Neil-G-
Reply With Quote
  #4  
Old 03-18-2013, 02:09 PM
HerbP HerbP is offline
Officially Welcomed to the 'Fest
Location: Georgia
 
Join Date: Jul 2009
Posts: 2,511
Mein Auto: 2005 645Ci & 2007 750Li
You can not get to the 2 center sensors, without removing the bumper cover. Is your PDC giving you a fault at startup, or beeping constantly? I just got through replacing my front wiring harness this weekend, for the same senor problem. The harness ohm out good, but replacing it fixed the problem. If you buy a new sensor, it needs to be the correct color. Painting them will add extra layers of paint, causing problems with the system. The wiring harness was 64.00.

Last edited by HerbP; 03-18-2013 at 02:33 PM.
Reply With Quote
  #5  
Old 03-19-2013, 02:27 AM
gebhardt gebhardt is offline
Registered User
Location: UK Liverpool
 
Join Date: Jan 2010
Posts: 19
Mein Auto: BMW 645 2005
Thanks for the reply I have ordered one from eBay should get it on Thursday.
Will have a go at changing it at the weekend UK weather permitting.

Cheers

Neil-G-
Reply With Quote
  #6  
Old 03-19-2013, 02:54 AM
645/333's Avatar
645/333 645/333 is offline
Michael
Location: uk
 
Join Date: Jun 2010
Posts: 1,160
Mein Auto: Black Sapphire BMW Z4 3L
You can reduce the volume of the ping in your Idrive!!
__________________

Does my bum look good in this !
Reply With Quote
  #7  
Old 03-19-2013, 06:04 AM
V8esp V8esp is offline
Registered User
Location: Chester UK
 
Join Date: Aug 2012
Posts: 57
Mein Auto: 645ci
Quote:
Originally Posted by gebhardt View Post
Thanks for the speedy reply will order a new sensor today and give it a go at the weekend.
Only problem is not sure if I can live with the bong bong till then.
Once again many thanks

Neil-G-
I have the same issue, so would be interested in an update when you're done - also where you get your sensor from

You can turn off the PDC via the idrive to get rid of the bong for now...
Reply With Quote
  #8  
Old 03-19-2013, 09:00 AM
gebhardt gebhardt is offline
Registered User
Location: UK Liverpool
 
Join Date: Jan 2010
Posts: 19
Mein Auto: BMW 645 2005
Hi V8esp tried turning off the pdc in I drive but still get the error bong when I start up.
I have ordered the sensor from eBay used real oem to get the required part number.
Will give you an update when I have fitted it but can't see it being before early next week.
Do you know which sensor has failed on your car?
I used INPA to trace my faulty sensor
I think the front looks easier than the rear to replace.

Cheers
Neil-G-
Reply With Quote
  #9  
Old 03-19-2013, 09:09 AM
V8esp V8esp is offline
Registered User
Location: Chester UK
 
Join Date: Aug 2012
Posts: 57
Mein Auto: 645ci
Hi,

I have plugged in INPA and get the same error as you - not sure where you reference the error code though but I think it's the corner sensor as I can't hear any clicking from that one when activated.

How much did the sensor set you back? and have you got the part no to had?

Cheers
Linc
Reply With Quote
  #10  
Old 03-19-2013, 10:16 AM
gebhardt gebhardt is offline
Registered User
Location: UK Liverpool
 
Join Date: Jan 2010
Posts: 19
Mein Auto: BMW 645 2005
Hi Linc
What colour is your car?
If you go into real oem and search for pdc the sensors are part no 2
They all end in a different number depending on the colour you require
Mine colour is sapphire black and I think off the top of my head it ended in 90
I got mine from eBay and got it for 20 including postage (new and in the box)
Let me know if you have a problem finding the part number you require.

Cheers

Neil-G-
Reply With Quote
  #11  
Old 03-20-2013, 03:05 PM
V8esp V8esp is offline
Registered User
Location: Chester UK
 
Join Date: Aug 2012
Posts: 57
Mein Auto: 645ci
Hi, it's titan silver, cant see any on ebay so may have to buy a plain one
and spray it!
Reply With Quote
  #12  
Old 03-21-2013, 07:04 AM
gebhardt gebhardt is offline
Registered User
Location: UK Liverpool
 
Join Date: Jan 2010
Posts: 19
Mein Auto: BMW 645 2005
Hi mate,

I have found one on ebay that will fit your car.
It is off a E60 but they are the same as the E63.
Sorry I dont know how to add a link so you will just have to follow the instructions below.
Go to ebay motor parts
Enter in the search bar BMW E60 pdc
If you scroll down to the ninth pdc that is the one you want.
You can either bid on it or pay the 34.99
I will be having a go at fixing mine next Thursday in work till then.
I will let you know how i get on.

Cheers

Neil -G-
Reply With Quote
  #13  
Old 03-28-2013, 05:14 AM
V8esp V8esp is offline
Registered User
Location: Chester UK
 
Join Date: Aug 2012
Posts: 57
Mein Auto: 645ci
Quote:
Originally Posted by gebhardt View Post
Hi mate,

I have found one on ebay that will fit your car.
It is off a E60 but they are the same as the E63.
Sorry I dont know how to add a link so you will just have to follow the instructions below.
Go to ebay motor parts
Enter in the search bar BMW E60 pdc
If you scroll down to the ninth pdc that is the one you want.
You can either bid on it or pay the 34.99
I will be having a go at fixing mine next Thursday in work till then.
I will let you know how i get on.

Cheers

Neil -G-
Hi Neil,

I ordered a plain black one in the end and sprayed it - 19, probably from the same guy as you. Anyway, just finished fitting this morning and it's all working fine - got my pdc working at last so I'm a happy man!!!

The one I replaced was a front offside corner - near the headlight washer...

It wasn't a bad job but probably not the best day to do it as its chuffin freezin - let me know how you get on and give me a shout if you need any help with bumper removal..

Linc
Reply With Quote
  #14  
Old 03-28-2013, 11:56 AM
gebhardt gebhardt is offline
Registered User
Location: UK Liverpool
 
Join Date: Jan 2010
Posts: 19
Mein Auto: BMW 645 2005
Hi Linc,
Made up to hear you got it working.
I have put mine on hold was going to do it today but it was freezing.
Might have a go at the weekend,
How long did it take you and was it easy to get the front bumper off.?
Did you take the bumper right off and ifso did you have to take out the fog lights

Cheers

Neil
Reply With Quote
  #15  
Old 04-02-2013, 02:00 AM
V8esp V8esp is offline
Registered User
Location: Chester UK
 
Join Date: Aug 2012
Posts: 57
Mein Auto: 645ci
Hi Neil,

The bumper was pretty easy to get off, took about 15 mins. You can get at all the bolts ok, just follow the instructions in the thread, otherwise you probably wouldn't know where to look. The trickiest screws are just inside the bumper. So, when you peel back the inner arch there are 2 screws just behind the headlight. When all the screws are out the bumper will just pull forward.

I didn't have to disconnect anything else as you can get to the sensors if you just rest the bumper on the floor.

Cheers
Linc
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms