Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Thread Tools Display Modes
Old 03-20-2013, 11:26 AM
mjk414 mjk414 is offline
Registered User
Location: pa
Join Date: Mar 2013
Posts: 1
Mein Auto: x5
ps door will not open, out of ideas

well, i have read many helpful forums to get me where im at but have run out of answers, please help if able.

04 x5, the door would only open from inside latch ,lock was inop while all other doors worked perfect, then it would not open at all, so i have the panel and everything off with door in shut position.

i still cannot find a way to open it, i pull on both handles using the inner cords and everything seems to be moving properly with the handles but will not release the door
Reply With Quote
Old 03-24-2013, 09:12 PM
Shogan Shogan is offline
Registered User
Location: Utah
Join Date: Feb 2013
Posts: 61
Mein Auto: '08 535xi or '02 X5
My 02 has needed the exterior door handle. Not the painted part but what that attaches to. I've replaced driver and passenger sides.
Reply With Quote
Old 03-25-2013, 07:20 AM
QSilver7's Avatar
QSilver7 QSilver7 is online now
Officially Welcomed to the 'Fest
Location: Northeast Indiana
Join Date: Aug 2008
Posts: 7,138
Mein Auto: 1997 740iL / 2006 X5 4.4
Item #18 in diagram below is the backside of the interior handle...#5 is the bowden cable that is attached to the handle on one end and the actuator (#1) on the other end. Item #4 is the operating rod.

So when you try to manually move the bowden cable...it does not move the operating rod upward? Have you tried disconnecting the electrical connector to the actuator and reconnecting it...or even replacing the actuator in case it's dead?

Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

Reply With Quote

Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

All times are GMT -7. The time now is 03:47 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
© 2001-2015 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms