Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

Reply
 
Thread Tools Display Modes
  #1  
Old 03-15-2013, 08:24 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
Launch Control~~HELP!!!

I just couldn't find the right answer so I decided to post an new thread and hope there is anyone who know about my issue. not really wanna do it, but at least I know my Z4 35i DCT have launch control and how to do it.
for 2009 Z4 35i 7speed DCT,currently 36k. I watched ppl did it from youtube and read my manual book before try it. so I know the basic.....
warm up already and drove at least 30min, sport+ mode switch to manual mode push to M1 depress brake and then depress accelerator all the way down....nothing happend, I just feel the car want to move and in 1000 RPM, everytime I depress accelerator when brake apply the car just want to move and can't go over 1000 rpm so I stop doing it, feel it is gonna hurt the drivetrain.
I watched one guy did it from youtube...when he switched to sport+ mode, in the small display of cluster have a car icon suddently he rev. up will change to checked flag, but for my z4, there's nothing happend when I switch to sport+ still just temp. and clock.......is that mean my car doesn't have this function???
Reply With Quote
Advertisement
  #2  
Old 03-16-2013, 07:25 AM
jparnes1 jparnes1 is offline
Officially Welcomed to the 'Fest
Location: Rochester, NY
 
Join Date: Dec 2009
Posts: 449
Mein Auto: 2011 Z4 35i, 2006 525xi
All E89's have this function. You're just not doing something correctly.
__________________
2006 525 xi, Orient Blue Metallic, Beige leather, Dark Poplar trim, Premium Package, Cold Weather Package

2012 Z4 35i, ED 2/24/12, Melbourne Red Metallic, Black leather, 6 MT, ///M Sport, Premium Package, Premium Sound Package, Cold Weather Package, Nav, Comfort Access, LED Angel Eyes, BMWPedals pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side marker, powder coated calipers, Extra Enjoyment Package
Reply With Quote
  #3  
Old 03-16-2013, 07:44 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
yeah.....so I need someone who could help me to find the answer, even the bwm mechanic don't know how to use it....maybe I was asking to the wrong mechanic guy.
Reply With Quote
  #4  
Old 03-17-2013, 08:30 AM
CeEl CeEl is offline
Registered User
Location: Chicago
 
Join Date: Jan 2012
Posts: 54
Mein Auto: not a Z4 just yet
Quote:
Originally Posted by Kai1122 View Post
yeah.....so I need someone who could help me to find the answer, even the bwm mechanic don't know how to use it....maybe I was asking to the wrong mechanic guy.

1. manual mode (Msomething will show up in the display)
2. sport +
3. press and hold brake
4. floor the throttle (all the way! kick down!)
Engine speed will rev to 4000 and hold there. Then you will see the checkered flag.
5. let go of the brake but keep the accelerator floored -- you will shift automatically -- hold on ... lot's of wheel spin

Don't underestimate how much warm up you need ... some say 6 miles driving is enough, with othes the temp has to be all the way to the regular operating temperature (middle of gauge). And it doesn't allow you to do it too often...
Reply With Quote
  #5  
Old 03-17-2013, 05:39 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
Mmmm..yeah temp is already around 230-240 and for 30 min. Driving.
Should I kick down the accelerator all the way down hard ?
Does it matter to switch to manual m1 and sport mode+ first or sports mode+ then manual m1? Or as long as in m1 gear and sport+ should be able to use launch control?...
Don't lknow...according to manual book say it won't let you use too soon and often once you launch the car in this way....maybe my car just not happy to let me do it all the time. Lol
Reply With Quote
  #6  
Old 03-17-2013, 07:37 PM
jparnes1 jparnes1 is offline
Officially Welcomed to the 'Fest
Location: Rochester, NY
 
Join Date: Dec 2009
Posts: 449
Mein Auto: 2011 Z4 35i, 2006 525xi
Ok first of all, if you've done LC once the car won't allow you to do it again until a certain amount of time has elapsed. If that's not the issue, then yes, you need to totally floor the accellerator past the kick down point
__________________
2006 525 xi, Orient Blue Metallic, Beige leather, Dark Poplar trim, Premium Package, Cold Weather Package

2012 Z4 35i, ED 2/24/12, Melbourne Red Metallic, Black leather, 6 MT, ///M Sport, Premium Package, Premium Sound Package, Cold Weather Package, Nav, Comfort Access, LED Angel Eyes, BMWPedals pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side marker, powder coated calipers, Extra Enjoyment Package
Reply With Quote
  #7  
Old 03-17-2013, 11:53 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
Tks. I might try it again later I floor the accelerator, but maybe not quick all the way down
Reply With Quote
  #8  
Old 03-18-2013, 05:36 AM
jcm12 jcm12 is offline
Officially Welcomed to the 'Fest
Location: Wickliffe, KY
 
Join Date: Dec 2011
Posts: 324
Mein Auto: 2012 Z4 35i--2002 330ci
Don't feel bad, I must be the dumbest person to ever order a Z. Got my 35i just about a year ago and I thought I had done enough research. I thought 2012 35i did not have LAUNCH and the 35is did. I guess I know what I'll be doing when it quits raining.
Reply With Quote
  #9  
Old 03-18-2013, 01:54 PM
airmarc airmarc is offline
Registered User
Location: Fort Lauderdale, FL
 
Join Date: Jan 2012
Posts: 51
Mein Auto: Z4 sdrive30i
Quote:
Originally Posted by jparnes1 View Post
All E89's have this function. You're just not doing something correctly.
I believe e89's with DCT have this function. Not all of them. Maybe Im wrong?
Reply With Quote
  #10  
Old 03-18-2013, 02:08 PM
jparnes1 jparnes1 is offline
Officially Welcomed to the 'Fest
Location: Rochester, NY
 
Join Date: Dec 2009
Posts: 449
Mein Auto: 2011 Z4 35i, 2006 525xi
My bad...you are correct. E89's with manual trannies (like mine) don't have LC.
__________________
2006 525 xi, Orient Blue Metallic, Beige leather, Dark Poplar trim, Premium Package, Cold Weather Package

2012 Z4 35i, ED 2/24/12, Melbourne Red Metallic, Black leather, 6 MT, ///M Sport, Premium Package, Premium Sound Package, Cold Weather Package, Nav, Comfort Access, LED Angel Eyes, BMWPedals pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side marker, powder coated calipers, Extra Enjoyment Package
Reply With Quote
  #11  
Old 03-18-2013, 02:50 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
Yeah. Traditional way is better. Less headache
But 7speed dct made me interested and give up my 9 years exp. Of driving manual car
I was alway prefer manual. But I still give some positive point for dct..at least I still not regret yet. Just miss to drive manual car sometime
Reply With Quote
  #12  
Old 03-18-2013, 02:59 PM
jcm12 jcm12 is offline
Officially Welcomed to the 'Fest
Location: Wickliffe, KY
 
Join Date: Dec 2011
Posts: 324
Mein Auto: 2012 Z4 35i--2002 330ci
Thanks for all the info guys. I do have DCT so I'm sure I'll have to try LC soon. Not something I plan on making a habit of though.
Reply With Quote
  #13  
Old 03-18-2013, 03:53 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
Please let me know if you make it happend and how.
Reply With Quote
  #14  
Old 03-18-2013, 04:16 PM
jcm12 jcm12 is offline
Officially Welcomed to the 'Fest
Location: Wickliffe, KY
 
Join Date: Dec 2011
Posts: 324
Mein Auto: 2012 Z4 35i--2002 330ci
Will do. I have scanned Launch Control section out of my manual. Please forgive poor quality. This is from my 2012 manual.
Attached Thumbnails
Click image for larger version

Name:	LC!.jpg
Views:	65
Size:	104.3 KB
ID:	367054  
Reply With Quote
  #15  
Old 03-19-2013, 03:38 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
ok...finally I got it. while I was driving to my friend's house and in front of his house I decided to give it a try.
exactly as manual book say....I think the most important part is to floor the accelerator and *** quick all the way down*** if I slowly depress accelerator won't actiave lanuch control
Reply With Quote
  #16  
Old 03-19-2013, 06:09 PM
CeEl CeEl is offline
Registered User
Location: Chicago
 
Join Date: Jan 2012
Posts: 54
Mein Auto: not a Z4 just yet
Quote:
Originally Posted by Kai1122 View Post
ok...finally I got it. while I was driving to my friend's house and in front of his house I decided to give it a try.
exactly as manual book say....I think the most important part is to floor the accelerator and *** quick all the way down*** if I slowly depress accelerator won't actiave lanuch control
And???? Did you like the experience?
Reply With Quote
  #17  
Old 03-19-2013, 06:24 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
Well...actually I just want to see if my launch control work so once I saw it rev up and show checked flag, that's it that's all I want to know if the function is working.
Beside I was in my friends community, don't wanna do stupid thing there but I pretty sure it must be fun and pull hard if I roll out
Reply With Quote
  #18  
Old 03-20-2013, 05:43 AM
jparnes1 jparnes1 is offline
Officially Welcomed to the 'Fest
Location: Rochester, NY
 
Join Date: Dec 2009
Posts: 449
Mein Auto: 2011 Z4 35i, 2006 525xi
Unbelievable! After all this, you didn't even do it?
__________________
2006 525 xi, Orient Blue Metallic, Beige leather, Dark Poplar trim, Premium Package, Cold Weather Package

2012 Z4 35i, ED 2/24/12, Melbourne Red Metallic, Black leather, 6 MT, ///M Sport, Premium Package, Premium Sound Package, Cold Weather Package, Nav, Comfort Access, LED Angel Eyes, BMWPedals pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side marker, powder coated calipers, Extra Enjoyment Package
Reply With Quote
  #19  
Old 03-20-2013, 11:19 AM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
Lol. But still happy that at least I found out the reason. Didn't have enough straight line over my friends community though.
Reply With Quote
  #20  
Old 03-20-2013, 12:36 PM
jcm12 jcm12 is offline
Officially Welcomed to the 'Fest
Location: Wickliffe, KY
 
Join Date: Dec 2011
Posts: 324
Mein Auto: 2012 Z4 35i--2002 330ci
Finally tried it and it does not work. My one year service is scheduled for 3/28, I told them I wanted this looked at also. Honestly its not so much that I would ever really use it, it's just I hate that I pay for something that does not work.
Reply With Quote
  #21  
Old 03-20-2013, 01:52 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
What's your situation? The machnic don't really know about it, they work for all kind of bmw but might not know all function have for specific one. I asked 2 bmw guys and they have no cule, one guy even told me "no don't have launch for this car" other machnic drove out my car and don't even know what was he doing,
Finally I realize and thanks the ppl here in this thread to gave me some useful information.
If you have done correctly by following the manual book. There is just one thing it didn't mention very clearly
Make sure you depress the brake and ""depress accelerator quick all the way down to the floor"""
Reply With Quote
  #22  
Old 03-20-2013, 04:13 PM
jcm12 jcm12 is offline
Officially Welcomed to the 'Fest
Location: Wickliffe, KY
 
Join Date: Dec 2011
Posts: 324
Mein Auto: 2012 Z4 35i--2002 330ci
Yes I did pedal down quickly because I read your "I got it" post many times. I just spoke with a lady in service at my nearest dealer (on the phone) after I realized it did not work. I politely mentioned a had two issues to discuss, first was to schedule my yearly service, second was LC not working. I would not be surprised to get the your car doesnt have it routine but time will tell. I have gone to the man who built the business, who sold it but is GM still, on a previous issue in order to get it resolved and might do this eventually on this situation. Like I said I drove the car for nearly a year without even knowing it had LC so it's not a huge deal in that sense. What I dont like if I personally sell the car or trade in to a different dealer then I feel obligated to tell them of this issue if it is not resolved. Yes I know a lot of people and all dealers would not tell me. I know I can be a jerk and am a bit touchy at times but I do consider myself to be pretty honest. Like I said time will tell. Sorry to ramble.
Reply With Quote
  #23  
Old 03-20-2013, 08:43 PM
Kai1122 Kai1122 is offline
Registered User
Location: Renton
 
Join Date: Mar 2013
Posts: 19
Mein Auto: Z4 35i
yeah, the LC is not really important, it just make you feel wanna have fun some time and pull harder off the line or impress ppl , with DCT and without LC it already give you good smooth and tire spin take off in sport+ if you depress accelerator hard.
but anyway..you should have LC too, maybe later you will realize or the car just not ready yet for some reason. as manual book say it can only use after break in and so it might just for some reason that computer just wont allow you to do it yet, but postive you should have this function as long as it is DCT.
Reply With Quote
  #24  
Old 03-28-2013, 02:48 PM
jcm12 jcm12 is offline
Officially Welcomed to the 'Fest
Location: Wickliffe, KY
 
Join Date: Dec 2011
Posts: 324
Mein Auto: 2012 Z4 35i--2002 330ci
Went in for my one year service today. Service guy and I went to an out of the way stretch of road and found out what I was doing wrong. I was putting it into maual with a flick of the downshift paddle. (When I hit either paddle it displays M). He had me put into Manual by moving stick to the left. (Which makes it display S). I had tried several times with the paddle and couldn't get it. I thought I had tried once with the stick but I guess not. So I can say now it DOES WORK!!! Man does it work. I highly recommend anyone with DCT to try it at least once. At exactly one year of Z ownership I will say that everything on the car works like it should. Couldn't say that on my 2010 328i.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 12:32 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms