Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-30-2013, 01:35 PM
marke7981 marke7981 is offline
Registered User
Location: oregon
 
Join Date: Jul 2011
Posts: 3
Mein Auto: Z3
automatic top probs....confused

Greetings,

Last fall my 2005 Z4 had it's top stop about 4 inches from the from the top and froze. I carefully helped it back down and then tried again and it did close...however the red light kept flashing. So jump to this spring now I have it out and ready to go the light is still flashing but the windows will not open nor will the top budge. I checked in the trunk and the lid is adjusted correctly and seems to to be making contact with the microswitch.
I tried the remote for the top and that will operate the windows but the top will still not move. Is there an easy solution for this??? Does this make sense to anybody else??? Any insight would be most appreciated. Thanks, Mark
Reply With Quote
Advertisement
  #2  
Old 04-02-2013, 05:14 PM
fastgaas fastgaas is offline
Registered User
Location: Palo Alto, CA
 
Join Date: Oct 2010
Posts: 33
Mein Auto: 2004 Z4
My recommendation is do a forum search on the Z4 top not working. There are some excellent posts and solutions that need not repeating.

It could be the switch, but the most common problem is the drains in the top pillar support tubs get clogged (did you ever clean them? didn't think so). In a decent rain the tubs (located in the car wall right behind the seats) fill with water. That would not normally be a problem except the hydraulic motor that drives the top is also located in the tub. You flood it a few times and it will bind up and fail. OK, it is a design flaw.

Happened to me. Top releases but hyd motor does not engage. Top opens a inch or two and light blicks.

Solution: You go to a dealer, he fixes it for $1000 to $2000. Or you follow the great instructions from Shipkiller on how to replace the top and replace the motor for a few hundred dollars (that is what I did)

Two years later my top works great and I always clean my drains.
Reply With Quote
  #3  
Old 04-03-2013, 05:35 AM
vintage42's Avatar
vintage42 vintage42 is offline
BMW CCA 1405
Location: Louisville, KY
 
Join Date: Jun 2007
Posts: 1,635
Mein Auto: 1997 BMW Z3 1.9 5MT
Quote:
Originally Posted by fastgaas View Post
... I always clean my drains.
How do you do that?
Reply With Quote
  #4  
Old 04-03-2013, 12:10 PM
Teacher Blind Teacher Blind is offline
Registered User
Location: Red Bluff, California
 
Join Date: Apr 2012
Posts: 44
Mein Auto: 2006 BMW Z4 3.0si
In the search box, type " clean soft top drains"
Go to the post entitled "05 z4 top motor prevention"

chickdr has a reply that will meet your needs
The post has a pdf file that gives excellent directions.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:03 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms