Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 04-06-2013, 03:38 PM
kz1911 kz1911 is offline
Registered User
Location: houma
 
Join Date: Aug 2012
Posts: 50
Mein Auto: 325i
rough idle and shutting off on cold start 03 325i

car shuts off on cold start, i disconnect the mass air sensor and starts fine, reconnect sensor runs ok but then slowly develops a rough idle
I am at this point about to pull my hair out, i have done the following:
CCV revamp
O2 sensors revamp.....sometimes i still get the O2 sensor codes, not sure why
vacuum lines revamp

what i think it could be:
old gasoline....car has been sitting for a while and gas might be old, i did add some new but perhaps mixture is bad
air leak maybe? ccv and vaccum lines were done but not sure


some suggestions ive seen:
bad fuel filter, dying fuel pump


if anyone knows or suggest something different please let me know, im just overwhelmed right now
Reply With Quote
Advertisement
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms