Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 04-13-2013, 11:10 AM
fitreddog fitreddog is offline
Registered User
Location: Alloa
 
Join Date: Apr 2013
Posts: 2
Mein Auto: X5 E53
Exclamation CD/Audio issues!!!!!!

Hi everyone, I'm looking for some help with my 2003 E53 3.0D Auto. When I bought it I never noticed a problem with the CD player (6 stacker in boot). The probel is that although its working, and recognising CD even appears to be playing them there is no sound.

I looked about a visited some forums, though I'd track down the problem to either being in the amp or in the radio module. Here come the other problem, most post about the radio say the radio module should be in the boot just in from of the battery on the left hand side but there is not one there on mine!!!!

I htink the only things in there are ABS, PDC and another module but nothing that looks like the radio in other pictures I've seen. Also should there be an amp on the left hand side under the multi disc player?Click image for larger version

Name:	BMW X5 E53 battery.jpg
Views:	57
Size:	110.6 KB
ID:	371192

Click image for larger version

Name:	13.04.13 014.jpg
Views:	51
Size:	125.2 KB
ID:	371193

Click image for larger version

Name:	13.04.13 012.jpg
Views:	54
Size:	86.1 KB
ID:	371194

I think I've managed to attatch some pictures.


I think at some point in the past there has been a sub fitted?

any thoughts

thanks for any help...
Reply With Quote
Advertisement
  #2  
Old 04-16-2013, 08:57 PM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 525
Mein Auto: BMW, Lotus, Porsche
If you have the CD Business player underneath the lid in the dash that is where your radio is. The radio in the boot is for the NAV people. Does the radio play? If the radio play it's not the amp. Do you have DSP? If you do the coaxial cable between the CD Chnager and the rear amp might have become dislodged. If you don't have DSP the 6-pin connector at the CD Changer might have become dislodge. Or you have a bad CD Changer.
Reply With Quote
  #3  
Old 04-18-2013, 08:02 AM
fitreddog fitreddog is offline
Registered User
Location: Alloa
 
Join Date: Apr 2013
Posts: 2
Mein Auto: X5 E53
thanks!

Thinks upallnight.

the CD player has a 6 pin in it.
I have a Tape player under the lid in the dash.
I don't think there is an ampin the boot.

this weekend I'll take the radio and tape player out fron the dash and check the connections there

thanks again for your help
Reply With Quote
  #4  
Old 04-18-2013, 08:05 AM
upallnight upallnight is offline
Officially Welcomed to the 'Fest
Location: Crook County
 
Join Date: Nov 2012
Posts: 525
Mein Auto: BMW, Lotus, Porsche
The amp is located underneath the CD Changer. You need to remove the CD changer to get to the amp.
Reply With Quote
Reply

Bookmarks

Tags
amplifier, audio install, cd player help, radio help


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms