Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X1 E84 (2011 - current)

X1 E84 (2011 - current)
The new to the US BMW X1 will arrive at BMW dealers in the fall of 2012 as a 2013 model year. Get your X1 28i with either sDrive (RWD) or xDrive (AWD) or get the US exclusive I6 N55 powered X1 35i dDrive.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-11-2012, 12:04 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
IPhone interface doesn't work

The car included an iPhone cable with both a USB and stereo iPhone adapter, which is supposed to be plug-and-play, allowing you to access the music on your phone via the stereo, but all i get is a "wrong cable" message displayed on the stereo. standard iPhone USB cable says the same thing (and dealer said that is supposed to work too. i tried with both the stereo jack and the USB jack, and neither work alone or together. the phone does get power from the USB jack though.

Anyone else having the same problem? i thought i remember reading something on this forum about that, but i can'y find anything on a search.
Reply With Quote
Ads by Google
  #2  
Old 09-11-2012, 01:40 PM
the_fox's Avatar
the_fox the_fox is offline
Custom User
Location: under the sun
 
Join Date: Jul 2006
Posts: 684
Mein Auto: X1
Just curious, why do you need a cable at all? Shouldn't this work wirelessly through Bluetooth?
__________________
Do not fold, staple, or mutilate. Void where prohibited.
Reply With Quote
  #3  
Old 09-11-2012, 08:14 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
Quote:
Originally Posted by the_fox View Post
Just curious, why do you need a cable at all? Shouldn't this work wirelessly through Bluetooth?
nope, maybe it does with the iDrive, but (even though that was also listed as "standard") we don't have it.

i plugged in a flash drive with some music on it and the stereo pulled it up just fine!
Reply With Quote
  #4  
Old 09-11-2012, 08:40 PM
MNX1024 MNX1024 is offline
Registered User
Location: No Idea
 
Join Date: Sep 2012
Posts: 16
Mein Auto: Probably an X1
Now this is starting to scare me. I'm planning to go drop down the deposit this Friday at the dealership and all of this is kind of discouraging me.
Reply With Quote
  #5  
Old 09-11-2012, 09:00 PM
kjboyd's Avatar
kjboyd kjboyd is offline
Drink the koolaid or else
Location: California
 
Join Date: Apr 2006
Posts: 2,097
Send a message via Yahoo to kjboyd
Mein Auto: 2009 MINI Cooper Clubman
What iPhone? And what software iOS? The cables are very temperamental.
__________________
Kevin


-----
2009 MINI Cooper Clubman - "Oxley"
Nightfire Red/NFR, Tuscan Leather, CP, PP, CW, Roof Rails & Aero Kit, 16" Bridge Spokes, Xenon, Auto, English Oak Trim & Wood Wheel, Alarm, Hi-Fi

-------

2007 Volvo S60 2.5T
2007 X3.0si PlatBronze/Beige
2006 X3 3.0i, Flamenco Red/Beige
1997 528iA, Oxford/Tan
1994 318iS, Black/Gray
1979 528iA, RubyRed, Tan
1971 2002, Sahara, Saddle
Reply With Quote
  #6  
Old 09-11-2012, 10:14 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
Quote:
Originally Posted by kjboyd View Post
What iPhone? And what software iOS? The cables are very temperamental.

iPhone 4S, OS 5.1.1

Using the supplied BMW "Video/audio adapter for Apple iPod/iPhone" cable SN 61-12-2-179-623
Reply With Quote
  #7  
Old 09-11-2012, 10:15 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
Quote:
Originally Posted by MNX1024 View Post
Now this is starting to scare me. I'm planning to go drop down the deposit this Friday at the dealership and all of this is kind of discouraging me.
it's called the new model blues...

i'm sure this iPhone thing will be worked out shortly
Reply With Quote
  #8  
Old 09-12-2012, 06:41 AM
mabrahams mabrahams is offline
Registered User
Location: FL
 
Join Date: Aug 2012
Posts: 27
Mein Auto: E30
The adapter is to control iPhone from wheel. You should be able to stream music via Bluetooth without the adapter.

http://www.bmwusa.com/Standard/Conte...a-51bfc4a0c532
(Yes this shows through iDrive, but it should still be the same function as non-iDrive models)

Also take a look at page 181 of the X1 drivers manual.

It was noted that if you have BMW Apps; the supplied cable doesn't work (but I'm not sure why the cable would be any different for BMW Apps?).

Last edited by mabrahams; 09-12-2012 at 06:54 AM.
Reply With Quote
  #9  
Old 09-12-2012, 10:24 AM
the_fox's Avatar
the_fox the_fox is offline
Custom User
Location: under the sun
 
Join Date: Jul 2006
Posts: 684
Mein Auto: X1
They'll have to come up with a new cable/adapter for iPhone 5 folks as well...
__________________
Do not fold, staple, or mutilate. Void where prohibited.
Reply With Quote
  #10  
Old 09-12-2012, 10:36 AM
mabrahams mabrahams is offline
Registered User
Location: FL
 
Join Date: Aug 2012
Posts: 27
Mein Auto: E30
The new iPhone will have a new adapter to old adapter dongle; shouldn't be a problem.
Reply With Quote
  #11  
Old 09-12-2012, 02:27 PM
Justin@NCBMW Justin@NCBMW is offline
'Fest Sponsor
Location: SoCal
 
Join Date: Jun 2012
Posts: 896
Mein Auto: MY13 X5 50i
Quote:
Originally Posted by stary View Post
The car included an iPhone cable with both a USB and stereo iPhone adapter, which is supposed to be plug-and-play, allowing you to access the music on your phone via the stereo, but all i get is a "wrong cable" message displayed on the stereo. standard iPhone USB cable says the same thing (and dealer said that is supposed to work too. i tried with both the stereo jack and the USB jack, and neither work alone or together. the phone does get power from the USB jack though.

Anyone else having the same problem? i thought i remember reading something on this forum about that, but i can'y find anything on a search.
Does your X1 have navigation? If yes use your own white "apple" cable
__________________
Justin W.
Lease Portfolio/ED Manager
New Century BMW ~ 7 Time Center of Excellence recipient 2013 PIA winner

1139 W Main St Alhambra, CA 91081

(800) 286-4269 Main Office
(626) 570-8444 ext. 4675


Click here to email me!


BMW i3s in stock

Last edited by Justin@NCBMW; 09-12-2012 at 02:31 PM.
Reply With Quote
  #12  
Old 09-12-2012, 05:35 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
Quote:
Originally Posted by mabrahams View Post
The adapter is to control iPhone from wheel. You should be able to stream music via Bluetooth without the adapter.

http://www.bmwusa.com/Standard/Conte...a-51bfc4a0c532
(Yes this shows through iDrive, but it should still be the same function as non-iDrive models)

Also take a look at page 181 of the X1 drivers manual.

It was noted that if you have BMW Apps; the supplied cable doesn't work (but I'm not sure why the cable would be any different for BMW Apps?).
Thanks, I already read the manual and the phone syncs to make calls via Bluetooth but not music. There is nomusic choice on the non I Drive stereo
Reply With Quote
  #13  
Old 09-12-2012, 05:37 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
Quote:
Originally Posted by Justin@NCBMW View Post
Does your X1 have navigation? If yes use your own white "apple" cable
No IDrive so now nav.. thought IDrive was standard when I bought the car...tried regular iPhone cable and it doesn't work either
Reply With Quote
  #14  
Old 09-12-2012, 06:51 PM
mabrahams mabrahams is offline
Registered User
Location: FL
 
Join Date: Aug 2012
Posts: 27
Mein Auto: E30
Ok... Did you try a shutdown of the phone and reboot it? Then remove both the USB and Headphone jack, plug it back in, connect the iPhone?
Reply With Quote
  #15  
Old 09-12-2012, 07:29 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
Quote:
Originally Posted by mabrahams View Post
Ok... Did you try a shutdown of the phone and reboot it? Then remove both the USB and Headphone jack, plug it back in, connect the iPhone?
yeah, also, i deleted the phone from the sync with the car and then re-sync'ed it. it still says wrong cable. interesting tidbit is that the USB reading says "iPhone" when i attach the USB cable, instead of "USB"
Reply With Quote
  #16  
Old 09-13-2012, 09:38 AM
mabrahams mabrahams is offline
Registered User
Location: FL
 
Join Date: Aug 2012
Posts: 27
Mein Auto: E30
I'd go back to the dealer and request a new cable.
Reply With Quote
  #17  
Old 09-13-2012, 02:20 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
talked with dealer and they don't know what's going on ... anyone else out there have the same problem?

Recap: cannot access music on iPhone through stereo via USB cable supplied by BMW
Reply With Quote
  #18  
Old 09-13-2012, 03:31 PM
kjboyd's Avatar
kjboyd kjboyd is offline
Drink the koolaid or else
Location: California
 
Join Date: Apr 2006
Posts: 2,097
Send a message via Yahoo to kjboyd
Mein Auto: 2009 MINI Cooper Clubman
Silly question... You DO HAVE music on the phone right?

Try this. Turn everything off. Not just sleep the phone but powered completely off. Then connect it all. Turn on phone. Wait for it to boot up. Does it show connect ON THE PHONE?, then turn on car. Then turn on radio and chose the mode button and go to iPod/phone.
__________________
Kevin


-----
2009 MINI Cooper Clubman - "Oxley"
Nightfire Red/NFR, Tuscan Leather, CP, PP, CW, Roof Rails & Aero Kit, 16" Bridge Spokes, Xenon, Auto, English Oak Trim & Wood Wheel, Alarm, Hi-Fi

-------

2007 Volvo S60 2.5T
2007 X3.0si PlatBronze/Beige
2006 X3 3.0i, Flamenco Red/Beige
1997 528iA, Oxford/Tan
1994 318iS, Black/Gray
1979 528iA, RubyRed, Tan
1971 2002, Sahara, Saddle

Last edited by kjboyd; 09-13-2012 at 07:56 PM.
Reply With Quote
  #19  
Old 09-13-2012, 10:23 PM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
Quote:
Originally Posted by kjboyd View Post
Silly question... You DO HAVE music on the phone right?

Try this. Turn everything off. Not just sleep the phone but powered completely off. Then connect it all. Turn on phone. Wait for it to boot up. Does it show connect ON THE PHONE?, then turn on car. Then turn on radio and chose the mode button and go to iPod/phone.

yes there is music! i've tried playing it while connecting.

I tried your idea with iPhone restart and no dice. tried it with the BMW cable (usb, stereo jack alone, plus stereo and USB together), and the standard iPhone cable.

anyone else having this problem??? i guess we're the only ones on this forum with a non-iDrive X1 trying to sync music so far!
Reply With Quote
  #20  
Old 09-14-2012, 03:23 AM
x3brian x3brian is offline
Officially Welcomed to the 'Fest
Location: Sacramento CA
 
Join Date: Jan 2011
Posts: 989
Mein Auto: X3
You might need a different cable.

I had a similar problem with my non I drive e88 (which audio is essentially the same as your e84) when I converted to the 4s although my issue was charging related.

I needed this:

http://www.shopbmwusa.com/ProductDet...ProductId=3241

Worth a try to ask the dealer.

Last edited by x3brian; 09-14-2012 at 03:44 AM.
Reply With Quote
  #21  
Old 09-18-2012, 10:52 AM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
dealer sent a new cable he tested on another car in the lot... if that doesn't work then it's our phone or the car
Reply With Quote
  #22  
Old 09-21-2012, 11:43 AM
stary stary is offline
Registered User
Location: redwood city
 
Join Date: Jun 2012
Posts: 99
Mein Auto: pending...
Got the new USB cable from the dealer and the interface works now!
__________________
2013 X1 sDrive 28i, M-Sport package, Mineral Grey
Reply With Quote
  #23  
Old 04-18-2013, 03:22 PM
Scolty Scolty is offline
Registered User
Location: NL
 
Join Date: Apr 2013
Posts: 1
Mein Auto: NL
Quote:
Originally Posted by stary View Post
Got the new USB cable from the dealer and the interface works now!

Heey got the same problem.

Wich cable do you got now?

Greetz
Reply With Quote
  #24  
Old 04-18-2013, 04:22 PM
eric9610 eric9610 is offline
Officially Welcomed to the 'Fest
Location: Irvine
 
Join Date: Feb 2013
Posts: 214
Mein Auto: '13 X1 35
I have idrive and Nav along with my Iphon 5, i can stream the music over Bluetooth or use my white cable to connect my phone to BMW APPS.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X1 E84 (2011 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms