Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 01-26-2013, 01:15 PM
desertviking desertviking is offline
Registered User
Location: Palm Springs
 
Join Date: Mar 2012
Posts: 17
Mein Auto: 2006 X5 4.4
2006 X5 HID low beam not working

Hi THere,
Hopefully there is someone here that can help me.
I recently installed non-OEM HID bulbs. I went for the 6000's rather than the 4300K.
Worked fine until a week ago the little green light next to the switch started to blink.
I kept driving and now the driver side bulb won't come on, but the little green light stopped blinking. So today I installed the original good bulb that I have saved. Still didn't come on. So I am thinking: Ballast etc. However here is the kicker: when I pull the left stalk on the steering wheel to make the light come on temporarily like they are supposed to, both lights come on every time.
I did go through a high pressure water car wash right before the green light started to come on.
Any ideas?

Lars
Reply With Quote
Advertisement
  #2  
Old 01-26-2013, 01:52 PM
boramkiv's Avatar
boramkiv boramkiv is offline
Propellers Up Front
Location: Chesapeake, VA
 
Join Date: Jan 2011
Posts: 1,955
Mein Auto: Some Bavarian car outside
Needs to be hooked up to check codes. A blinking green light indicates a problem with the adaptive lighting. Seems like you need a new light module especially since they are lighting for 40 seconds as pathway lighting. That eliminates bulb ballast igniter. These are all options though as codes need to be read for better analysis. Find an independent mechanic which specializes in BMW.
Reply With Quote
  #3  
Old 01-26-2013, 07:00 PM
desertviking desertviking is offline
Registered User
Location: Palm Springs
 
Join Date: Mar 2012
Posts: 17
Mein Auto: 2006 X5 4.4
Ok, so I got it working again.
I disconnected the battery for about 30 min, cause I figured that the computer needed to be reset. Now everything is working including the adaptive system. I figure that moisture started this problem. The lower screws are stripped on the cover. Lets see if it holds up.
Thanks for the reply.
Reply With Quote
  #4  
Old 04-15-2013, 07:41 PM
jett jett is offline
Registered User
Location: Ontario, Canada
 
Join Date: Apr 2013
Posts: 5
Mein Auto: 2002 X5 4.4i Sports
My low beam bulb burnt too. I know it's D2S, but don't know the power is 35w or 55w? when I buy online there are 4 options which one match the 2002 x5 e53?
1. Signature Series (35w)
2. Power Series (55w)
3. Stealth Series (Slim)
4. Volt Canbus Series (Premium)
Reply With Quote
  #5  
Old 04-20-2013, 08:20 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 6,170
Mein Auto: 1997 740iL / 2006 X5 4.4
Quote:
Originally Posted by jett View Post
My low beam bulb burnt too. I know it's D2S, but don't know the power is 35w or 55w? when I buy online there are 4 options which one match the 2002 x5 e53?
1. Signature Series (35w)
2. Power Series (55w)
3. Stealth Series (Slim)
4. Volt Canbus Series (Premium)
Did you look up the bulb in the part database (like realoem.com or bmwfans.info)? The wattage of the bulb is usuallly given in the "SUPPLEMENTAL" column...plus you get the BMW 11 digit part nbr which also helps in finding the correct part.
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
  #6  
Old 04-20-2013, 02:26 PM
jett jett is offline
Registered User
Location: Ontario, Canada
 
Join Date: Apr 2013
Posts: 5
Mein Auto: 2002 X5 4.4i Sports
Thanks. got it.
Reply With Quote
Reply

Bookmarks

Tags
hid bulb, low beam malfunction


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms