Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 04-08-2013, 01:24 PM
martindaman martindaman is offline
Registered User
Location: Denmark
 
Join Date: Apr 2013
Posts: 26
Mein Auto: 1989 BMW 525i M50
BMW 525i E34 Central Lock problem

Hey bimmerfest!

I kinda have a small problem with my e34.. It seems that the central lock doesn't work

It just doesn't do anything when i turn the key, besides locking the door that the key is in.. But if i lock it from the passenger door it also locks the tank/fuel cover this is a bit annoying, I've checked all the fuses (both in the front and under the backseat) and they all look fine, is this a common problem and do any of you know the solution to this ?
The only way to lock/unlock the backdoors is by pushing the pin.



The car is an
1989 Bmw e34 Saloon
M50b25 engine non vanos

It would be great if you would help me out

Best Regards: Martin Mortensen
Reply With Quote
Advertisement
  #2  
Old 04-08-2013, 05:02 PM
south26 south26 is offline
Officially Welcomed to the 'Fest
Location: Dayton, OH
 
Join Date: May 2009
Posts: 805
Mein Auto: 535i 1989
Sounds like a bad actuator. They are easy to replace, if you were closer I would offer to sell you one.


Andy
Reply With Quote
  #3  
Old 04-09-2013, 02:10 AM
martindaman martindaman is offline
Registered User
Location: Denmark
 
Join Date: Apr 2013
Posts: 26
Mein Auto: 1989 BMW 525i M50
Thanks for the reply.. I'll check it out this afternoon!
Reply With Quote
  #4  
Old 04-09-2013, 03:00 AM
_Ethrty-Andy_'s Avatar
_Ethrty-Andy_ _Ethrty-Andy_ is offline
E34 Converted E30 Fanatic
Location: Humble New Zealand
 
Join Date: Nov 2008
Posts: 6,140
Send a message via MSN to _Ethrty-Andy_
Mein Auto: E34 Touring AC Schnitzer
so let me get this straight, it works from the passenger door and the boot/trunk? but not the drivers door? yes will be a worn actuator that sneces where the key is in the door.

mine did the same about 6 weeks ago, was giving me grief so took it all apart, just a connector had fallen off i must not have clipped it up properly
__________________

E30 above Sold

E34 V12 Project Thread Here: http://www.bimmerfest.com/forums/sho...=502437&page=4
Last updated 2nd January 2014
Reply With Quote
  #5  
Old 04-09-2013, 03:46 AM
martindaman martindaman is offline
Registered User
Location: Denmark
 
Join Date: Apr 2013
Posts: 26
Mein Auto: 1989 BMW 525i M50
Yep! That's how it is.. It only locks the passenger door and boot/trunk.. Can't unlock the passenger door though. But I'll take the door apart today and see if its just a connector or some like that.
Reply With Quote
  #6  
Old 04-11-2013, 11:25 AM
WC5150 WC5150 is offline
South East Area*562*
Location: Norwalk,CA
 
Join Date: Sep 2012
Posts: 13
Mein Auto: 1995 525i
I had the same problem one time, only, not only did the locking system not work, but my car wouldn't start! All I did to fix the problem was I disconnected the battery terminals for 2 seconds and hooked them back up! So I think all I did was reset the system? But it worked!!!
Reply With Quote
  #7  
Old 04-19-2013, 01:45 AM
martindaman martindaman is offline
Registered User
Location: Denmark
 
Join Date: Apr 2013
Posts: 26
Mein Auto: 1989 BMW 525i M50
the thing is the car starts probably. but can it be a sensor ? while driving it says my door is open all the time ? Or is this not related..
But im pretty sure it's a connector, or maybe the central lock relay, but then the lock on the right side wouldnt lock the gas cover.
Oh well i got a free central lock relay, trying to switch it today. And look for problems with the connectors.
Thx for the reply's guys!
Reply With Quote
  #8  
Old 04-20-2013, 09:00 AM
HipMusic Man HipMusic Man is online now
Registered User
Location: minnesota
 
Join Date: Mar 2013
Posts: 30
Mein Auto: '89 535i
WC that was the anti-theft. By doing the reset by battery like that it also reset the anti-theft.

Check the actuators in the doors for the locks. the bracket holding the actuator in my driver side door broke somehow. So unlocking it was a nightmare. If yours are broke you can use zip ties for now making sure they're not in the way of the window brackets moving up and down. Then get a new bracket. They are a pain to install from the looks of them but that's what I would do.

If its not the brackets look at the central locking control module. I believe its under the back seat but im not sure with your car. The manual might have something for that. The door latch button affects the central locking. My 535i has a viper remote start and keyless entry that I installed and I found out a lot of compontents in the car interact with the central locking. Even my sunroof and windows roll up when the doors are locked. thats my favorite feature.

Sent from my SGH-T989 using Bimmer App

Last edited by HipMusic Man; 04-20-2013 at 09:03 AM.
Reply With Quote
  #9  
Old 04-20-2013, 11:28 AM
Larrick Larrick is offline
Officially Welcomed to the 'Fest
Location: Berkeley California
 
Join Date: Sep 2009
Posts: 595
Mein Auto: 1994 525it
There is a little known function with the e34 locking system.
It is mentioned in the Owners manual. I actually locked myself inside a 525it in the parking lot
of a "Pick and Pull" in California. It was embarrassing as I had to be aided by AAA wedging open
the door so I could hand the key out to be rescued.
The car would not star either. It is some kind of security locking system.
The Manual warns not to do it with people in the car!
We think that my son inadvertently did something to the passenger side lock while we were loading
our Pick and Pull treasures.
It is just something to think about but I believe you have a bad accuator.
Reply With Quote
  #10  
Old 04-20-2013, 03:01 PM
HipMusic Man HipMusic Man is online now
Registered User
Location: minnesota
 
Join Date: Mar 2013
Posts: 30
Mein Auto: '89 535i
Quote:
Originally Posted by Larrick View Post
There is a little known function with the e34 locking system.
It is mentioned in the Owners manual. I actually locked myself inside a 525it in the parking lot
of a "Pick and Pull" in California. It was embarrassing as I had to be aided by AAA wedging open
the door so I could hand the key out to be rescued.
The car would not star either. It is some kind of security locking system.
The Manual warns not to do it with people in the car!
We think that my son inadvertently did something to the passenger side lock while we were loading
our Pick and Pull treasures.
It is just something to think about but I believe you have a bad accuator.
Werent you able to just unlock it by pulling up on the door lock?



Sent from my SGH-T989 using Bimmer App
Reply With Quote
  #11  
Old 04-20-2013, 04:45 PM
Larrick Larrick is offline
Officially Welcomed to the 'Fest
Location: Berkeley California
 
Join Date: Sep 2009
Posts: 595
Mein Auto: 1994 525it
Believe me ..I was locked inside a car. The owner of the tow company came down just to see the moron stuck in his car.
He joked that he should have brought a blonde wig for me to have his picture taken with me. I was the laughing stock of the
tow company. the owner is a well known race car driver in the area.
The first thing the AAA guy asked me was to lift the door lock. They all regarded me as an idiot.
THe mini-jaws of life was needed to get the keys out of the car.
Read the owners manual for details of the locking system if you don't believe me.
Reply With Quote
  #12  
Old 04-20-2013, 06:46 PM
HipMusic Man HipMusic Man is online now
Registered User
Location: minnesota
 
Join Date: Mar 2013
Posts: 30
Mein Auto: '89 535i
Facinating. Good story though. Lol

Sent from my SGH-T989 using Bimmer App
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms