Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)

F10 / F11 (2011 - Current)
The new chapter in the highly successful story of the BMW 5 Series Sedan (F10) and wagon (F11)

Reply
 
Thread Tools Display Modes
  #1  
Old 03-27-2012, 09:36 AM
BMWGlock BMWGlock is offline
Registered User
Location: Virginia
 
Join Date: Mar 2012
Posts: 3
Mein Auto: 2011 BMW 528i
Navigation arrows display in dash even after trip is over (back in car).

I've noticed when I use the navigation that after I get back in the car, often the trip may not have realized we made it, so I "stop guidance." Yet, the arrows still show in the dash display as if it is still pointing to the destination. Only if I enter a new destination, then "stop guidance" to that trip, will the arrows go away. (They reset the arrows for the new trip and then stop when I stop guidance.)

Is this a glitch just to me or something in the system? Any way to resolve?

Thank you.
Reply With Quote
Advertisement
  #2  
Old 03-27-2012, 09:44 AM
radarguy radarguy is offline
Officially Welcomed to the 'Fest
Location: Connecticut
 
Join Date: Feb 2010
Posts: 813
Mein Auto: 2011 535ix; 2015 X5 35ix
Doesn't make sense to me, but that's the way it works.
Reply With Quote
  #3  
Old 03-27-2012, 10:34 AM
Die Wolfe's Avatar
Die Wolfe Die Wolfe is offline
Officially Welcomed to the 'Fest
Location: Northern California
 
Join Date: Jan 2012
Posts: 1,050
Mein Auto: '12 535i Msport/'13 X5M
Quote:
Originally Posted by BMWGlock View Post
I've noticed when I use the navigation that after I get back in the car, often the trip may not have realized we made it, so I "stop guidance." Yet, the arrows still show in the dash display as if it is still pointing to the destination. Only if I enter a new destination, then "stop guidance" to that trip, will the arrows go away. (They reset the arrows for the new trip and then stop when I stop guidance.)

Is this a glitch just to me or something in the system? Any way to resolve?

Thank you.
That happened to me once so far...I figured it was no big deal and had to reset. When I drove my car later after restarting, it was gone.
__________________
2013 BMW X5///M
2012 BMW 535i M Sport

2008 Chevy Trailblazer SS (Sale pending)
1971 Buick Skylark
Reply With Quote
  #4  
Old 03-27-2012, 10:50 AM
Gran Turismo's Avatar
Gran Turismo Gran Turismo is offline
Alpina Addict
Location: Switzerland
 
Join Date: Aug 2006
Posts: 1,352
Mein Auto: '11 Alpina B5 Biturbo
It's a glitch, you'll find several threads about this on various BMW forums. Some argue it's a feature, so the driver notices that the car is parked in some distance to the actual destination...

Workarounds:
1. As already mentioned, choose a new destination and cancel again
2. Stop guidance via voice command shortly before reaching the destination
__________________
Current: 2011 Alpina B5 Biturbo Saloon
Retired: 2007 650i SMG Coupe


"Really skilled drivers have smashed bugs on their side windows too" - Walter Röhrl
Reply With Quote
  #5  
Old 03-27-2012, 10:51 AM
Mr. Grumpy's Avatar
Mr. Grumpy Mr. Grumpy is offline
BMW Freak
Location: NOLA, but my heart is in SoCal
 
Join Date: Aug 2011
Posts: 259
Mein Auto: 2011 535i
Quote:
Originally Posted by Die Wolfe View Post
That happened to me once so far...I figured it was no big deal and had to reset. When I drove my car later after restarting, it was gone.
Same here.
__________________

2011 535i (07/2011 build) Imperial Blue, Oyster/Black Interior, Anthracite Wood Trim, ZSP, ZPP, ZP2, ZCV, 2TB, 6NF, 6NR.

Retired: 2009 328i,Titanium Silver, Black Interior, Dark Wood Trim, ZPP, ZLP, 609, 494, AAW Tune.

Reply With Quote
  #6  
Old 03-27-2012, 08:11 PM
apw2607 apw2607 is offline
Officially Welcomed to the 'Fest
Location: Seattle
 
Join Date: Jun 2005
Posts: 484
Mein Auto: 2009 X5 35d
Quote:
Originally Posted by Mr. Grumpy View Post
Same here.
Yea. It's not isolated to the new 5 either. Same on the x5 with HUD. Arrow never goes away even after destination is reached. I say its a bug.
Reply With Quote
  #7  
Old 03-27-2012, 10:27 PM
kc1953 kc1953 is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Feb 2012
Posts: 478
Mein Auto: 2012 535i.
Quote:
Originally Posted by BMWGlock View Post
I've noticed when I use the navigation that after I get back in the car, often the trip may not have realized we made it, so I "stop guidance." Yet, the arrows still show in the dash display as if it is still pointing to the destination. Only if I enter a new destination, then "stop guidance" to that trip, will the arrows go away. (They reset the arrows for the new trip and then stop when I stop guidance.)

Is this a glitch just to me or something in the system? Any way to resolve?

Thank you.
Main Menu/Settings/Info Display: uncheck Navigation

That should get rid of the persistent arrow and distance from destination.
__________________
2012 535i, black sapphire metallic, oyster/black dakota, premium, premium sound, technology, sport, sport auto, heated front seats.
Reply With Quote
  #8  
Old 04-22-2013, 08:06 AM
jeffpiazza jeffpiazza is offline
Registered User
Location: Boston area
 
Join Date: Mar 2013
Posts: 1
Mein Auto: 2013 535i xDrive
I'm having this same issue on my 2013 F10.

Actually, I've also noticed that if I get to the screen showing the current or last destination, the choice offered is "Start Navigation," implying that at least on the main screen, the system is aware that it's no longer supposed to be providing guidance.

Where do I file a bug report with BMW? It's disappointing that the software went to production with such a glaring defect.
Reply With Quote
  #9  
Old 04-22-2013, 04:51 PM
playdrum's Avatar
playdrum playdrum is offline
Enthusiast
Location: New Jersey
 
Join Date: Mar 2013
Posts: 196
Mein Auto: 2013 535xi M-Sport
I'm able to get rid of it by hitting the button on the turn single lever.
__________________
__________________


2013 535xi M-Sport | Alpine White/Black Dakota Leather/Hexagon Trim | Premium | Cold | Technology | Driver Assistance | Sport Transmission | Sport Seats | Premium hi-fi
Prior: 2011 535xi Sedan | Titanium Silver/Black Dakota Leather | Sport Package | Premium | Cold | Nav | Sport Transmission | Sirius | PDC
Prior: 2009 528xi Sedan | Monaco Blue/Cream Leather | Premium | Cold | Nav | Sirius | Xenon
Prior: 2006 330xi Sadan | Alpine White/Sand Leather | Premium | Cold | Nav

Reply With Quote
  #10  
Old 04-22-2013, 05:48 PM
Needsdecaf's Avatar
Needsdecaf Needsdecaf is offline
Everything's Bigger in TX
Location: The Woodlands, TX
 
Join Date: Sep 2006
Posts: 7,106
Mein Auto: 2007 MDX
Quote:
Originally Posted by playdrum View Post
I'm able to get rid of it by hitting the button on the turn single lever.
Usually it comes back.
__________________
2011 535i
Sophisto Grau / Oyster - Black Nappa, Anthracite Wood Gone but not forgotten.

Heaven is where the police are British, the cooks are French, the cars are German, the lovers are Italian and it is all organised by the Swiss.

Hell is where the police are German, the cooks are English, the cars are French, the lovers are Swiss, and it is all organised by the Italians
Reply With Quote
  #11  
Old 04-22-2013, 06:13 PM
markl53's Avatar
markl53 markl53 is offline
bimmerfest Supporting Member
Location: Gaithersburg, MD
 
Join Date: Nov 2004
Posts: 5,330
Mein Auto: 2011 535i
Just push the MFD button on the stalk and it goes away, once you disengage nav and the arrow comes back the first time. Cycle through the various displays and it's gone. NBD to me.
__________________
BMW-CCA
Bimmerfest Supporting Member



2014 535i Individual | Azurite Black/Amaro Brown Merino | Premium | Cold | PDC | Rear Camera | Anthracite Hdr
Prior: 2011 535i AT | Black Sapphire/Cinnamon | Premium | Heated Sts | Nav | Sirius | Anthracite Hdr & Trim
Prior: 2008 335i 6MT Sedan | Black Sapphire/Terra Leather | Premium | Cold | CA | OEM Alarm
Prior: 2005 330i 6MT | Black Sapphire/Sand Leather | Premium | Cold | UGO | OEM Alarm
Reply With Quote
  #12  
Old 04-22-2013, 08:08 PM
dbs600 dbs600 is offline
Officially Welcomed to the 'Fest
Location: New York, NY
 
Join Date: Apr 2010
Posts: 2,411
Mein Auto: 2011 750LXi Individual
Yes, this is absolutely a defect / bug / glitch in the design of the navigation / iDrive system software for the Fxx chassis models. You can tell it's not normal because the arrow remains not only on the navigation / iDrive screen, but also on the instrument cluster display, not to mention the weird grey background. When I first got my car, I was exceptionally annoyed and couldn't believe how BMW allowed such an oversight to slide through. I wrote BMW at multiple addresses, including their "Technology Office" in California, which designs some of their software, but to no avail, with no response. Nevertheless, the problem does not seem to have resolved itself and I find BMW's supposed 'attention to detail' appalling on an 'after sales' / 'customer service' level; with most everything; not sure if this attitude is exclusive to North America or to AG too. In all, I have come to live with the problem, trying to accept / embrace it for its help in keeping one's bearings after arriving at a destination, but before parking, albeit not necessary / uncalled for. Everything is deemed 'normal' / 'as designed' / 'cannot duplicate' with this company, rarely acknowledging much... Should have given more weight to the way in which they 'managed' their N54 HPFP problems before purchasing my 7, as such is the corporate mentality. :|

Last edited by dbs600; 04-23-2013 at 07:50 AM.
Reply With Quote
  #13  
Old 04-22-2013, 08:17 PM
alewifebp's Avatar
alewifebp alewifebp is offline
Officially Welcomed to the 'Fest
Location: Northern NJ
 
Join Date: Sep 2008
Posts: 935
Mein Auto: 2014 550i
It appears in HUD as well. Since I'm typically at the final destination when the navigation stops, I'm about to turn the car off anyway which will get rid of the arrow. It's annoying. I'm a little surprised to see that it still happens in 2013 cars.
__________________
ED on 7/18/2014: 2014 550i, Space Gray, Mocha. M Sport, Cold Weather, DAP, Executive, Lighting
PCD on 9/6/2011: 2011 550i, DSB, black/oyster. Prem 2, Conv, Ventilated, HUD, Sport, DHP, SAT
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F10 / F11 (2011 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms