Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)

E46 M3 (2001-2006)

Reply
 
Thread Tools Display Modes
  #1  
Old 04-27-2013, 12:25 PM
mcmannhouse mcmannhouse is offline
Registered User
Location: washington state
 
Join Date: Oct 2012
Posts: 5
Send a message via ICQ to mcmannhouse
Mein Auto: m3
SMG not shifting

Just did a engine and smg transmission swap from a 2003 m3 smg to a 2003 m3 smg. Engine starts and runs fine. SMG trans will not shift. Codes came up P0760,P1740,P1848, P1850, P0763, Replaced shifter and transmission control module, unpluged all 3 hood switches no luck. Put test light on gr/wh and rd/wh wires that come out of control module for the hood pins and test light wont come on when it is grounded or hot. I have replaced the salmon relay, I have checked the wire plug to the trany several times, they are all clean, pins are stright and plugs tight, clutch and hydraulic fluid all good. It goes in R, 1st and 2nd on the dash window some of the time. You can hear the hy pump when key is turned on. And a clicking like its trying to shift some of the times. But the transmission will not engauge. When unlocked you can hear he pump motor running.The trasmission worked fine before the swap allthow the car was rolled. Two of the codes are shift solenoid and two codes are no ground, plates A & B. I did run a battery cable to the trans from the frame to make sure it was grounded, no luck. The service engine, brake, trany lights are on the dash and will not reset. The battery reads 14.3 volts when not runing, allthow when running the car for a half hour battery went dead, will test alternater and probley replace. must have burned it out with battery charger. Both cars have about 50K miles. Any advice will be greatly appreciated. Thank You
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E46 M3 (2001-2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms