Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)

E36 /7 Z3 (1996-2002)
E36/7 Z3 roadster and coupe talk with our gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-28-2013, 11:59 PM
Vikont Vikont is offline
Registered User
Location: UAE
 
Join Date: Apr 2013
Posts: 2
Mein Auto: Z3
Exclamation Idle runs high itself on turn

Hi everybody,

I got Z3 1997, M44 engine and problem persists since I bought it. When in 4th and 5th gear on around 3000rpm car keeps running even though gas pedal is released (feels like cruise control). Stays on 3000rpm and then you can feel 2 engine shakes (very mild) before rpm falls down normally.
Other concerning thing is that when making turn idle lunches up like crazy (up to 5000-6000rpm). This happens always, any gear, even i neutral..
Idle is stable and normal when starting the engine, no change when a/c, lights are on.

Throttle body changed, idle control valve cleaned, computer test gives nothing and car never had cruise control

I learned how to drive it and adopted to that behaviour But my wife is gonna start driving it soon and theres my concern

Thank You
Reply With Quote
Ads by Google
  #2  
Old 04-29-2013, 06:27 AM
vintage42's Avatar
vintage42 vintage42 is offline
BMW CCA 1405
Location: Louisville, KY
 
Join Date: Jun 2007
Posts: 1,294
Mein Auto: 1997 BMW Z3 1.9 5MT
Quote:
Originally Posted by Vikont View Post
... Z3 1997, M44 engine... When in 4th and 5th gear on around 3000rpm car keeps running even though gas pedal is released (feels like cruise control). Stays on 3000rpm and then you can feel 2 engine shakes (very mild) before rpm falls down normally. Other concerning thing is that when making turn idle lurches up... to 5000-6000rpm). This happens always, any gear, even in neutral... Idle is stable and normal when starting the engine, no change when a/c, lights are on. Throttle body changed, idle control valve cleaned, computer test gives nothing and car never had cruise control...
Perhaps the throttle cable is sticking or frayed or needs adjustment. Or the pivot shaft needs a little oil.

Last edited by vintage42; 04-29-2013 at 06:58 AM.
Reply With Quote
  #3  
Old 04-29-2013, 09:30 AM
Mikey48 Mikey48 is offline
Officially Welcomed to the 'Fest
Location: Charleston,S.C.
 
Join Date: Mar 2011
Posts: 402
Mein Auto: BMW Z4 3.0
Check your motor mounts. The only thing I can think of is if one of your motor mounts was broke and the engine is moving and pulling on the throttle cable or a broken trans mount. This is weird. Good luck. Please keep us posted.
Reply With Quote
  #4  
Old 04-29-2013, 11:31 AM
Vikont Vikont is offline
Registered User
Location: UAE
 
Join Date: Apr 2013
Posts: 2
Mein Auto: Z3
Throttle cable checked, no probs with it. It's weird it's get stuck only in 4th and 5th around 3000rpm and above (2nd and 3rd runs normally) and on turns even in neutral. So i guess if it's cable it will stuck always when pulled above 3000. Still on turns if i really slow it (below 20km/h), it drops and runs normally.

Thnks for reply
Reply With Quote
  #5  
Old 04-29-2013, 12:04 PM
Mikey48 Mikey48 is offline
Officially Welcomed to the 'Fest
Location: Charleston,S.C.
 
Join Date: Mar 2011
Posts: 402
Mein Auto: BMW Z4 3.0
Maybe that idle control valve is shot ?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E36 /7 Z3 (1996-2002)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms