Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 04-28-2013, 04:19 PM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
FEM_Body error....need help

Hi guys,

Just got my car this Friday and did setup E-Sys as per the step by step instruction and I backed-up the original CAF files. Every CAF file was backed-up except FEM_BODY. Whenever I try to read it its giving me error:

FEM_BODY [40]
readCPS 0.k
cafd_00000794-004_228_010 Fehler:
File for "cafd_00000794_228_010" not found! [C012].

Can you please let me know how I can fix this.

While you reading this Could I please also ask how I can get these options for my car?

1: Show Sports meter in iDrive (I dont have Navigation so its normal iDrive screen 6.5" I think)
2: Fold and unfold the mirrors with remote lock and unlock buttons.
3: Any way I can get the audio file names in iDrive and instrument cluster to scroll?
4: Auto Start/Stop function to start in the last used setting
5: Unlocks doors when engine is stopped only when start/stop button is pushed.
6: Allows single pull to open all doors.
7: Enable the gear shift indicator got all 4 driving options (ECO PRO, COMFORT, Sports & Sports+)

All help will be very much appreciated.
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.

Last edited by Nittenyadhav; 05-04-2013 at 10:36 AM.
Reply With Quote
Ads by Google
  #2  
Old 04-28-2013, 11:20 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
Hi guys,

Just got my car this Friday and did setup E-Sys as per the step by step instruction and I backed-up the original CAF files. Every CAF file was backed-up except FEM_BODY. Whenever I try to read it its giving me error:

FEM_BODY [40] [F137962]
readCPS 0.k
cafd_00000794-004_228_010 Fehler:
File for "cafd_00000794_228_010" not found! [C012].

Can you please let me know how I can fix this.

While you reading this Could I please also ask how I can get these options for my car?

1: Show Sports meter in iDrive (I dont have Navigation so its normal iDrive screen 6.5" I think)
2: Fold and unfold the mirrors with remote lock and unlock buttons.
3: Any way I can get the audio file names in iDrive and instrument cluster to scroll?
4: Auto Start/Stop function to start in the last used setting
5: Unlocks doors when engine is stopped only when start/stop button is pushed.
6: Allows single pull to open all doors.
7: Enable the gear shift indicator got all 4 driving options (ECO PRO, COMFORT, Sports & Sports+)

All help will be very much appreciated.
cafd_00000794_228_010 is not in any PSdZData release though 49.2. I suspect your car came from the factory with something even newer, like 49.3. I am not sure though if ISTA/P 2.49.3 has even been pushed to the dealers yet, but I will find out tomorrow. If it has, then you will need a copy of it to code your FEM_BODY module.

As for your coding specifics:

1) Only possible with Nav Professional, which your car does not have.
2) Check F30 Coding Cheat Sheet for Coding
3) Not possible as far as I know.
4) Check F30 Coding Cheat Sheet for Coding
5) Not sure I understand. How is it unlocking now if not when Start/Stop is pushed?
6) Check F30 Coding Cheat Sheet for Coding
7) Only possible with 6MT (6 Speed Manual Transmission), which your car does not have.

F30 Cheat Sheet:

https://docs.google.com/spreadsheet/...Ia3ZmbUE#gid=0
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #3  
Old 04-29-2013, 03:09 AM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Thanks for looking into this and for F30 Cheat Sheet Shawn. I'll wait for you confirmation on latest PSdZData.
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #4  
Old 04-30-2013, 12:46 AM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Hi Shawn did you get any luck with 49.3 PSdZData?
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #5  
Old 04-30-2013, 10:41 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
Hi Shawn did you get any luck with 49.3 PSdZData?
Sorry, but not yet.

First we need to confirm the existence of a new ISTA/P, presumably 2.49.3.

Check the I-Level of your car, and advise what it shows for I-Step Current:

http://www.f30post.com/forums/showpo...postcount=1403

If it is something newer than F020_13_03_503, like F020_13_03_504, then we have a new ISTA/P version.

If that is the case, then I will find out if BMW AG has pushed this new version out to the dealerships yet, and if so, I will get a copy.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #6  
Old 04-30-2013, 02:02 PM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Thanks Shawn, I checked it and I level of my car is F020_13_03_503 (please see the image attached). Please let me know what you suggest I can do to fix this issue?
Attached Thumbnails
Click image for larger version

Name:	I-Step.jpg
Views:	39
Size:	51.4 KB
ID:	374026  
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #7  
Old 04-30-2013, 04:35 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
Thanks Shawn, I checked it and I level of my car is F020_13_03_503 (please see the image attached). Please let me know what you suggest I can do to fix this issue?
Well, I was able to confirm earlier today that ISTA/P 2.49.3 does in fact exists, and I am pretty sure it is what you car has on it.

While your I-Level is F020-13-03-503, which is ISTA/P 2.49.2, I think we are going to see that for the F20, ISTA/P 2.49.3 is also the same I-Level, as it is often the case where the I-Level does not change with ISTA/P versions.

So, now we need to wait until the 49.3 PSdZData is available, which should not take more than a few days, and I expect cafd_00000794-004_228_010 to be added in it.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #8  
Old 04-30-2013, 10:42 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
Thanks Shawn, I checked it and I level of my car is F020_13_03_503 (please see the image attached). Please let me know what you suggest I can do to fix this issue?
I can confirm now that all Fxx chassis I-Levels remained unchanged at Fxx-13-03-503 in ISTA/P 2.49.3, and that cafd_00000794.caf.004_228_010 is 1 of 6 new CAFD's added in 49.3.

PM sent.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips

Last edited by shawnsheridan; 04-30-2013 at 10:43 PM.
Reply With Quote
  #9  
Old 05-01-2013, 12:26 AM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Thanks for look into this Shawn, much appreciated. I'll add the new CAFD file and report back.
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #10  
Old 05-01-2013, 01:03 PM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
hi Shawn,

thanks for that file it working and reading the FEM_Body CAFD file, however now when I'm trying to edit any of the cafd file I'm getting this error (please see attached image). I do have the code away file and I did mapped it in settings.

Any help will be appreciated Shawn. Thanks a mill
Attached Thumbnails
Click image for larger version

Name:	Result.jpg
Views:	34
Size:	31.3 KB
ID:	374213  
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #11  
Old 05-01-2013, 02:00 PM
FrogmanF30's Avatar
FrogmanF30 FrogmanF30 is online now
Officially Welcomed to the 'Fest
Location: Southern California
 
Join Date: Mar 2012
Posts: 406
Mein Auto: 2012 328i
Quote:
Originally Posted by Nittenyadhav View Post
hi Shawn,

thanks for that file it working and reading the FEM_Body CAFD file, however now when I'm trying to edit any of the cafd file I'm getting this error (please see attached image). I do have the code away file and I did mapped it in settings.

Any help will be appreciated Shawn. Thanks a mill
You can't use the old 3.18.4 Code Away token to code an F30 with 2.49.0 or later. You need 3.22.5, a set of patches, and a new token. PM Shawn for details.
Reply With Quote
  #12  
Old 05-01-2013, 02:30 PM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Quote:
Originally Posted by FrogmanF30 View Post
You can't use the old 3.18.4 Code Away token to code an F30 with 2.49.0 or later. You need 3.22.5, a set of patches, and a new token. PM Shawn for details.
thanks FrogmanF30, I actually have E-Sys 3.22.5 and psdzdata 49.1. I think I dont have code away for 3.22.5. may be Shawn can help.
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #13  
Old 05-01-2013, 02:38 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
thanks FrogmanF30, I actually have E-Sys 3.22.5 and psdzdata 49.1. I think I don't have code away for 3.22.5. may be Shawn can help.
Look at the picture you just posted. E-Sys Options is still pointing to the old Code Away.EST file. You need to change it to point to your new .EST file.

The two patched .jar files need to be renamed and put in their proper location too if you have not done so.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #14  
Old 05-01-2013, 03:19 PM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Thanks Shawn, could you please let me know more about these .jar files? where I can locate them, what new name I need to give them and where I need to place them?

That other part is also done I'm waiting on mail reply now
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #15  
Old 05-01-2013, 03:38 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
Thanks Shawn, could you please let me know more about these .jar files? where I can locate them, what new name I need to give them and where I need to place them?

That other part is also done I'm waiting on mail reply now
They will come with the "other part", with instructions as to which two folders they go in. You need to remove PATCHED from the file names first.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #16  
Old 05-03-2013, 12:19 AM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Hi Shawn,

Just to update you all is working fine now with E-Sys after purchasing the token. I've tried 1 or 2 codes and they worked great. Thanks for all of you and especially you Shawn for helping me out. Today I'm taking my car for Boot lid issue to dealer and once back I'll try few other codes what I wanted to do. If any issues I may have I'll seek your help. Thanks agian.
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #17  
Old 05-03-2013, 09:06 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
Hi Shawn,

Just to update you all is working fine now with E-Sys after purchasing the token. I've tried 1 or 2 codes and they worked great. Thanks for all of you and especially you Shawn for helping me out. Today I'm taking my car for Boot lid issue to dealer and once back I'll try few other codes what I wanted to do. If any issues I may have I'll seek your help. Thanks agian.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #18  
Old 05-03-2013, 10:06 AM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Hi Shawn, You know if there is a way to get the PSI reading for Tyre pressure in my iDrive for F30?
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #19  
Old 05-03-2013, 10:08 AM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
Hi Shawn, You know if there is a way to get the PSI reading for Tyre pressure in my iDrive for F30?
I am pretty sure you have FTMS, not TPMS, and FTMS has no actual pessure / temp sensors as it works only a tire rotational speed.

If you do not have Option 2VB, you do not have the proper TPMS hardware.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #20  
Old 05-03-2013, 10:38 AM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Quote:
Originally Posted by shawnsheridan View Post
I am pretty sure you have FTMS, not TPMS, and FTMS has no actual pessure / temp sensors as it works only a tire rotational speed.

If you do not have Option 2VB, you do not have the proper TPMS hardware.
Ahh thanks Shawn I checked and I dont have 2VB in FA so I cant have this.
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #21  
Old 05-04-2013, 10:31 AM
Nittenyadhav's Avatar
Nittenyadhav Nittenyadhav is offline
Officially Welcomed to the 'Fest
Location: Dublin, Ireland
 
Join Date: May 2010
Posts: 238
Mein Auto: BMW F30 316D 2013
Hi Shawn, could you please help me out with connection issue Im getting in E-Sys? Today I went in car to do some coding and for some reason I'm not getting connection (please see the image). I can see the yellow mark on network connection but when I go to connect its ZGW I'm getting blank screen. Everything was working fine before. Do you know what causing this and how I can resolve it?
Attached Thumbnails
Click image for larger version

Name:	Untitled.jpg
Views:	40
Size:	117.2 KB
ID:	374727  
__________________
__________________________________________________ ____

BMW 316D Sports F30, Build Date - 04/04/2013, Colour - Imperial Blue, HK Audio, Xenon, Tinted Rear and back Windows.
Reply With Quote
  #22  
Old 05-04-2013, 12:18 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,161
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Nittenyadhav View Post
Hi Shawn, could you please help me out with connection issue Im getting in E-Sys? Today I went in car to do some coding and for some reason I'm not getting connection (please see the image). I can see the yellow mark on network connection but when I go to connect its ZGW I'm getting blank screen. Everything was working fine before. Do you know what causing this and how I can resolve it?
Assuming it was working fine yesterday, and you have made no changes whatsoever with E-Sys Configuration or Data files, I suspect a bad cable connection or E-Sys or your PC Lan Port is jammed up somehow. I would reboot PC, make a fresh ENET Connection to the car, and make sure the cable is making good contact on both the OBD II and Ethernet sides and try again.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms