Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 05-06-2013, 12:20 PM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
After Coding Tailgate Doesn't Open or Close

Hello,

I recently coded my 2013 X3 to auto close my tailgate using the button in the cockpit or from the fob.

The coding worked after waiting the suggested 1 hour but 24 hours later it quit working.

Not only does the TG not close automatically it doesn't open either, it unlocks but doesn't lift.

Has anyone else experienced similar problems? Do you have a solution?

Thanks,
ERK

Here is the coding I used:

Close Trunk/ Tailgate through button on FOB
HKFM | 3010 | SCH_FBD | aktiv / Werte=01
HKFM | 3010 | TASTER_FBD | aktiv / Werte=01

Close Trunk/ Tailgate through button on driver side
HKFM | 3010 | SCH_TOEHKI | aktiv / Werte=01
HKFM | 3010 | TASTER_FBD | aktiv / Werte=01
Reply With Quote
Ads by Google
  #2  
Old 05-06-2013, 06:05 PM
jaza45 jaza45 is offline
I'm in Miami B.
Location: Miami
 
Join Date: Sep 2003
Posts: 11
Send a message via AIM to jaza45 Send a message via Yahoo to jaza45
Mein Auto: E92 M3
Try to code the module back to default and then recode it again, it happen to me once with a friends 550GT.
Reply With Quote
  #3  
Old 05-06-2013, 09:14 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,701
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by erkbiz View Post
Hello,

I recently coded my 2013 X3 to auto close my tailgate using the button in the cockpit or from the fob.

The coding worked after waiting the suggested 1 hour but 24 hours later it quit working.

Not only does the TG not close automatically it doesn't open either, it unlocks but doesn't lift.

Has anyone else experienced similar problems? Do you have a solution?

Thanks,
ERK

Here is the coding I used:

Close Trunk/ Tailgate through button on FOB
HKFM | 3010 | SCH_FBD | aktiv / Werte=01
HKFM | 3010 | TASTER_FBD | aktiv / Werte=01

Close Trunk/ Tailgate through button on driver side
HKFM | 3010 | SCH_TOEHKI | aktiv / Werte=01
HKFM | 3010 | TASTER_FBD | aktiv / Werte=01
Please do not cross post:

http://www.bimmerfest.com/forums/sho...&postcount=320
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #4  
Old 05-08-2013, 10:53 AM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
Please disregard

Please disregard

Too bad we cannot remove posts from this forum

ERK

Last edited by erkbiz; 05-08-2013 at 11:07 AM.
Reply With Quote
  #5  
Old 05-08-2013, 01:03 PM
Stealth.Pilot's Avatar
Stealth.Pilot Stealth.Pilot is offline
The Driver
Location: Florida
 
Join Date: Jul 2009
Posts: 4,533
Mein Auto: 2014 M5
Did you check if you a accidentally nudged the valet trunk lock switch? This is a toggle switch in your glovebox or arm rest compartment which locks the trunk. Once that switch is set to lock, nothing will open or close the trunk. Sometimes it gets accidentally activated when you are fumbling in the armrest compartment.
__________________

2014 ///M5 Individual
Frozen Grey, Silverstone Full Merino, Piano Black, Exec Pkg, Drivers assistance pkg, LED Package, Bang and Olufsen, 20" Forged wheels
Reply With Quote
  #6  
Old 05-08-2013, 02:44 PM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
Stealth.Pilot

My vehicle is a small SUV it doesn't have the switch you site. Also, the tailgate unlocks it just doesn't automatically lift. What I did discover, however, is that if I repeatedly press the button on the fob the tailgate does go up in steps. Furthermore when I press the button on the tailgate to lower it instead of closing it jerks in an upward motion like it's trying to open further and this is with the restored default values having done a VO coding which removed the coding that I did.

Thanks for your suggestion.

ERK

Last edited by erkbiz; 05-08-2013 at 02:49 PM.
Reply With Quote
  #7  
Old 05-14-2013, 03:37 AM
TurboBusa TurboBusa is offline
Officially Welcomed to the 'Fest
Location: Charleston S.C.
 
Join Date: Jan 2012
Posts: 249
Mein Auto: Lexus LS400
Sorry I cant be of more help, but I don't know about this coding stuff. I am thinking about getting my vehicle done this weekend, but this scares me. Did you ever get this work correctly? What happened? Please update!! Hopefully the pros will assist you with this.
Reply With Quote
  #8  
Old 05-14-2013, 04:32 AM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
TurboBusa,

Nope, I still have the problem, it is intermittent, (maybe it's healing itself?), and I am still working on it. My progress is slow because of my schedule. Prior to coding the TG I successfully coded the digital MPH readout. I am thinking that my situation is not typical.

If I am unable to resolve this I will end up at the dealer and tell them that the TG is operating intermittently and will have them recode the vehicle. Will I do any further coding? Right now I am not sure.

ERK

Last edited by erkbiz; 05-14-2013 at 04:34 AM.
Reply With Quote
  #9  
Old 05-14-2013, 04:39 AM
Teemo Panda's Avatar
Teemo Panda Teemo Panda is offline
Bimmefest Plasti-Dip Guru
Location: New Jersey
 
Join Date: Dec 2011
Posts: 851
Send a message via Skype™ to Teemo Panda
Mein Auto: E53, E46-M3, E70, F25-X3
After Coding Tailgate Doesn't Open or Close

Wow, u have to wait 1hr and a half for the TG to kick in? Damn

When I get my car coded, my TG worked right after in my X3.

If you go to the dealer and they find out about you messing with the coding of the car, don't be surprised if they would void the whole thing regarding to coding.

I would suggest to load up the original files that you backed up that wasn't coded.


Sent from BimmerApp mobile app
__________________
Reply With Quote
  #10  
Old 05-14-2013, 04:49 AM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
Kamigawa120,

It wasn't that I had to wait the 90 minutes the cheat sheet stated that it took 1 to 2 hours to work so I didn't test it out immediately I chose to wait the suggested time. I did reset values back to their original state and the problem persisted, go figure.

I am thinking the dealer won't know that I was mucking with the vehicle their job is to just fix it. If they look at the current coding on the module they will see the default values cause I changed everything back. I don't see how they can tell that I did any coding. Besides I will play dumb, "Coding, I don't know what that even means"

ERK

Last edited by erkbiz; 05-14-2013 at 04:51 AM.
Reply With Quote
  #11  
Old 05-14-2013, 07:36 PM
TRIPLE_O TRIPLE_O is offline
OOO
Location: UPSTATE NY/NORTHERN NJ/NYC
 
Join Date: Feb 2012
Posts: 190
Mein Auto: E90 335i
Did you try what I recommended?
Reply With Quote
  #12  
Old 05-15-2013, 04:29 AM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
I will be doing a VO coding on the module today. I hope it works.

As stated this is an intermittent problem. Yesterday evening when got home I used the button in the vehicle to open the TG and it went into a loop. It would unlock, raise about a foot, stop, close, lock then repeat. This continued unabated until I pressed the button again.

Last edited by erkbiz; 05-15-2013 at 04:48 AM.
Reply With Quote
  #13  
Old 05-15-2013, 03:22 PM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
Just finished VO coding the module. Here is a copy of the log generated during the coding process:

Caf's suchen
Tal wird generiert
Abarbeitung wird gestartet

TAL execution started. [C205]
ExecutionID=2013/05/15-17:24:36.650
[] prepareTALExecution started
[] prepareTALExecution finished
[] prepareVehicleForCoding started
[] prepareVehicleForCoding finished
[HKFM_LS - 6B] prepareECUforCoding started
[HKFM_LS - 6B] prepareECUforCoding finished
[HKFM_LS - 6B] authenticateECUforCoding started
[HKFM_LS - 6B] authenticateECUforCoding finished
[HKFM_LS - 6B - cafd_000007c8-006_004_000] Transaction type: cdDeploy; Message: TA started
[HKFM_LS - 6B - cafd_000007c8-006_004_000] Transaction type: cdDeploy; Message: TA finished
[HKFM_LS - 6B] finalizeECUCoding started
[HKFM_LS - 6B] finalizeECUCoding finished
[] finalizeVehicleCoding started
[] finalizeVehicleCoding finished
[] finalizeTALExecution started
[] finalizeTALExecution finished
TAL execution finished
TAL-Execution finished with status: "Finished". [C207]
TAL execution finished. Duration: "13s". [C206]
MSM update: Read current SVT. [C194]
MSM update started. [C215]
MSM update finished. [C216]
VCM Update: Write FA to VCM. [C188]
VCM Update: Write FP to VCM. [C190]
VCM Update: Read current SVT. [C191]
VCM Update: Check current SVT with TAL. [C192]
VCM Update: Write target SVT. [C193]
VCM Update: Write FA to backup. [C189]
VCM Update: finished. [C195]
Abarbeitung beendet
Reply With Quote
  #14  
Old 05-15-2013, 04:11 PM
sfiermon sfiermon is offline
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Apr 2011
Posts: 370
Mein Auto: 2014 x3 35i
what is a VO coding?
Reply With Quote
  #15  
Old 05-15-2013, 05:40 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,701
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by erkbiz View Post
Just finished VO coding the module. Here is a copy of the log generated during the coding process:

Caf's suchen
Tal wird generiert
Abarbeitung wird gestartet

TAL execution started. [C205]
ExecutionID=2013/05/15-17:24:36.650
[] prepareTALExecution started
[] prepareTALExecution finished
[] prepareVehicleForCoding started
[] prepareVehicleForCoding finished
[HKFM_LS - 6B] prepareECUforCoding started
[HKFM_LS - 6B] prepareECUforCoding finished
[HKFM_LS - 6B] authenticateECUforCoding started
[HKFM_LS - 6B] authenticateECUforCoding finished
[HKFM_LS - 6B - cafd_000007c8-006_004_000] Transaction type: cdDeploy; Message: TA started
[HKFM_LS - 6B - cafd_000007c8-006_004_000] Transaction type: cdDeploy; Message: TA finished
[HKFM_LS - 6B] finalizeECUCoding started
[HKFM_LS - 6B] finalizeECUCoding finished
[] finalizeVehicleCoding started
[] finalizeVehicleCoding finished
[] finalizeTALExecution started
[] finalizeTALExecution finished
TAL execution finished
TAL-Execution finished with status: "Finished". [C207]
TAL execution finished. Duration: "13s". [C206]
MSM update: Read current SVT. [C194]
MSM update started. [C215]
MSM update finished. [C216]
VCM Update: Write FA to VCM. [C188]
VCM Update: Write FP to VCM. [C190]
VCM Update: Read current SVT. [C191]
VCM Update: Check current SVT with TAL. [C192]
VCM Update: Write target SVT. [C193]
VCM Update: Write FA to backup. [C189]
VCM Update: finished. [C195]
Abarbeitung beendet
This all looks good. Was the TAL Log green (successful) or Red (unsuccessful)?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #16  
Old 05-15-2013, 05:45 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,701
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by sfiermon View Post
what is a VO coding?
When you VO Code an ECU (right-click on ecu itself and select code), E-Sys will code all Function Data Lines (100% of the module) based on the Production Date and the SA Option Codes defined in FA (VO), as opposed to FDL Coding where you change individual Function Data Lines without any regard to FA (VO).
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #17  
Old 05-15-2013, 06:15 PM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
That is a good question. I don't know what the TAL log is or where to look for it. I did not see anything red which normally stands out. If you can tell me where to look for it I will try to recall if I saw something red or green.....thanks.
Reply With Quote
  #18  
Old 05-15-2013, 06:52 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,701
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by erkbiz View Post
That is a good question. I don't know what the TAL log is or where to look for it. I did not see anything red which normally stands out. If you can tell me where to look for it I will try to recall if I saw something red or green.....thanks.
I was thinking it was log you posted, which should have been in a pop-up window.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #19  
Old 05-15-2013, 07:15 PM
sfiermon sfiermon is offline
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Apr 2011
Posts: 370
Mein Auto: 2014 x3 35i
After Coding Tailgate Doesn't Open or Close

Quote:
Originally Posted by shawnsheridan View Post
When you VO Code an ECU (right-click on ecu itself and select code), E-Sys will code all Function Data Lines (100% of the module) based on the Production Date and the SA Option Codes defined in FA (VO), as opposed to FDL Coding where you change individual Function Data Lines without any regard to FA (VO).
Is there a benefit to VO coding?


Sent from BimmerApp mobile app
Reply With Quote
  #20  
Old 05-15-2013, 07:18 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,701
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by sfiermon View Post
Is there a benefit to VO coding?


Sent from BimmerApp mobile app
Yes. One, assuming you have the necessary hardware, if you know the SA Option Code for a feature, but do not know all the individual FDL Codes required to enable it, you can simply add the Option to the VO and VO Code the module, and let the VO do all the FDL Coding work for you. Two, it is a quick easy way to reset an entire module to its as delivered factory condition.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
  #21  
Old 05-16-2013, 03:45 AM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
Shawn, Yes, you are correct, the log is the TA Log. I don't recall any coloring so I don't believe there was anything colored red. I guess the bottom line is, did this VO work. I'm on my way out the door in a few and will try it several times throughout the day. Wish me luck.
Reply With Quote
  #22  
Old 05-16-2013, 08:54 AM
Teemo Panda's Avatar
Teemo Panda Teemo Panda is offline
Bimmefest Plasti-Dip Guru
Location: New Jersey
 
Join Date: Dec 2011
Posts: 851
Send a message via Skype™ to Teemo Panda
Mein Auto: E53, E46-M3, E70, F25-X3
After Coding Tailgate Doesn't Open or Close

Erkbiz, quick question. What is the year map version of your Navigation system?


Sent from BimmerApp mobile app
__________________
Reply With Quote
  #23  
Old 05-16-2013, 12:22 PM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
kamigawa120,

I can do this for you but I don't know how to extract the year map version info from my vehicle.

erkbiz
Reply With Quote
  #24  
Old 05-16-2013, 12:28 PM
erkbiz erkbiz is offline
Registered User
Location: Michigan USA
 
Join Date: Mar 2013
Posts: 85
Mein Auto: 2013 X3
Shawn, Triple_O,

TG Update.

When I first tried to open the TG it just unlocked it did not lift. Awhile later tried again and everything functioned as it should. Tried some time after that and it was still working. Not calling this problem fixed as of yet cause it was always intermittent. I figure if I go a week of normal operation and it continues to work I will claim success.

I thank you for all the advice you have given. Oh, and of course, if the problem is solved I will once again try to code it for auto close....Perhaps I am a "glutton for punishment".

Thanks again,
ERK
Reply With Quote
  #25  
Old 05-16-2013, 12:29 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 8,701
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by erkbiz View Post
kamigawa120,

I can do this for you but I don't know how to extract the year map version info from my vehicle.

erkbiz
Check under iDrive Nav Options. It will dispaly the map version.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - 2TB SAT / 6WB MFID Cluster / 4U1 Ceramic Controls / 6NR BMW Apps / Rear Fog Lights / Cyba Double Layer Black Chrome Quad Tips
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms