Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 05-09-2013, 08:48 PM
bad540i bad540i is offline
Registered User
Location: New Zealand
 
Join Date: May 2013
Posts: 29
Mein Auto: 1998 BMW 540i
540i stalling problem!

Some times when i start my 540i it stalls after a couple of seconds. today it stalled while i was driving . i have just cleaned my MAF sensor and nothing has changed! how do i remove the idol control valve and clean it? And is it hard to do? or harder than cleaning the MAF sensor.
Reply With Quote
Ads by Google
  #2  
Old 05-09-2013, 11:19 PM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 8,332
Mein Auto: '97 540i 6 speed
Actually, it's the "idle control valve."

Not difficult. The valve is under the engine cover, at the front of the intake manifold. It's an aluminum can about the size of a small juice can.

Unhook the plastic retainer, and carefully disconnect the hoses. Hose out the valve with brake cleaner. Properly cleaned, the valve shoud rattle when shaken. Examine the hoses to make sure they are not split.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #3  
Old 05-10-2013, 09:25 AM
borahatch borahatch is offline
Registered User
Location: Sunny SoCal
 
Join Date: Apr 2006
Posts: 92
Mein Auto: 1998 BMW 540i
Do you have a scanner? It could also be your cam position sensor starting to fail. I had a pending code for my CPS for months. One day, I started my car and it stalled within seconds. Ordered a new CPS (OEM only) and all is well.
__________________
1998 540i
Reply With Quote
  #4  
Old 05-10-2013, 07:42 PM
bad540i bad540i is offline
Registered User
Location: New Zealand
 
Join Date: May 2013
Posts: 29
Mein Auto: 1998 BMW 540i
Hey guys i did what people told me and cleaned the icv it was quite seized up and didnt clink. After cleaned it was moving freely. I placed the part back in and car is still stalling . Should i get my codes read and move to cam position sensor? how much are these oem?
Reply With Quote
  #5  
Old 05-10-2013, 07:54 PM
borahatch borahatch is offline
Registered User
Location: Sunny SoCal
 
Join Date: Apr 2006
Posts: 92
Mein Auto: 1998 BMW 540i
Yes, get your car scanned. Takes out all the guess work. I picked up my CPS for $130 from an Indy BMW repair shop. You might be able to get it cheaper online. Just make sure you're getting a BMW part and not some knock-off.
__________________
1998 540i
Reply With Quote
  #6  
Old 05-10-2013, 07:58 PM
bad540i bad540i is offline
Registered User
Location: New Zealand
 
Join Date: May 2013
Posts: 29
Mein Auto: 1998 BMW 540i
Thank you ^^^
Reply With Quote
  #7  
Old 05-10-2013, 08:32 PM
borahatch borahatch is offline
Registered User
Location: Sunny SoCal
 
Join Date: Apr 2006
Posts: 92
Mein Auto: 1998 BMW 540i
No problem. Let us know how things work out.
__________________
1998 540i
Reply With Quote
  #8  
Old 05-15-2013, 12:06 AM
bad540i bad540i is offline
Registered User
Location: New Zealand
 
Join Date: May 2013
Posts: 29
Mein Auto: 1998 BMW 540i
Hey guys i just bought a scanner although it isnt giving me a code it saying cam position sensor
What do io do ? does my car only have one cam position sensor? also it had a few more before i cleared them . One was hot film mass airflow sensor and another was cc continuous power supply! what do i do
Reply With Quote
  #9  
Old 05-15-2013, 11:00 AM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 8,332
Mein Auto: '97 540i 6 speed
it isnt giving me a code it saying cam position sensor If there's no code, how do you know?

There's only one CPS, and it's mounted to the front of the right side cylinder head.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #10  
Old 05-15-2013, 12:29 PM
borahatch borahatch is offline
Registered User
Location: Sunny SoCal
 
Join Date: Apr 2006
Posts: 92
Mein Auto: 1998 BMW 540i
To make things easy on you, here's a picture of the box my CPS came in. That's the part number you'll need. We have the same car.
[IMG][/IMG]
__________________
1998 540i
Reply With Quote
  #11  
Old 05-15-2013, 01:58 PM
bad540i bad540i is offline
Registered User
Location: New Zealand
 
Join Date: May 2013
Posts: 29
Mein Auto: 1998 BMW 540i
i mean its not giving me a p code haha its just saying 70 cam position sensor
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms