Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 04-14-2013, 01:36 PM
David Arabiat David Arabiat is offline
Officially Welcomed to the 'Fest
Location: Jordan
 
Join Date: Nov 2011
Posts: 102
Mein Auto: 1988 m20b20 BMW E34
hesitation while accelerating

my e34 (m20b20) recently started hesitating when im accelerating ( mostly between 3000-4000 rpm ) ... had this problem a couple of years ago ... the problem was the spark plug wires ... ones of them was bad ... replaced the bad wire with a used one from an old set of sparkplug wires that i had around ...

now that i got the same problem again , i figured ill just buy new spark plug wires ... got a new set of wires ( had an option of german or chinese .. bought german ) installed them ... and i was really surprised that the problem still persists .... changed the fuel filter too .. and that didnt help

so if it isnt the wires ... can it be :
1) dirty fuel injectors?
2) fuel pump ?
3) problem with the spark plugs? ( changed them less than 6 months ago )
4) can it be a problem with the exhaust system ?
5) vacuum system ?

any suggestions would be great ... in advance , suggestions to check my check engine codes wont be helpful as my car is pretty old and doesnt have an OBC

thanks all
Reply With Quote
Ads by Google
  #2  
Old 04-17-2013, 10:58 AM
CarDriver's Avatar
CarDriver CarDriver is offline
Officially Welcomed to the 'Fest
Location: Saint Albans, New York
 
Join Date: Apr 2008
Posts: 2,409
Mein Auto: 1992 525it /2004 ML350
Did you replace the spark plugs and inspect the ditributer cap and rotor (if M20) ?
__________________
Reply With Quote
  #3  
Old 04-18-2013, 07:10 AM
David Arabiat David Arabiat is offline
Officially Welcomed to the 'Fest
Location: Jordan
 
Join Date: Nov 2011
Posts: 102
Mein Auto: 1988 m20b20 BMW E34
The spark plugs were changed not too long ago (6 months) ... but when i changed the spark plug wires , i didnt change the spark plugs ...
the Distributor cap and rotor i did not inspect .. as i dont know how to inspect it and what to look for ... should i just replace it ? is it relatively expensive or cheap ?
Reply With Quote
  #4  
Old 05-12-2013, 03:52 AM
David Arabiat David Arabiat is offline
Officially Welcomed to the 'Fest
Location: Jordan
 
Join Date: Nov 2011
Posts: 102
Mein Auto: 1988 m20b20 BMW E34
Re: hesitation while accelerating

Well .. If anybody is interested , my problem was resolved ... One fine day.. I started the engine to go to work ... The car started normally ...then I drove off ... I noticed that the hesitation has changed to something worse.. The car wouldn't respond to the throttle ... I floor the pedal and it only goes up to 1500 rpms .. The car was undrivable ... I thought that its the end to either the AFM or the fuel pump ... Parked the car near the house and left it as it is for 5 days until I found time to try to fix the problem ...
Yesterday I had some free time .. So I managed to drive the car for 20 km on first gear and 1500-2000 rpms to reach a shop that sells used BMW parts ..
Told the guy about my problem ..and I told him I think its the fuel pump or the AFM ... He said no need to try to replace the pump ... He did a test in which he clamps the fuel return hose near the fuel injectors ... If he clamps and the car starts running better then the fuel pump is bad ... It didn't ... So he said 100% its not the fuel pump ..
Next we tried to swap the AFM ... Nothing changed ... He tried to change the motronic computer ... Nothing ....
Tried out another crank shaft sensor ... Nothing ....
Inspected spark plugs .... Tried out another set of sparkplug wires and capacitor ... Still same problem ... Next were the injectors ... We tried out a set of used injectors ...no luck ... The problem was still there ..
The guy has now lost hope ... He told me to leave the car at his garage and next day a BMW electric specialist will have a look ...
He reinstalled all my old parts back ....as they turned out to be perfectly good ...
And just before we closed the bonnet , he says - one last try... Highly unlikely part to go bad in a BMW but let's try the ignition coil ... He grabbed a used coil that he had ...connected the coil electric connections and wire to it ... And .... It worked!!!!! Turns out it was the coil !!!!! So easy to install ...I don't know if the guy should have thought about it earlier... But he says he has never run into coil problems ...

Paid 15 bucks for that used coil ... And gave the guy 20 bucks for his efforts ... And now it runs well again :-)



Sent from my Nexus S using BimmerApp mobile app
Reply With Quote
  #5  
Old 05-12-2013, 06:40 AM
Bimmerfan84's Avatar
Bimmerfan84 Bimmerfan84 is offline
Officially Welcomed to the 'Fest
Location: South Florida
 
Join Date: Sep 2012
Posts: 166
Mein Auto: 1998 528i
Shoot I wish I had seen this thread earlier. (I hadn't been on in a while) I had the same problem with my M50TUB25 I thought it was a vacuum leak or AFM until I closely inspected the coils. The original Bremi coils are prone to cracking but cracks so small you can only see them if you take an extremely bright LED flashlight and shine them on the top of the coils at different angles. I replaced one but still had a slight misfire and found three others had small cracks so I replaced them all with BOSCH coils (which aren't as prone to cracking) and the car runs GREAT!
Reply With Quote
  #6  
Old 05-12-2013, 06:41 AM
snowsled7 snowsled7 is offline
The Ornery Old Man
Location: SW Mountains
 
Join Date: Mar 2012
Posts: 980
Mein Auto: GTI
Who cares if it took him too long to figure it out, you fixed the car for $35 The car only needs three things to run, fuel, air, spark. Figuring out which you are missing before swapping parts is usually a bit more expediant. I don't have yard like that to visit anywhere near here, sounds like a great learning experience.

Those old coils are nothing unique to BMW's and they can all fail with time. The clue to the coil going was that it started and ran fine cold then suddenly lost power and wouldn't build rpm. Fuel pump was a good call to check first because it is so common.

Good to hear it is back on the road, thanks for the update!
__________________
Current ride... '13 GTI Wolfsburg
BMW's from my past...
'92 535i/5 '89 325ix/5
'98 750iL '86 325(e)/5
'95 740iL '84 318i/5
Reply With Quote
  #7  
Old 05-12-2013, 08:02 AM
BMR_LVR's Avatar
BMR_LVR BMR_LVR is offline
Humble E34 lover
Location: Asheboro, NC
 
Join Date: Dec 2008
Posts: 5,264
Mein Auto: 1992 525i
Glad you got it sorted out

Someone else with the M20 was having similar problems a while back and I suggested checking the coil and an obnoxious member here who thinks they know everything basically said that wouldn't cause the problem.

Sorry I didn't chime on your post because I would have recommended checking not only the coil, but the rotor button and distributor cap.

Again, glad you got it running again.
__________________
Most problems are usually something simple !

Quote:
Originally Posted by noego View Post
It's Deja Poo - as in, I've heard this **** before.
Steve

Calypso Red 1992 525i with 200K miles

1991 735i - Sold
1992 525i - Sold
1995 325is - Sold
2000 528i - Sold

Reply With Quote
  #8  
Old 05-12-2013, 02:33 PM
David Arabiat David Arabiat is offline
Officially Welcomed to the 'Fest
Location: Jordan
 
Join Date: Nov 2011
Posts: 102
Mein Auto: 1988 m20b20 BMW E34
thanks for the support guys
Snowsled ... yeah ... thats the way i was thinking about it too ... car needs air , fuel and a spark to run ... )
but that m20 doesnt have coils .. it has only one coil .. with a wire .. i think the m50's have a coil per spark ... so i only needed to replace the one coil that i had ...

BMR LVR ... yeah i need to change my disturbutor cap and rotor and get new ones ... because as i've read , they need to be changed every like 20k miles .... mine have been on the car ever since it was built in 1988 :P ... around 200k ... lol ... but the car seems to run fine though .. found a bosch rotor ... but bosch disturbutors are harder to find here .. found other german brands .. but to get bosch would be the safer choice ...
Reply With Quote
  #9  
Old 05-12-2013, 05:48 PM
MySatinDoll MySatinDoll is offline
New to S5X Tinkering
Location: Next door bring tools and beer.
 
Join Date: Jan 2011
Posts: 1,433
Mein Auto: 1995 e34 S52b32/5
I just had this happen. But it's happened before.
My distributor cap and rotor button were the culprits.

At least this time the rotor button remained in one piece except for the brass end which blew off and rattled around in the cap.
Lucky for me it stayed in the cap.
__________________

_______________________________________

Every once in a while the Lion has to show the Jackals who he is...
- Christopher Walken "The Lion Speech"
95 e34 525 5 spd S52 Swap... The new Garden State Grocery Getter projekt.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms