Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-21-2013, 01:07 PM
David Covell David Covell is offline
Registered User
Location: DC
 
Join Date: Sep 2008
Posts: 8
Mein Auto: X%
AC not working 2001 X5

Looked through the blogs and did not appear to find my exact situation. AC stopped working after reliably producing 40F at the vents. Pressure test indicated 115 psi, so 134a does not appear to be low. AC belt is fine, but clutch does not engage. Since all fans work, I do not believe is is a Final Stage Resistor. Suspect other relay/fuse. Does anyone know how to trigger the AC clutch to check for a failed relay/fuse?

Thanks for the advice.
Reply With Quote
Advertisement
 

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms