Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)

E60 (2004 - 2010)
BMW 5-Series (E60 chassis) was first seen in the Unites States in the fall of 2003 with a 2004 Model Year designation. The E60 is now available as a 528i, 528xi, 535i, 535xi, 550i and a 535xi sports wagon! -- View the E60 Wiki

Reply
 
Thread Tools Display Modes
  #626  
Old 05-14-2013, 06:14 PM
Jay25 Jay25 is offline
Registered User
Location: NYC
 
Join Date: Nov 2011
Posts: 35
Mein Auto: 2004 BMW 530i
Great news. I am happy for u. I hope it's being done at a bmw dealership.
Reply With Quote
  #627  
Old 05-14-2013, 06:20 PM
djray77 djray77 is offline
Registered User
Location: Mi
 
Join Date: Apr 2013
Posts: 5
Mein Auto: 2004 545i/sport pkg
Yes it is, I hate most stealerships be I trust they know BMW's better than any other shop.
Reply With Quote
  #628  
Old 05-15-2013, 08:27 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
Quote:
Originally Posted by djray77 View Post
Got some good news today! They are going to put in a new trans for me and accept the 9 hours the warranty company pays woohooo! Only 100 deductible out of my pocket. Really hope that puts the end to this annoying problem. I just hope the remaned trans was done right and there isnt something else knowing my luck.
Awesome!
Reply With Quote
  #629  
Old 05-19-2013, 12:16 AM
H F H F is online now
Officially Welcomed to the 'Fest
Location: Claremont California
 
Join Date: Mar 2010
Posts: 1,954
Mein Auto: 2005 545i
Quote:
Originally Posted by djray77 View Post
Yes it is, I hate most stealerships be I trust they know BMW's better than any other shop.
If they havent dropped ur tranny yet.. If it was my car.. Change the rear coolant passage cover pan gasket... u have to drop the trany,,, take the flywheel out to get to it.. Preventive maintanence while the trany is down.. Will be good money well spent ..
__________________
Reply With Quote
  #630  
Old 05-19-2013, 01:51 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
Quote:
Originally Posted by H F View Post
If they havent dropped ur tranny yet.. If it was my car.. Change the rear coolant passage cover pan gasket... u have to drop the trany,,, take the flywheel out to get to it.. Preventive maintanence while the trany is down.. Will be good money well spent ..
Agree x10000%!!

It's next to nothing in additional parts or labor. Have them replace this. Happily pay for this out of pocket
Reply With Quote
  #631  
Old 05-21-2013, 04:02 PM
djray77 djray77 is offline
Registered User
Location: Mi
 
Join Date: Apr 2013
Posts: 5
Mein Auto: 2004 545i/sport pkg
Well **** I just read this and I have my car back
Reply With Quote
  #632  
Old 06-04-2013, 12:36 PM
BusEngineer BusEngineer is offline
Registered User
Location: Atlanta
 
Join Date: Mar 2012
Posts: 2
Mein Auto: 323IS-529I
I have the same transmission surge problem on my E60. Has anyone had a luck by changing
the transmission fluid. Who else can update the transmission program?
Reply With Quote
  #633  
Old 06-04-2013, 12:45 PM
Jay25 Jay25 is offline
Registered User
Location: NYC
 
Join Date: Nov 2011
Posts: 35
Mein Auto: 2004 BMW 530i
My remedy was to replace with a new transmission at the dealership.
Reply With Quote
  #634  
Old 06-17-2013, 03:53 PM
djray77 djray77 is offline
Registered User
Location: Mi
 
Join Date: Apr 2013
Posts: 5
Mein Auto: 2004 545i/sport pkg
Yea my remedy was the same as Jay25
Reply With Quote
  #635  
Old 06-18-2013, 08:43 AM
BusEngineer BusEngineer is offline
Registered User
Location: Atlanta
 
Join Date: Mar 2012
Posts: 2
Mein Auto: 323IS-529I
Transmission jolts upon acceleration at 40 MPH

Thanks guys for sharing your solution. I was looking for how to repair it instead of replacing the transmission. I am wondering if changing solenoids and seals will solve the problem.
Reply With Quote
  #636  
Old 06-18-2013, 11:41 AM
H F H F is online now
Officially Welcomed to the 'Fest
Location: Claremont California
 
Join Date: Mar 2010
Posts: 1,954
Mein Auto: 2005 545i
Quote:
Originally Posted by BusEngineer View Post
Thanks guys for sharing your solution. I was looking for how to repair it instead of replacing the transmission. I am wondering if changing solenoids and seals will solve the problem.
It most likely will member shpenxel changed his out and solved his shifting issues.
here he is in action check it out...

__________________

Last edited by H F; 06-18-2013 at 11:43 AM.
Reply With Quote
  #637  
Old 07-10-2013, 01:08 AM
93 525 Paul 93 525 Paul is offline
Registered User
Location: Fresno
 
Join Date: Jun 2013
Posts: 10
Mein Auto: 525i 550i 2002c
Schpenxel Rocks

Hey All:
Long timer over at an E34 board and bought an 07 550i w 66k miles earlier this year. Had noticed both a delay on going into reverse and the odd hiccup at 37mph but hadn't thought much of either.
Then I spent hours today reading the hundreds and hundreds of posts in this thread. Was horrified at the 2009 posts, then relieved when I read some of the $1500 fix posts then overjoyed when I watched schpenxel tackle this b*tch in his freaking driveway. God hates a coward and Schpenxel has real courage.
I think I have it fairly in hand except for the reset adaptation procedure. Can you help me out on that as well?
Reply With Quote
  #638  
Old 07-10-2013, 05:23 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
For that you need a DCAN cable and INPA software. I'll post more info in a bit
Reply With Quote
  #639  
Old 07-10-2013, 05:40 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
You need this cable:

http://www.one-stop-electronics.com/...&product_id=16

Others work, but this is the "golden standard" so to speak that everyone uses and it works great.

Then you need to get INPA installed.. follow this guide:

http://bmwcoders.com/forum/bmw-gt1-o...-software-328/

Once you get that done let us know--basically after that you'll just hook everything up and open INPA, select your vehicle model, go to transmission and there's an option in there somewhere to reset adaptations
Reply With Quote
  #640  
Old 07-26-2013, 11:30 PM
Rpman69 Rpman69 is offline
Registered User
Location: New York
 
Join Date: Mar 2013
Posts: 7
Mein Auto: 2004 BMW 545i
Quote:
Originally Posted by WJGreer View Post
If you turn the key to position 2 (where all the power is on, but do not start the car), then push the throttle all the way down and hold it for 60-90 seconds, the car resets the information that the transmission has "learned" about your driving and begins anew.
Do you know if I can do that on my 2004 BMW 545i ? Hold the accelerator down for 60-90 seconds and the tranni will reprogram ?????
Reply With Quote
  #641  
Old 08-05-2013, 10:52 AM
Sid58 Sid58 is offline
Registered User
Location: Harare
 
Join Date: Jul 2013
Posts: 24
Mein Auto: 545i
Re: 05 545i Transmission Surging Issues help!

my 545i 2003 model also has a similar problem bmw south africa dont repair anything and suggested i replace the gear box at a cost of $4000 you will find that your solonoids might be blocked

Sent from my GT-S5300 using BimmerApp mobile app
Reply With Quote
  #642  
Old 08-05-2013, 11:56 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
Quote:
Originally Posted by Sid58 View Post
my 545i 2003 model also has a similar problem bmw south africa dont repair anything and suggested i replace the gear box at a cost of $4000 you will find that your solonoids might be blocked

Sent from my GT-S5300 using BimmerApp mobile app
In my case on the solenoids that were supposed to be closed when no electricity was applied, I could blow some amount of air through them. On the new ones I couldn't get a bit through them..

I'm not sure if they get clogged or if they wear out and start leaking
Reply With Quote
  #643  
Old 08-07-2013, 07:35 PM
nyjam530i nyjam530i is offline
Registered User
Location: New York
 
Join Date: Jul 2013
Posts: 8
Mein Auto: 530i
I have a question regard transmission oil. I have a 2005 530i and so far no issues with the transmission. The car has 116k. I took it to the dealer for a battery cable recall and I had asked about changing the transmission oil. They looked at me funny and said, they never do this. However, I have been to 2 independent shops and both owners recommend changing the oil. What do you guys have to say on this?
Reply With Quote
  #644  
Old 08-07-2013, 07:42 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
Quote:
Originally Posted by nyjam530i View Post
I have a question regard transmission oil. I have a 2005 530i and so far no issues with the transmission. The car has 116k. I took it to the dealer for a battery cable recall and I had asked about changing the transmission oil. They looked at me funny and said, they never do this. However, I have been to 2 independent shops and both owners recommend changing the oil. What do you guys have to say on this?
First, find a new dealer.

BMW used to call the transmission fluid a "lifetime" fluid.. they have since revised lifetime to mean 100K miles.. so you're due in my opinion

I'd change the oil & filter using a kit from thectsc.com. Reset adaptations afterwards. Some say using other oils is fine, etc. etc. but I've never thought it was worth the risk when you only change it a few times over the life of the car

Oh, and I'm up to 202K miles by the way, 2004 545i. Original transmission

Last edited by schpenxel; 08-07-2013 at 07:50 PM.
Reply With Quote
  #645  
Old 08-07-2013, 07:51 PM
nyjam530i nyjam530i is offline
Registered User
Location: New York
 
Join Date: Jul 2013
Posts: 8
Mein Auto: 530i
Quote:
Originally Posted by schpenxel View Post
First, find a new dealer.

BMW used to call the transmission fluid a "lifetime" fluid.. they have since revised lifetime to mean 100K miles.. so you're due in my opinion

I'd change the oil & filter using a kit from thectsc.com. Reset adaptations afterwards. Some say using other oils is fine, etc. etc. but I've never thought it was worth the risk when you only change it a few times over the life of the car

Oh, and I'm 202K miles by the way, 2004 545i. Original transmission
Thanks man! I will certainly get it changed. I will ask one of the techs at the dealer, maybe the service advisor was mistaken. If the dealer won't do it, then I will go to the independent shop.

Funny enough, I owned a Nissan Maxima as well and I was told that I should never change the transmission oil too. However, after it started began to slip a little I took it to a local mechanic who changed it and I have been fine since.

Btw, 202k miles is solid. I have a 2004 325XI with 157k miles and I just noticed an oil leak.
Reply With Quote
  #646  
Old 08-07-2013, 07:55 PM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
I've read the "never change it.. it will self destruct afterwards" thing a few times.. and after I changed mine the first time, I had a lot of problems so I was regretting having changed it. I basically couldn't use 5th gear any more..It would buck and slam back and forth between gears every few seconds, so I had to manually basically skip over 5th as fast as I could.. HOWEVER, after I finally got my INPA cable I was able to reset adaptations, and that went away. A little later I changed the solenoids too and that got rid of all the errors I was getting and made it so much smoother than it shifted before. It's been find ever since (about 20K miles now)

I think changing tranny fluid gets a bad rap because people never do it until something is already on the way out.. then the transmission stops working right after they change it and they try to blame it all on that, when it was really because they didn't change it 150K miles earlier.

Anyways, enough of that rant That's good mileage out of her!

speaking of which.. I'm probably going to change my fluid again either at the next oil change or the next one.
Reply With Quote
  #647  
Old 08-08-2013, 07:11 AM
elektron82 elektron82 is offline
Anfynger
Location: Florida
 
Join Date: Nov 2012
Posts: 12
Mein Auto: 05 545i
Post Slip and flush

Just went to a local indy shop and they said my pan was real clean on the outside so no sign of leaks. They will do a power flush without dropping the pan for $200. They will drop the pan and change the filter and fluid with flush for $500. Some of the other items they quoted seemed reasonable and based on my conversation they seem to be trustworthy.

I am of the thought that these units tend to leak and the loss of fluid leads to issues. I can imagine a lot of shops not flushing or replacing fluid properly according to the strict BMW procedure and actually causing problems.

I have started to notice in the morning on cold start and take off from a stop sign it seems like the engine is decoupled from the transmission and I hit the gas pedal too quickly and the engine revs up like its in neutral. It gets to about 2-2500 rpm's and then slams together like dumping a clutch and breaks a little traction.

The decoupling is actually a feature for saving fuel while stopped right?
Reply With Quote
  #648  
Old 08-08-2013, 07:12 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
Are they going to power flush with zf fluid?
Reply With Quote
  #649  
Old 08-08-2013, 04:16 PM
BeameD BeameD is offline
Registered User
Location: ATL-GA
 
Join Date: Nov 2007
Posts: 20
Mein Auto: 2005 545i
The transmission safe-mode recently popped up on my '05 i545 as I was taking off. I cut the car off and cut it back on and the message disappeared, but I noticed that the car would kind of hesitate before taking off. Parked the car in the garage and was getting ready to drive it to the dealership when I got a 'transmission malfunction' warning message in red with the exclamation. I turned the car off and back on again and the message disappeared again, but when I put the car in 'Drive' the car didn't move and the engine just reved as I pressed the gas. I pressed the gas pedal a little harder as the RPMs rose and the car started to slowly creep forward. I also noticed a whirring sound that got louder as I gave the car more gas.

Does this sound like an issue that might be solved by replacing the solenoids?

I figured I would try to change fluid and transmission filter after 131,000 miles, thinking it had not been done. After dropping the undercarriage cover, I didn't find any transmission leaks anywhere. The bottom of the filter looked as if it had been changed. One of the bolts had been stripped and a few appeared replaced. I purchased the car from BMW used 6yrs ago w/34,000 miles on it and I never had the transmission filter replaced.

Now I'm contemplating paying the dealership to diagnose the issue or put that money towards purchasing diagnostic cable & software and read the code(s) myself.
Reply With Quote
  #650  
Old 08-09-2013, 07:15 AM
schpenxel schpenxel is offline
DIY'er
Location: Greensboro, NC
 
Join Date: Nov 2009
Posts: 3,313
Mein Auto: 2004 545i
I would try putting it over into "manual" mode and try 1 2 and 3 (I think you can get to 3 while sitting still..). Let us know what happens

First also of course check transmission fluid level (easier said than done on these things..)

Also, get a list of the codes
Reply With Quote
Reply

Bookmarks

Tags
advice, bmw 5 series, issues, tranny problems


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E60 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:44 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms