Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Do-It-Yourself H.Q.

Do-It-Yourself H.Q.
Share your DIY projects or ask questions about how to fix something on your own. Help fellow Bimmerfest members improve your wrench turning skills! All BMW DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Display Modes
  #1  
Old 05-21-2013, 05:04 PM
Pulsar Pulsar is offline
Registered User
Location: PHILADELPHIA
 
Join Date: May 2013
Posts: 1
Send a message via ICQ to Pulsar
Mein Auto: 2001 528i
Aftermarket audio & turn signals/AC

Hey... my girlfriend has a 528i with a bunch of aftermarket audio equipment, installed by a number of different places. At some point, someone screwed something up and the car has some pretty weird electrical problems now.

Hazards work externally at all times. Dashboard indication and clicking sound for hazards and turn signals work only when car is off/during the first few seconds after turning key to accessory/run.

AC blows, but never gets cool. Have not tried refrigerant yet. Girlfriend says dealer checked refrigerant. Might try anyway in future.

Checked all fuses. Removed fuses going to aftermarket amp and subwoofers... no change.

Reverse lights do not turn on.

What is weird is if I turn the hazards on, pop the trunk, and listen to the relays while my girlfriend turns the key from off to accessory, there is a click that corresponds exactly to the loss of dash indicator function. I hear a click when she turns the key, then several seconds later, another click at the exact same time the dash hazard indicators go out. Completely reproducible.

Any ideas? I am stumped.

Thanks
Reply With Quote
Advertisement
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Do-It-Yourself H.Q.
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms