Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)

E90/E91/E92/E93 (2006 - 2013)
The E9X is the 4th evolution of the BMW 3 series including a highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! -- View the E9X Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 06-05-2013, 09:32 AM
Stape Stape is offline
Registered User
Location: Temecula
 
Join Date: Jun 2013
Posts: 5
Mein Auto: 325i
Expansion Valve

I'm having intermittent problems with the A/C. Sometimes it works (usually when the car is cold) and somtimes it doesn't. The system was low so I serviced it with a can from Autozone. Initially, it worked fine but now it's hit or miss. I've been told the most common problem with this system is the expansion valve and the temperature sensor. The temp is working fine. Anyone had similar problems or have any suggestions?

Thanks,
Stape
Reply With Quote
Ads by Google
  #2  
Old 06-05-2013, 09:49 AM
3two8iguy's Avatar
3two8iguy 3two8iguy is offline
Officially Welcomed to the 'Fest
Location: Somewhere between New York & Raleigh
 
Join Date: May 2013
Posts: 310
Mein Auto: 2011 E90 328i sedan
When you mention low,do you mean low in refrigerant?if so how do you know it was low?If you did check your system with guages and it was low than you have a leak,refrigerant does not evaporate.What model?What year?If you want answers then you must supply the wizards on this forum with information,thankyou.
__________________
Life is a Journey,Enjoy your ride.

Last edited by 3two8iguy; 06-05-2013 at 09:53 AM.
Reply With Quote
  #3  
Old 06-05-2013, 10:18 AM
Stape Stape is offline
Registered User
Location: Temecula
 
Join Date: Jun 2013
Posts: 5
Mein Auto: 325i
Expansion valve

I appreciate the quick response. I noticed the air stopped blowing cold on a road trip last weekend. I checked the system via the low pressure port (I think this would be the refrigerant) with the guage that came on the bottle I purchased from Autozone. It wasn't extremely low but it wasn't within the triangle they provided in the directions. Initially after I serviced it, it was blowing really cold air like it used too, then on the return trip it stopped blowing cold again. This morning, after I started the car, it was blowing cold again. The compressor kicks on fine. It seems like it works fine when you first start the car.

06 325i, 6speed, sport package.

Last edited by Stape; 06-05-2013 at 10:19 AM.
Reply With Quote
  #4  
Old 06-05-2013, 11:11 AM
tony(topaz,SMG) tony(topaz,SMG) is offline
Officially Welcomed to the 'Fest
Location: Atlanta
 
Join Date: Feb 2005
Posts: 125
Mein Auto: '11 335i,'02 M3, '08 X5,
You are going to need someone with some A/C experience and a set of gauges (high and low ports) to correctly identify the problem you're having.
Reply With Quote
  #5  
Old 06-24-2013, 11:32 AM
Stape Stape is offline
Registered User
Location: Temecula
 
Join Date: Jun 2013
Posts: 5
Mein Auto: 325i
The A/C would initially work on the car when the engine was cold. After the engine compartment warmed up it would cause the Expansion Valve to get stuck. I have since replaced the valve and recharged the system and everything is working great! Expansion Valve is not to difficult to replace and it cost about $30. I had to pay $50 to have a garage discharge the system before I replaced the valve and then I bought a bottle of A/C Pro from Autozone and recharged the system. The only other item I had to purchase (because I didn't have one) was a socket with a 6mm hex key (also bought at Autozone). There are several models of this valve so be sure that the store orders the correct one for your car. I had to go back to Autozone because apparently their system had four different valves for my car. My suggestion is to remove the valve and take it into the store. It's ok to drive the car, just don't try to turn on your A/C. Hope this information helps. Any questions please don't hesitate.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E90/E91/E92/E93 (2006 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms