Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-03-2013, 09:15 AM
Helgason Helgason is offline
Registered User
Location: Iceland
 
Join Date: Jul 2013
Posts: 41
Mein Auto: E39 535i Shadowline
ABS + ASC lights turn on after a few minutes

Hello there guys, how are you.

I'm having troubles with the car I just bought.

I bought it knowing that the ABS was not working properly and I hoped it just was only a sensor problem. Both the ABS + ACS were always on.

I went to my local BMW workshop and had the car computer codes read.
They told me there were error codes on left+right front wheels.

They reset the codes, so the lights went off.
When I was driving from the workshop the brakes went on when I was driving, so couldn't move the car properly until the ABS light got on again. When it came on again the car worked fine, except the lights were back on.

So I took out both the sensors(man it took a while to get them out), and replaced them with new ones.

When I started the car, the ABS light was still on, so I shut it on and off a few times and took a test drive. The lights went out for about a minute and came back on.

So after I replaced the ABS sensors, the problem has changed.
When I start the car now, both the lights are out.
However, when I push the brakes on a dry street, the ABS kicks in and my pedal vibrates(like I was breaking on a slippery surface).
The ABS then keeps kicking in the first 1-3 minutes I drive, then the ABS light come back on and the brakes function properly.

I'm just wondering what to do next.
I'm going to have the computer read again and see if it has the same error codes.

Do you have any ideas on how to fix this problem?
Reply With Quote
Advertisement
  #2  
Old 07-03-2013, 10:07 AM
Burning2nd Burning2nd is offline
Under the lift arms
Location: Under the lift arms
 
Join Date: Aug 2010
Posts: 4,511
Mein Auto: E39 540, E36 328is, E83x3
It's going in to default mode

It shuts it self down when it has voltage problems

You need to get your self a Bentley manual
Do some testing at the sensors
Do some testing at the module

Stop throwing parts at it
__________________
Specializing In BMW, Audi, Mercedes Benz ,Volkswagen, Volvo

"Burning 2nd is a lot like vitamin tonic. Overly harsh, tastes like crap, but somewhere in all that there's good intent......just have to learn to read between the lines, actually you have to squint really hard to see the good, but its there somewhere"
Reply With Quote
  #3  
Old 07-04-2013, 09:06 AM
Helgason Helgason is offline
Registered User
Location: Iceland
 
Join Date: Jul 2013
Posts: 41
Mein Auto: E39 535i Shadowline
Thanks for the response.
Just downloaded the manual and man, it's something. Will talk to my mech's about this.
Reply With Quote
  #4  
Old 07-04-2013, 02:35 PM
HTK12 HTK12 is offline
Officially Welcomed to the 'Fest
Location: Finland
 
Join Date: Aug 2012
Posts: 859
Mein Auto: E39 540i
Since you only got asc on a V8 I assume it's <-8/98 model. These older models rarely have abs module issues. This could be just an electric gremlin so first clean battery posts and cables. Make sure battery cables are tight. Check all ground connections in the engine bay. Load test the battery & check the altenator. What brand are the replacement abs sensors?
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms