Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 06-14-2013, 05:20 AM
jviss jviss is offline
Registered User
Location: Westborough, MA
 
Join Date: Nov 2008
Posts: 81
Mein Auto: '06 X3
HTC One and 2006 X3 won't pair (bluetooth)

Just got an HTC One via T-Mobile. I tried several times to pair it with the X3, and never got to first base - the HTC never sees the X3 bluetooth. Has anyone successfully paired these two, who might give me a hint as to what I'm doing wrong?

What I've tried are various combinations of starting the car and telling the phone to 'scan for devices.' First scan for devices then start; start, then initiate scan. No luck. The phone's bluetooth never sees the car. It was working moments before with my iPhone 4, and has been working for the last 4 years with that phone and previous an iPhone 3. I had to occasionally reset the bluetooth by unplugging and replugging the module connector in the back, left storage compartment, maybe 3 or 4 times in the last 4+ years.

Any help is sincerely appreciated!

Thanks,

jv

Last edited by jviss; 06-14-2013 at 05:21 AM. Reason: typo
Reply With Quote
Advertisement
  #2  
Old 06-14-2013, 06:19 AM
vern vern is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Apr 2002
Posts: 4,739
Send a message via AIM to vern
Mein Auto: 01 330ci 05 530i 06 X3
Quote:
Originally Posted by jviss View Post
Just got an HTC One via T-Mobile. I tried several times to pair it with the X3, and never got to first base - the HTC never sees the X3 bluetooth. Has anyone successfully paired these two, who might give me a hint as to what I'm doing wrong?

What I've tried are various combinations of starting the car and telling the phone to 'scan for devices.' First scan for devices then start; start, then initiate scan. No luck. The phone's bluetooth never sees the car. It was working moments before with my iPhone 4, and has been working for the last 4 years with that phone and previous an iPhone 3. I had to occasionally reset the bluetooth by unplugging and replugging the module connector in the back, left storage compartment, maybe 3 or 4 times in the last 4+ years.

Any help is sincerely appreciated!

Thanks,

jv
Try removing the battery from your phone for 30 seconds or so that will let your phone reboot then try pairing again. It worked for me on my phone. Samsung M400. Good luck
cheers
vern
__________________
2012 335iA Blk. Sapphire- Sport-Blk. Dakota Leather/Red-Brushed Alum.Trim-DAP-PP-CWP Rear View Camera-BMW Asst w/Enhanced BT&USB-High Gloss Blk.Trim Hghight-PSP-Speed Limit Info-Tech. Pkg-PDC-Rear Manual Sun Shades-SAT-Variable Sport Steering-Wheel Locks- Rubber Mats-Euro Del 5/14/12-Redelivery 7/16/12 2006 X3 3.0iA 4/6 Silver Gray Metallic-Black Leather-Nav-PP-SP-Xenon Headlights-PDC-Heated Front Seats-Privacy Glass-Servotronic Steering-Premium Sound System-R R R- Wheel Locks- Rubber Mats
Reply With Quote
  #3  
Old 06-14-2013, 07:22 AM
jviss jviss is offline
Registered User
Location: Westborough, MA
 
Join Date: Nov 2008
Posts: 81
Mein Auto: '06 X3
Thanks, but it's a brand new phone, and I don't think it's trivial to remove the battery. I don't think there's anything wrong with the phone, it paired to my computer fine.
Reply With Quote
  #4  
Old 06-14-2013, 11:02 AM
joylove joylove is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Mar 2013
Posts: 997
Mein Auto: 08 e83 LCI
A full power down of both units might help, but consider that teh BT in the HTC is some new BT 4.0LE or something which is too clever for the old CSR module in the car an a firmware update might be needed to address backwards compatibility.
Reply With Quote
  #5  
Old 06-15-2013, 06:16 AM
vern vern is offline
Officially Welcomed to the 'Fest
Location: New Jersey
 
Join Date: Apr 2002
Posts: 4,739
Send a message via AIM to vern
Mein Auto: 01 330ci 05 530i 06 X3
Quote:
Originally Posted by jviss View Post
Thanks, but it's a brand new phone, and I don't think it's trivial to remove the battery. I don't think there's anything wrong with the phone, it paired to my computer fine.
If the battery is new or not it don't make a difference you looking to " reboot" the phone. Like I said it worked for me Good luck
cheers
vern
__________________
2012 335iA Blk. Sapphire- Sport-Blk. Dakota Leather/Red-Brushed Alum.Trim-DAP-PP-CWP Rear View Camera-BMW Asst w/Enhanced BT&USB-High Gloss Blk.Trim Hghight-PSP-Speed Limit Info-Tech. Pkg-PDC-Rear Manual Sun Shades-SAT-Variable Sport Steering-Wheel Locks- Rubber Mats-Euro Del 5/14/12-Redelivery 7/16/12 2006 X3 3.0iA 4/6 Silver Gray Metallic-Black Leather-Nav-PP-SP-Xenon Headlights-PDC-Heated Front Seats-Privacy Glass-Servotronic Steering-Premium Sound System-R R R- Wheel Locks- Rubber Mats
Reply With Quote
  #6  
Old 06-15-2013, 10:33 AM
Kit Fox Kit Fox is offline
Registered User
Location: Illinois
 
Join Date: Jun 2013
Posts: 13
Mein Auto: 2005 BMW X3
Try to repair your iPhone again see if that works, if it is that then the module in the car itself seems to be fine.

Regardless of results, some have found disconnecting the module (in the trunk, left side), and reconnecting it a bit later helpful.

Should it not be the module itself (if you can pair a different phone), the issue may be on your phone's side. Consider contacting an android forum. As someone mentioned above, the HTC ONE, uses the 4.0 Bluetooth system which may be "too advanced".
Reply With Quote
  #7  
Old 06-15-2013, 02:54 PM
jerry325 jerry325 is offline
Registered User
Location: Lima, OH
 
Join Date: Jan 2005
Posts: 57
Mein Auto: 2006 X3 Blue & silv.325ci
Jviss, successfully paired my HTC one with my 06. The key is to switch the ignition to the on position, but DO NOT START the car, then have the phone search for the BMW connection. You may have to have the phone search for the BMW connection a few times. Keep the ignition in the second position while trying and you should have success! Nice phone!
Reply With Quote
  #8  
Old 06-16-2013, 07:31 AM
X3emist's Avatar
X3emist X3emist is offline
Officially Welcomed to the 'Fest
Location: NW Georgia USA
 
Join Date: Nov 2009
Posts: 1,311
Mein Auto: 06 X3 Sport
Read this

http://www.bimmernav.com/BMW_X3_Blue...tructions.html
__________________
2006 X3 Silver Grey/Black Lthr/Alum Trim/Sport Prem Pkg/Xenons/Servotronic/Prem Sound/Satellite Radio/Heated Seats/Carbon Fiber Pillars/Blue Tooth/Aux In/Cargo Net/Aluminum Pedals/V1 Hardwired
[SIGPIC]
Reply With Quote
  #9  
Old 07-09-2013, 03:03 PM
jviss jviss is offline
Registered User
Location: Westborough, MA
 
Join Date: Nov 2008
Posts: 81
Mein Auto: '06 X3
Solved. Thanks for the input on this. I just kept trying and trying the pairing and connection dance, and it finally stuck. I can't say for sure what exactly I did.

The phone book never finishes loading, though, but at least it's connected.
Reply With Quote
Reply

Bookmarks

Tags
bluetooth, htc, pairing, pairing phone


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms