Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 07-09-2013, 12:44 PM
Reeds 540 Reeds 540 is online now
Registered User
Location: South Bend
 
Join Date: Jan 2013
Posts: 19
Mein Auto: 2000 540i
Just got trans fail safe prog error on my 2000 540i no hint of driving problem prior.

Sent from my SCH-I535 using BimmerApp mobile app
Reply With Quote
Advertisement
  #2  
Old 07-09-2013, 02:35 PM
edjack edjack is offline
Officially Welcomed to the 'Fest
Location: San Jose, CA
 
Join Date: May 2007
Posts: 9,702
Mein Auto: '97 540i 6 speed
Get the codes read.
__________________


Ed in San Jose '97 540i 6 speed aspensilber over aubergine leather. Build date 3/97. Golden Gate Chapter BMW CCA Nr 62319.
Reply With Quote
  #3  
Old 07-09-2013, 09:16 PM
Reeds 540 Reeds 540 is online now
Registered User
Location: South Bend
 
Join Date: Jan 2013
Posts: 19
Mein Auto: 2000 540i
Codes for trans fail safe program

A couple of these are old as I have needed a cam position sensor for a while, but I included all that came up. P0348 P174 P0600 P0171. Since last post the fail safe error went away when restarted, then returned after a few minutes. it is definitely going into some kind of safe mode as shifting is different. feels like its slowly easing into a higher gear from stop. also the Brake and ABS lights have come on and stayed on even when trans fail safe program went away. throw in speedometer and tachometer and temp gauge stopping from time to time. I did top off the Brake and trans fluid which were a little low, just at the low side limit markings. Battery holds a charge fine. we'll see what it does tomorrow. I prefer doing maintenance my self, and often replace a part or two for a likely problem, before spending the big $$$ on Mechanic. Thanks for any advice.
Reply With Quote
  #4  
Old 07-09-2013, 09:20 PM
Reeds 540 Reeds 540 is online now
Registered User
Location: South Bend
 
Join Date: Jan 2013
Posts: 19
Mein Auto: 2000 540i
Battery alternator

I researched several other posts about this warning, and they seemed to indicate alternator and battery as potential problems. I don' completely understand how this could be if Battery is holding a charge just fine and staying recharged wit normal use. If there is a fusible link or other related issue to check let me know.
Reply With Quote
  #5  
Old 07-10-2013, 04:07 AM
HTK12 HTK12 is offline
Officially Welcomed to the 'Fest
Location: Finland
 
Join Date: Aug 2012
Posts: 915
Mein Auto: E39 540i
Quote:
Originally Posted by Reeds 540 View Post
I researched several other posts about this warning, and they seemed to indicate alternator and battery as potential problems. I don' completely understand how this could be if Battery is holding a charge just fine and staying recharged wit normal use. If there is a fusible link or other related issue to check let me know.
I had trans failsafe due to failing battery. The battery did start the car just fine.. Battery resting voltage was ~12V, when it should be 12.4V+. Replaced the battery and haven't had issue since. These cars are really sensitive to electrical issues, so first check the alternator & battery.

What kind of scanner did you use? Which diagnostic port?
Reply With Quote
  #6  
Old 07-10-2013, 06:18 AM
Reeds 540 Reeds 540 is online now
Registered User
Location: South Bend
 
Join Date: Jan 2013
Posts: 19
Mein Auto: 2000 540i
I just had codes scanned a autozone. Not many service choices here other than dealer.
Reply With Quote
  #7  
Old 07-10-2013, 06:20 AM
Reeds 540 Reeds 540 is online now
Registered User
Location: South Bend
 
Join Date: Jan 2013
Posts: 19
Mein Auto: 2000 540i
Assuming the guys at autozone don't know how. what is the procedure for checking the resting voltage on the battery. I am wary of disconnecting it for fear of loosing codes to radio and other electronics. I am at least the third owner of the car and not sure they are available.
Reply With Quote
  #8  
Old 07-10-2013, 06:21 AM
Reeds 540 Reeds 540 is online now
Registered User
Location: South Bend
 
Join Date: Jan 2013
Posts: 19
Mein Auto: 2000 540i
I have a basic voltage meter at the house.
Reply With Quote
  #9  
Old 07-10-2013, 07:17 AM
Burning2nd Burning2nd is offline
Under the lift arms
Location: Under the lift arms
 
Join Date: Aug 2010
Posts: 4,730
Mein Auto: E39 540, E36 328is, E83x3
Your looking or 12vdc when the car is off and nothing is turned on .

Your looking for 13.8-14.6vdc when te car is running (depending on load )

If you have a voltage load tester you can test the battery's performance when the car is off
"Load test"
__________________
Specializing In BMW, Audi, Mercedes Benz ,Volkswagen, Volvo

"Burning 2nd is a lot like vitamin tonic. Overly harsh, tastes like crap, but somewhere in all that there's good intent......just have to learn to read between the lines, actually you have to squint really hard to see the good, but its there somewhere"

15486372<-----
Reply With Quote
  #10  
Old 07-10-2013, 11:18 AM
m1gunr m1gunr is offline
Registered User
Location: Tacoma
 
Join Date: Jul 2013
Posts: 10
Mein Auto: 530i
my tranny issues started when the alternator was failing. Once replaced, issues went away.
Reply With Quote
  #11  
Old 07-10-2013, 01:06 PM
HTK12 HTK12 is offline
Officially Welcomed to the 'Fest
Location: Finland
 
Join Date: Aug 2012
Posts: 915
Mein Auto: E39 540i
Quote:
Originally Posted by Reeds 540 View Post
I just had codes scanned a autozone. Not many service choices here other than dealer.
So most likely their scanner can't read transmission codes. So get the codes pulled with a proper scanner. You'll need to use the 20 pin diagnostic port that is in the engine bay.
Reply With Quote
  #12  
Old 07-13-2013, 12:23 PM
avu3 avu3 is offline
Officially Welcomed to the 'Fest
Location: Fairfield, Kali
 
Join Date: Jul 2011
Posts: 100
Mein Auto: '02 540iA Sport
I'm another who had transfailure warning and limp mode as first signs of failing batteries and alternators.

Retrospectively, I knew how long my alternator was not working right based on progressively poor shifting.
I was able to pre-diagnose a subsequent alternator failure based on the trans performance

Rule that out, those are both much simpler fixes than the trans.

If you get the battery load tested on the car, don't do it at the jump points. Do it at the battery. The parts store testers seem to be tricked by the cable run.

Scott
Reply With Quote
  #13  
Old 07-13-2013, 07:17 PM
rcmarty rcmarty is offline
Registered User
Location: Penticton B.C. Canada
 
Join Date: Oct 2011
Posts: 25
Mein Auto: 03 540 M sport
Don't for get the visor test for a bad ignition switch

Martin
Reply With Quote
  #14  
Old 07-14-2013, 11:35 AM
Reeds 540 Reeds 540 is online now
Registered User
Location: South Bend
 
Join Date: Jan 2013
Posts: 19
Mein Auto: 2000 540i
Already replaced the ignition switch. Found a decent BMW Mechanic and left it with him. I had some front end parts replaced recently and since ABS and brake lights were also on he said that may be the issue. Still don't understand how a battery that is staying charged by alternator could cause the problem. Then again, I didn't understand how my wife using lighted vanity mirror could shut off radio and make steering wheel go up and down! I will post findings when repairs complete. Thanks again for help.
Reply With Quote
  #15  
Old 07-14-2013, 07:58 PM
avu3 avu3 is offline
Officially Welcomed to the 'Fest
Location: Fairfield, Kali
 
Join Date: Jul 2011
Posts: 100
Mein Auto: '02 540iA Sport
Quote:
Originally Posted by Reeds 540 View Post
Still don't understand how a battery that is staying charged by alternator could cause the problem. Then again, I didn't understand how my wife using lighted vanity mirror could shut off radio and make steering wheel go up and down! I will post findings when repairs complete. Thanks again for help.
The Trans stuff and alternator/battery is from voltage irregularities. Caused by an alternator not putting out the right voltage/current and/or the battery not accepting the charge at the rate that it should.

The vanity mirror sounds like a short/shorted wires.

S
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms