Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - 2014)

X6 E71 / E72 (2008 - 2014)
The BMW X6 luxury crossover went on sale in April 2008 as a 2009 model year. BMW referes to the X6 as a Sports Activity Coupe (SAC) as it combines the attributes of an SUV (high ground clearance, xDrive and all-weather ability) with the stance, styling and roof line shape of a coupe. The E71 X6 was built off the E70 X5 (2007 - 2013) platform at BMW's Spartanburg, SC plant. Total worldwide sales were just over 235,000, sold mostly to the BRIC countries. US total sales was 34,082 vehicles.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2013, 09:34 AM
Abummer Abummer is offline
Registered User
Location: Dallas
 
Join Date: Jun 2013
Posts: 7
Mein Auto: 2009 X6
Thumbs down X6 Fuel Pump issue

My wife and children were in the car when they attempted to turn across traffic on a very busy street in Dallas. When oncoming traffic allowed, they attempted and the car immediately "shut down". Leaving them about 3 feet in the left lane of oncoming traffic. Message dash stated the fuel pump was inoperable. She immediately called me and was terrified to get out of the car, due to traffic i arrived 15 miutes later to get them out of the car and transfer them to my car. I tried starting the car to only have it shut down immediately. This happened 3 days after getting the car out of the shop after the fuel pump was replaced. This same issue occurred about 1 week earlier. Fortunately, my wife was in a parking lot.
Judging by the amount of issues that I found online, this seems to be a major concern.
Any thoughts?

Abummer
Reply With Quote
Advertisement
  #2  
Old 06-13-2013, 08:34 AM
Abummer Abummer is offline
Registered User
Location: Dallas
 
Join Date: Jun 2013
Posts: 7
Mein Auto: 2009 X6
I need to clarify an earlier statement. I had mentioned "This happened 3 days after getting the car out of the shop after the fuel pump was replaced". It was actually 2days.
Reply With Quote
  #3  
Old 06-21-2013, 10:36 AM
Abummer Abummer is offline
Registered User
Location: Dallas
 
Join Date: Jun 2013
Posts: 7
Mein Auto: 2009 X6
As of tomorrow, the X6 described above will have been in the shop for two straight weeks. So to keep things simple, we have had the vehicle in our possession for 2 days this month between repairs. I have not heard from BMW of Dallas since Monday of this week. They contacted me 1 week ago to tell me that the repairs they tried had NOT eliminated the problem as the test drive resulted in the car stalling out. I have no idea what they are working on.
Reply With Quote
  #4  
Old 06-22-2013, 12:35 AM
dreamalaska dreamalaska is offline
Registered User
Location: Alaska
 
Join Date: May 2012
Posts: 24
Mein Auto: Lexus
X6 Fuel Pump issue

Thx for the update - good luck and keep us posted


Sent from BimmerApp mobile app
Reply With Quote
  #5  
Old 07-08-2013, 04:27 PM
morrocanx6 morrocanx6 is offline
Registered User
Location: MD
 
Join Date: Jul 2013
Posts: 2
Mein Auto: x6 3.5
I have had that issue with a 2010 X6 3.5 in california for 6 times withiin 5 months. all fuel pressure pump issues. BMW ended u replacing my car. seems to have been soemthing to fo with some washers being damaged with gas additives.
Reply With Quote
  #6  
Old 07-09-2013, 08:22 AM
Abummer Abummer is offline
Registered User
Location: Dallas
 
Join Date: Jun 2013
Posts: 7
Mein Auto: 2009 X6
I am happy to announce that after 7 long months, we are no longer burdened by the X6. After picking up the vehicle from the BMW of Dallas (servicing dealer), I drove across the street to Sewell and purchased a Lexus. making this the 5th Lexus we will have owned. Classic BMW understood my situation and we agreed on a trade in value, as I was not going to be buying another BMW. I am sure BMW makes good equipment, however, this car and the servicing dealer BMW of Dallas, could not have been more disappointing. Good luck!
Reply With Quote
  #7  
Old 07-14-2013, 03:37 PM
dreamalaska dreamalaska is offline
Registered User
Location: Alaska
 
Join Date: May 2012
Posts: 24
Mein Auto: Lexus
X6 Fuel Pump issue

Thanks for the update - sorry to hear about the ordeal...the Lexus will def come with peace of mind and at least 250,000 miles of reliable service...


Sent from BimmerApp mobile app
Reply With Quote
  #8  
Old 03-05-2014, 02:08 AM
ZAMBA CYP ZAMBA CYP is offline
Registered User
Location: cyprus
 
Join Date: Jul 2012
Posts: 3
Send a message via Skype™ to ZAMBA CYP
Mein Auto: bmw
i have a X6 Xdrive 3.0d (m57 engine). unfortunatly yesterday it did not start. honestly it starts than 5 second run than stops. are anybody has an idea????? still same
Reply With Quote
  #9  
Old 03-09-2014, 04:12 PM
sunnyj sunnyj is offline
Registered User
Location: South Africa
 
Join Date: Jan 2013
Posts: 9
Mein Auto: BMW X5 E70 3.0d
Perhaps failed injector. I got a similar problem. See thread http://www.bimmerfest.com/forums/sho...=1#post8199554
Reply With Quote
  #10  
Old 03-10-2014, 03:36 PM
ZAMBA CYP ZAMBA CYP is offline
Registered User
Location: cyprus
 
Join Date: Jul 2012
Posts: 3
Send a message via Skype™ to ZAMBA CYP
Mein Auto: bmw
I changed the hi pressure pump but it is not enough enjectors should have change. Anyway at the end it start but there is 5 points to check :
low fuel pressure
High pressure
High pressure pomp regulator
Rail pressure sensor
Enjectors
Reply With Quote
  #11  
Old 03-10-2014, 03:38 PM
ZAMBA CYP ZAMBA CYP is offline
Registered User
Location: cyprus
 
Join Date: Jul 2012
Posts: 3
Send a message via Skype™ to ZAMBA CYP
Mein Auto: bmw
Quote:
Originally Posted by sunnyj View Post
Perhaps failed injector. I got a similar problem. See thread http://www.bimmerfest.com/forums/sho...=1#post8199554
Thanks bro you are right
Reply With Quote
Reply

Bookmarks

Tags
fuel pump, x6


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - 2014)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms