Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)

E46 (1999 - 2006)
The fourth generation 3 Series (E46 chassis) was introduced in 1999 and set the standard for engineering and performance during it's years of production including being named to Car & Driver's 10 best list every one of those years! ! -- View the E46 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 08-03-2013, 07:11 AM
Megasquirter Megasquirter is offline
Registered User
Location: florida
 
Join Date: Oct 2012
Posts: 2
Mein Auto: 01 e46 330i
p0313, p1191, p1193 code ?'s

2001 bmw 330i
These are the codes ive been gettingP0313-Lack of fuelP1191-Manufacture specificP1193-manufacture specific
My*car*runs fine withh no noticable issues and ive done mostly all preventive maintence.After installing aftermarket headers(no cats) i knew i was going to throw the SES light. Before i got around to installing some defoulers on the post o2s my fuel pump went out. I replaced it with a new aftermarket one and its been fine. I installed the defoulers and After this i used my bros VW tool(program) on his laptop to check and clear the codes and i got these three. I assumed the lack of fuel code was from when the pump went out and i believe the p1191,p1193 was from the header. A day after i cleared the codes all three showed back up.So here are my questions;Could all three of these codes be caused from the headers alone?Is the lack of fuel code because installed an aftermarket fuel pump?Has anyone installed the defoulers and not have them worked succesfully to clear the codes?Could my pre o2 sensors have gone bad and thats why im still getting the codes,and what are the symptoms of a bad o2? I plan on getting tourqe pro and an obd2 to bluetooth adapter to help diagnose this issue and any future issues. Right now there are no drivability issues just the annoying light.
Im just trying to get to the bottom of this so i know what i should do next to get rid of the codes. Any help is appreciated. Thanks
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E46 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:43 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms