Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 08-30-2013, 02:54 AM
DanielS DanielS is offline
Registered User
Location: Amstelveen, The Netherlands
 
Join Date: Aug 2013
Posts: 4
Mein Auto: E34 - 525i, E46 328i, E39
E39 16:9 screen to hot and upgrade issues

Hi everybody, i've done some extensive searching with Google but came up empty handed.

My problem is that I bought a second hand 16:9 screen to replace the old (still working) 4:3 screen. Installing it in the E39 of my wife was easy... maybe to easy... in and out in 10 min, and that includes a cigaret brake.
Now after reconnecting the battery, and turning on the ignition the screen turns on and starts to dimm straight away and after about 3 min. It tells me that the screen has become to hot and then it just go's black. Any thoughts what this might be?

After this I wanted to install a MK4 unit but as the car is a touring my old antenne cable was not long enough so I decided to hookup the MK4 unit without the GPS antenne cable. But the MK4 unit just spins the disk and Sat-Nav function is not availible in the 3 min that I can look at the screen.
Offcourse I did install the MK4 unit with the battery disconnected.

Things i've already tried are:
Disconnecting the battery and having both leads connected to each other. I also left the car for 30 min's with the battery disconnected.

I do own a copy of bmtechnic stuff but i'm not sure how this could help at them moment.

Any thoughts would be much appreciated.
Reply With Quote
Advertisement
  #2  
Old 08-30-2013, 04:48 AM
DennisCooper!'s Avatar
DennisCooper! DennisCooper! is offline
Officially Welcomed to the 'Fest
Location: West London / Heathrow UK
 
Join Date: Jan 2011
Posts: 1,674
Mein Auto: 03 Ex Cop 530d Touring
Hi,

Could you post up the message it displays that the temperature is too hot? I haven't seen/heard that one before! You'll need to extend or get the right cable to connect up to the GPS drive - I 'vaguely' believe it will want to have a GPS signal to be operational. There again, it might not, so you could have a duff/malfunctioning GPS computer. To test, you'll want to test the GPS computer you have in another BMW which uses the same system and see if it works.

Cheers, Dennis!
Reply With Quote
  #3  
Old 08-30-2013, 05:20 AM
DanielS DanielS is offline
Registered User
Location: Amstelveen, The Netherlands
 
Join Date: Aug 2013
Posts: 4
Mein Auto: E34 - 525i, E46 328i, E39
I will try and take a picture from the screen, but it's really really hard to read when it shows up. The message I get in German is: "Der Monitor wird wegen zu hoher Temperatur vorbeugend abgeschaltet"

For the GPS Drive I need to give the $tealership a call and see if they have it in stock... Unfortanatly I don't have another car that I could pop the MK4 in to test it's workings. But i'm sure that if the CD keeps on spinning and it won't eject something isn't wright. i've already tried the 3 min trick and the next step would be the power trick, and if all else fails i'll be stuck with the last option of opening it up. On the other hand I might to that straight away and clean the unit on the inside.
Reply With Quote
  #4  
Old 08-30-2013, 06:05 AM
DennisCooper!'s Avatar
DennisCooper! DennisCooper! is offline
Officially Welcomed to the 'Fest
Location: West London / Heathrow UK
 
Join Date: Jan 2011
Posts: 1,674
Mein Auto: 03 Ex Cop 530d Touring
Hi,

You'll need to search around the forums to see if that error message has appeared for anyone else and if there's any quick, cheap and easy ways to perhaps resolve it. I think 'vaguely' again, the amplifier unit might be whats actually overheating so you might want to ensure that has nothing stuffed against it?...

The Mk4 computer/GPS drives are known to fail and there's a few specialist companies that overhaul and repair them. Have a look on Ebay for BMW Mk4 repairs. In the UK there's a few places advertising this service. It's up to you to evaluate if it's worth it, as other modules like the amplifier can also fail, so as these oem modules get older, more begin to fail as you've discovered.

Good luck!

Cheers, Dennis!

Last edited by DennisCooper!; 08-30-2013 at 06:06 AM.
Reply With Quote
  #5  
Old 08-30-2013, 07:34 AM
DanielS DanielS is offline
Registered User
Location: Amstelveen, The Netherlands
 
Join Date: Aug 2013
Posts: 4
Mein Auto: E34 - 525i, E46 328i, E39
Because the car is a Touring, isn't the amp in the back of the car?

I'm off in about 30 min....WEEKEND!!! And then I'll drive home and take the screen out. Also I still have to program the old video module with NavCoder, also I want to remove the TV function as it is no longer supported in the Netherlands. Once i've done that then i'll check back on the screen. See if it will function out of the mounting position built in position.
Reply With Quote
  #6  
Old 08-30-2013, 12:34 PM
DanielS DanielS is offline
Registered User
Location: Amstelveen, The Netherlands
 
Join Date: Aug 2013
Posts: 4
Mein Auto: E34 - 525i, E46 328i, E39
Ok.... I've solved the problem.... or actually i've made it somebody else his problem. I went back to the person who sold me the screen and showed him the problem. He didn't understand what the problem was, but was happy to swap it with another unit he had. Attached the new unit and no problem after a 20 min drive.

Next step is to go to the $tealership and get a cable for the GPS antenne. But as that is a different topic I won´t post anything here.

@Denniscooper thanks for the suggestions and help!
Reply With Quote
Reply

Bookmarks

Tags
16:9, e39 touring, hot screen, mk2 upgrade, mk4


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms