Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)

E34 (1989 - 1995)

Reply
 
Thread Tools Display Modes
  #1  
Old 08-04-2013, 08:38 PM
Photojunky Photojunky is offline
Registered User
Location: Pacifica
 
Join Date: Sep 2012
Posts: 25
Mein Auto: 1991 525i
Finally fixed my transmission on my 91 525i.

I kept on getting the trans program warning light after the car was warmed up then the car would not shift out of 3rd gear so I took it to my local shop which is normally very good and fair. I told them from everything I had read I thought it was the TRANSMISSION speed sensor or band apply solenoid. So the dummies changed the speed sensor located on the axle and not the transmission speed sensor. So then they changed it back and told me the code said it was the kick down switch. I told them I didn't think so but told them to do it since they were only going to charge me 164. When I got the car back after 15 mins of driving the problem started up. I brought it back but this time they told me they were going to send it to their transmission guy who owned a shop and did all their tranny work. To make a long story short he said the tranny was bad and needed to be replaced. I said BS. I got my car back and changed the band apply solenoid like I told them in the first place and so far the problem seems to have gone away. I'll keep my fingers crossed.

Last edited by Photojunky; 08-04-2013 at 08:45 PM.
Reply With Quote
Advertisement
  #2  
Old 08-05-2013, 12:49 PM
paperplane94 paperplane94 is offline
Officially Welcomed to the 'Fest
Location: Los Angeles, CA
 
Join Date: Jan 2012
Posts: 927
Mein Auto: 1989 525i M20B25
Yay!
Reply With Quote
  #3  
Old 09-09-2013, 05:26 PM
55bmw 55bmw is offline
Registered User
Location: knoxville tn
 
Join Date: Sep 2013
Posts: 9
Mein Auto: 1992 525i
band apply solenoid?

Quote:
Originally Posted by Photojunky View Post
I kept on getting the trans program warning light after the car was warmed up then the car would not shift out of 3rd gear so I took it to my local shop which is normally very good and fair. I told them from everything I had read I thought it was the TRANSMISSION speed sensor or band apply solenoid. So the dummies changed the speed sensor located on the axle and not the transmission speed sensor. So then they changed it back and told me the code said it was the kick down switch. I told them I didn't think so but told them to do it since they were only going to charge me 164. When I got the car back after 15 mins of driving the problem started up. I brought it back but this time they told me they were going to send it to their transmission guy who owned a shop and did all their tranny work. To make a long story short he said the tranny was bad and needed to be replaced. I said BS. I got my car back and changed the band apply solenoid like I told them in the first place and so far the problem seems to have gone away. I'll keep my fingers crossed.
What and where is the band apply solenoid?
I have similar problem and replaced the transmission speed sensor, no help.
Oh, I'm very new here
Hi
Reply With Quote
  #4  
Old 09-09-2013, 07:52 PM
Photojunky Photojunky is offline
Registered User
Location: Pacifica
 
Join Date: Sep 2012
Posts: 25
Mein Auto: 1991 525i
Remove your transmission fluid pan, then your transmission filter. Then towards the rear of the pan you will see a small solonoid with a wire going to it and a pin holding it in. Remove the electrical carefully, mine was brittle, then remove the pin. It is an easy job but messy because you will be draining fluid. Pm me the result if you do it.
This is what it looks like. http://www.amazon.com/4L30E-Transmis.../dp/B00CBFMXG6
Reply With Quote
  #5  
Old 09-09-2013, 07:55 PM
Photojunky Photojunky is offline
Registered User
Location: Pacifica
 
Join Date: Sep 2012
Posts: 25
Mein Auto: 1991 525i
And what is it? From my understanding it downshifts the tranny from 4th and 3rd to 2nd.
Reply With Quote
  #6  
Old 09-10-2013, 09:51 AM
Doktor Bert's Avatar
Doktor Bert Doktor Bert is offline
Der Sturm Uberdoktor
Location: Palm Springs
 
Join Date: Oct 2012
Posts: 903
Mein Auto: BMW 525i
Nice work!
__________________
"Herr Doktor will see you now..."
Reply With Quote
  #7  
Old 09-11-2013, 12:51 PM
BMWFatherFigure's Avatar
BMWFatherFigure BMWFatherFigure is offline
Old School
Location: Perth, Western Australia
 
Join Date: Aug 2012
Posts: 2,338
Mein Auto: E23;E30;E38;E32;E34 +
The solonoid works the band type brake that stops the gear housing spinning. This 'changes gear'. Only 2 gears involved, not three. Google planet and sun gears and see how it works.
__________________
Good - Fast - Cheap: Pick any two.
Current:
E23 735i; E32 735iL (X 2 - 1 Alpine White and 1 Glacier Blue); E34 535i; E38 735iL; R50 Cooper; R55 Cooper Clubman.
Previous:
E21 318i; E30 318i; E32 735iL; E34 535i; E38 730iL; E53 4.4i
Reply With Quote
  #8  
Old 09-12-2013, 09:32 PM
justaseatacguy justaseatacguy is offline
Registered User
Location: Seattle
 
Join Date: Jun 2013
Posts: 27
Mein Auto: 91 525I
Not sure if I am hurting anything or not, but when my transmission program light comes on, I just stop, turn the car off for 10 seconds, restart and the light goes out and everything is "normal" until the next times. Transmission Program light comes on sporadically (maybe two times a week, sometimes longer).
Reply With Quote
  #9  
Old 09-13-2013, 06:14 AM
Photojunky Photojunky is offline
Registered User
Location: Pacifica
 
Join Date: Sep 2012
Posts: 25
Mein Auto: 1991 525i
Mine was doing exactly that but it was also locking in third gear. I'd turn it off and wait a couple then it would work for a while. If you've never changed your transmission fluid I start there. Can't hurt.
Reply With Quote
  #10  
Old 09-17-2013, 07:10 PM
Milliesdad Milliesdad is offline
Registered User
Location: Auckland New Zealand
 
Join Date: Sep 2013
Posts: 9
Mein Auto: 525i E34 Touring
random trans program notification

lots of electronic reasons this could be :-)
may just be spades on connectors and relays - the gear selector connection under the panel around the gearstick down to the solenoids on the exterior and in the box having bad connections
(if your box goes ping anytime it may be the gear selector or gate button on the stick, or the sport economy button connectors/relays or on the trail from the throttle and gear control to the ECM from under bonnet to trans - usually down the trans end connectors between the ECM and trans- even worth cleaning the relays under the bonnet by the fuses and in the passenger side wall or behind glove) the 3rd gear one a bit more serious to look at as protection mode is always worth getting a computer plugged in for fault codes - and more likely damaging if you persist with
Reply With Quote
  #11  
Old 09-18-2013, 06:18 AM
Photojunky Photojunky is offline
Registered User
Location: Pacifica
 
Join Date: Sep 2012
Posts: 25
Mein Auto: 1991 525i
According to the shop mine was giving the wrong code, I can't remember what they told me. The transmission shop they sent it to said the same thing. So I looked up the problem on the Internet and also looked up the specific transmission also used in many other vehicles and started with the easiest and cheapest issues and got lucky.
Reply With Quote
  #12  
Old 09-18-2013, 08:40 AM
55bmw 55bmw is offline
Registered User
Location: knoxville tn
 
Join Date: Sep 2013
Posts: 9
Mein Auto: 1992 525i
I am goint to try the band apply solenoid next.
Here is what i've done so far:
replaced gear shifter thing under the console, electrical about 3" long and 1/2" wide
replaced trans speed sensor
relaced fluid, filter

it is running a bit warm so i'm going to replace thermostat, water pump
oh, also my auxiliary fan does not work, so replacing that too
that should cool things down a bit, i know heat is the enemy to engine and tranny
any help getting good prices on any of the above mentioned would be appreciated
Reply With Quote
  #13  
Old 02-17-2014, 12:07 PM
55bmw 55bmw is offline
Registered User
Location: knoxville tn
 
Join Date: Sep 2013
Posts: 9
Mein Auto: 1992 525i
it worked

I finally got it installed, after 4 weeks and no problems, it's fixed :-) :-) :-) :-) :-) :-) :-)
Reply With Quote
  #14  
Old 02-17-2014, 12:21 PM
Milliesdad Milliesdad is offline
Registered User
Location: Auckland New Zealand
 
Join Date: Sep 2013
Posts: 9
Mein Auto: 525i E34 Touring
was it the band solenoid?
Reply With Quote
  #15  
Old 02-17-2014, 02:20 PM
55bmw 55bmw is offline
Registered User
Location: knoxville tn
 
Join Date: Sep 2013
Posts: 9
Mein Auto: 1992 525i
Yes

Quote:
Originally Posted by Milliesdad View Post
was it the band solenoid?
Yes it was, the low band solenoid, cost about $80 on eBay.
It is just under the trans filter.
Glenn
Reply With Quote
  #16  
Old 05-23-2014, 07:26 AM
55bmw 55bmw is offline
Registered User
Location: knoxville tn
 
Join Date: Sep 2013
Posts: 9
Mein Auto: 1992 525i
Angry i'm back

Well, it's been a few months and it started to happen again, just as bad. I replased a lot of cooling issues, no help. Could the solenoid have gone bad again? Maybe the wires going to it? I'm at a loss.Aaaarrrggg!!!
Reply With Quote
  #17  
Old 05-23-2014, 08:56 AM
Photojunky Photojunky is offline
Registered User
Location: Pacifica
 
Join Date: Sep 2012
Posts: 25
Mein Auto: 1991 525i
My transmission finally went as well, and the horn stopped working, and the headlights stopped working, and the stereo, and the air bag light... I sold that piece of junk for $600 bucks. It was the first BMW I owned that fell apart like that. Oh well.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E34 (1989 - 1995)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms