Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2013, 01:53 AM
skptc skptc is offline
Registered User
Location: Lake Forest, CA
 
Join Date: Jul 2008
Posts: 59
Mein Auto: 03 Z4, 04 X5
04 X5 head unit dead?

In trying to figure out whether to go with an aftermarket unit I removed the MID (head unit) and the cd then reconnected them but the head unit will not come on at all Checked the fuses and they all look ok. CD player works. At a loss could the head unit be fried?
Reply With Quote
Ads by Google
  #2  
Old 09-13-2013, 07:42 AM
tolgatt tolgatt is offline
Registered User
Location: Calgary,AB
 
Join Date: Aug 2013
Posts: 31
Mein Auto: 2005 BMW X5 4.4 Sport
Which fuses did you check ? there is some in the glove box and some at the right rear panel in the trunk as well .
Mine works but seems to be stuck on something where some of my buttons dont respond at all . There are definitely repair services for your MID unit or replacements on ebay seem to be much cheaper than the dealership price.
Reply With Quote
  #3  
Old 09-13-2013, 08:01 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,677
Mein Auto: 1997 740iL / 2006 X5 4.4
Just in case I misunderstood what you wrote...the MID is NOT the "head unit". It is a multi-informational display...that is basically an input control device for the various audio/phone/clock/OBC features the vehicle is optioned with. Info & data is sent to the MID from the various components connected to it...again, it only controls the info/data that is sent to it or returned from it.

The radio tuner is incorporated into the in-dash CD player (or cassette tape player) if you have the MID. And if you have the nav screen, the radio tuner is a separate component mounted in the rear of the vehicle (I believe under the cargo floor in the X5?).

There's also a fuse on the back of the in-dash CD or cassette unit. Did you check to see if you blew that fuse? You can see the fuse in the pic below...its from my old 99 540iT (with round pins)...but the layout is the same with the newer (2000-up) flat pin connectors:





-
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 09-13-2013 at 08:11 AM.
Reply With Quote
  #4  
Old 09-13-2013, 09:18 AM
skptc skptc is offline
Registered User
Location: Lake Forest, CA
 
Join Date: Jul 2008
Posts: 59
Mein Auto: 03 Z4, 04 X5
Re: 04 X5 head unit dead?

Sorry for the confusion.definitely have the MID. Checked fuses front and back and the one in the cd. All seem ok. Thought the tuner was in the back. Didn't know it was in the cd player. So what are these in rear driver side?
Attached Thumbnails
Click image for larger version

Name:	1379089113203.jpg
Views:	56
Size:	41.2 KB
ID:	396621  
Reply With Quote
  #5  
Old 09-13-2013, 09:39 AM
tolgatt tolgatt is offline
Registered User
Location: Calgary,AB
 
Join Date: Aug 2013
Posts: 31
Mein Auto: 2005 BMW X5 4.4 Sport
the one in the bottom (box) is the amplifier for your DSP system , you should have the subwoofer box at the opposite side under the fuses.
All the remaining cabling is I think for the prep for a CD changer
Reply With Quote
  #6  
Old 09-13-2013, 09:43 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,677
Mein Auto: 1997 740iL / 2006 X5 4.4
Edit: ditto tolgatt (you beat me to it)

The amp, CD changer, ULF/Bluetooth, phone and radio tuner (if you have NAV) is what you'll find located in the rear area. The radio turner again, is actually below the cargo floor. If you're X5 has the subwoofer...it is located behind the opposite (right side) cargo panel....along with the rear fuse box.
__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 09-13-2013 at 09:44 AM.
Reply With Quote
  #7  
Old 09-13-2013, 10:30 AM
tolgatt tolgatt is offline
Registered User
Location: Calgary,AB
 
Join Date: Aug 2013
Posts: 31
Mein Auto: 2005 BMW X5 4.4 Sport
Whatever I wrote , I probably learned from your posts anyways QSilver7
Reply With Quote
  #8  
Old 09-13-2013, 12:49 PM
skptc skptc is offline
Registered User
Location: Lake Forest, CA
 
Join Date: Jul 2008
Posts: 59
Mein Auto: 03 Z4, 04 X5
Re: 04 X5 head unit dead?

Thanks guys. Getting a better understanding of all this. Btw I have DSP, MID,.in dash cd, no nav, no cd changer no bt.

So the half dome black alien object under the spare tire is the tuner?

Time to confess my predicament. I removed the MID and cd player to try to connect an EONON unit... when that experiment failed I reconnected the MID and cd at which time I may have forgotten to turn the key to the full off position... since then the MID is dead as in not even illumination.

Right now before I even get back to the EONON unit I'm trying to figure out if this is a reset/programming issue or if I killed the MID
Reply With Quote
  #9  
Old 09-14-2013, 05:42 AM
skptc skptc is offline
Registered User
Location: Lake Forest, CA
 
Join Date: Jul 2008
Posts: 59
Mein Auto: 03 Z4, 04 X5
Re: 04 X5 head unit dead?

Starting a new thread to document my eonon saga
Reply With Quote
  #10  
Old 09-16-2013, 01:48 PM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,677
Mein Auto: 1997 740iL / 2006 X5 4.4
Quote:
Originally Posted by skptc View Post

1. So the half dome black alien object under the spare tire is the tuner?

2. I removed the MID and cd player to try to connect an EONON unit... when that experiment failed I reconnected the MID and cd at which time I may have forgotten to turn the key to the full off position... since then the MID is dead as in not even illumination.
1. No, the "alien object" directly under the dome is part of the SLS (self leveling system)...see illustration below. The radio tuner for those WITH the nav screen (BMW53/BM54) is located even further down...in front of the battery. But since you have the MID, the tuner is incorporated into the in-dash CD player...make sure the fuse in the rear harness of the CD unit isn't blown:

(radio tuner for those with onboard Nav (BM53/BM54) is located in front of battery on left side in pic below from Xoutpost)




2. If you disconnected/reconnected wiring harnesses with the ignition on...double check every fuse in the system front & rear (pull them out to visually check them...then push them back in if ok) that is connected with the audio/phone/obc/DSP (everything the MID receives data/info from). For example, for my 06...I'd check fuse #s 1,6,7,11,13,16,39,43,45,72,73,74,75...your fuses may be different, depending on build date...so check the front & rear fuse indexes for your vehicle:

(front fuse index is on drop down lid in glove box)



(rear fuse index is adhered to rear fuse box (on my 06)...may be adhered to panel or other area in rear)

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 09-16-2013 at 04:06 PM.
Reply With Quote
  #11  
Old 09-16-2013, 03:14 PM
skptc skptc is offline
Registered User
Location: Lake Forest, CA
 
Join Date: Jul 2008
Posts: 59
Mein Auto: 03 Z4, 04 X5
Re: 04 X5 head unit dead?

Thanks. That's what I was getting to as well. Back to the fuse boxes...
Reply With Quote
  #12  
Old 09-16-2013, 03:44 PM
skptc skptc is offline
Registered User
Location: Lake Forest, CA
 
Join Date: Jul 2008
Posts: 59
Mein Auto: 03 Z4, 04 X5
Re: 04 X5 head unit dead?

No kidding....I thought that's what they used to keep track of my whereabouts...

Seriously now. Just plunked down 1500 yo have all four shocks replaced... that damn dome better not go out on me.

Anyway thanks for all the info. Don't know what I'd do without this forum. I think I'm narrowing my options down...hopefully the next options ruled out are suicide and self inflicted torture... oh wait, too late on the last one
Reply With Quote
  #13  
Old 09-27-2013, 01:14 AM
DDutchman DDutchman is offline
Registered User
Location: Florida and Germany
 
Join Date: Aug 2012
Posts: 82
Mein Auto: 2005 X5 3.0i
If I ever meet the morons at BMW who thought putting a $900 radio unit in the boot of an SAV with no drainage for melting snow or wet beach stuff and battery acid fumes I will not be responsible for my actions. The entire trunk is designed for liquids to run down to the lowest point where the radio and leveler are. I was able to rescue the leveller unit. The radio is now a paperweight. That is why I bought the Eonon D5124F. All I have to do is figure out how to keep the dash above water. Oh, yeah, and I need to figure out how to get the system to plug into the blue and white connectors.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 03:33 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms