Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - 2014)

X6 E71 / E72 (2008 - 2014)
The BMW X6 luxury crossover went on sale in April 2008 as a 2009 model year. BMW referes to the X6 as a Sports Activity Coupe (SAC) as it combines the attributes of an SUV (high ground clearance, xDrive and all-weather ability) with the stance, styling and roof line shape of a coupe. The E71 X6 was built off the E70 X5 (2007 - 2013) platform at BMW's Spartanburg, SC plant. Total worldwide sales were just over 235,000, sold mostly to the BRIC countries. US total sales was 34,082 vehicles.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2013, 11:49 PM
Nadimx6 Nadimx6 is offline
Registered User
Location: Lebanon
 
Join Date: Sep 2013
Posts: 2
Mein Auto: BMW X6 2010
Rough idle when cold

Hello Friends,

Well I donno what happened .. but My x6 2010 3.5 started few days ago to have a rough idle when cold .

Yesterday , the check engine lighted up .. I took it to the dealership , they said they want to change the valve cover , it is an issue of something called breeder .. which comes with the valve cover .. I did not buy the story ..

Another thing is I remembered I filled the whole tank one day before that started to happen ..
Others friends are saying , maybe the spark plugs or coils or injectors ..

But what i noticed lately that I used to open the driver's door , and used to hear a small sound like a pump .. as if a pre pump ignition .. now I am not .. but donno if this is related .. I told the dealership about the pump thing , they check the realtime pumping pressure and they said both pumps are working fine .. 55 bar and 5 bar ..

So any ideas would be great
Reply With Quote
Advertisement
  #2  
Old 09-16-2013, 07:07 AM
Nadimx6 Nadimx6 is offline
Registered User
Location: Lebanon
 
Join Date: Sep 2013
Posts: 2
Mein Auto: BMW X6 2010
Update : I dropped in the tank a small bottle of Octane booster . Back to normal now .. but still cannot hear this small pump when I open the driver's door ..
It was a bad fuel
Reply With Quote
Reply

Bookmarks

Tags
coil, cold, fuel, idle, pump, rough, x6


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - 2014)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 05:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms