Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

Reply
 
Thread Tools Display Modes
  #1  
Old 09-17-2013, 03:49 AM
F1LOCO F1LOCO is offline
Registered User
Location: Sunnyland
 
Join Date: Sep 2013
Posts: 18
Mein Auto: 2011 Z4 s35i
New Z4 owner...

Good to be back to a two seat roadster with twin turbos....

2011 CPO'd with 12500 miles.

Now a couple of questions:
1. Notice on cold morning start up only, a terrible sounding metallic rattle for about 12-20 seconds? CATs? Something else?
2. After running hot, and at idle, noticed an occasional lull and lunge in the engine? I even felt a "bump" for lack of terminology from under the car, but it is a manual and in neutral, so it can't be a u-joint or drive shaft? Thoughts?
3. How the heck do I change the locks to stop unlocking every time I stop in traffic? I have iDrive and it was set up to lock when door are closed and lock when driving. Do not see any setting for unlocking, though, on the screens.
Attached Thumbnails
Click image for larger version

Name:	Bimmer2Small.jpg
Views:	93
Size:	185.6 KB
ID:	397329   Click image for larger version

Name:	BImmer3Small.jpg
Views:	101
Size:	171.2 KB
ID:	397330  

Last edited by F1LOCO; 09-17-2013 at 04:32 AM.
Reply With Quote
Advertisement
  #2  
Old 09-17-2013, 06:43 AM
jparnes1 jparnes1 is offline
Officially Welcomed to the 'Fest
Location: Rochester, NY
 
Join Date: Dec 2009
Posts: 444
Mein Auto: 2011 Z4 35i, 2006 525xi
That rattling sound is coming from the metal gate in the right exhaust. It doesn't open fully until the engine reaches temperature, so it flaps around a little. I had this with my first Z4 but not with my second. I believe there's a fix for this, so I'd bring it in. It's annoying.
The door lock thing sounds like an electrical goof up. As you point out, there's no setting to do what the locks are doing.
The "bump" you feel...IDK.
BTW, nice color combo. Never seen that before.
__________________
2006 525 xi, Orient Blue Metallic, Beige leather, Dark Poplar trim, Premium Package, Cold Weather Package

2012 Z4 35i, ED 2/24/12, Melbourne Red Metallic, Black leather, 6 MT, ///M Sport, Premium Package, Premium Sound Package, Cold Weather Package, Nav, Comfort Access, LED Angel Eyes, BMWPedals pedal covers, stubby antenna, Luxon strut bar, CF engine cover, LCI side marker, powder coated calipers, Extra Enjoyment Package
Reply With Quote
  #3  
Old 09-17-2013, 06:44 AM
EdCT's Avatar
EdCT EdCT is offline
zeddy
Location: Connecticut
 
Join Date: Mar 2002
Posts: 7,361
Mein Auto: '06 330cic ZHP / '07 M35x
Quote:
Originally Posted by F1LOCO View Post
Good to be back to a two seat roadster with twin turbos....

2011 CPO'd with 12500 miles.

Now a couple of questions:
1. Notice on cold morning start up only, a terrible sounding metallic rattle for about 12-20 seconds? CATs? Something else?
2. After running hot, and at idle, noticed an occasional lull and lunge in the engine? I even felt a "bump" for lack of terminology from under the car, but it is a manual and in neutral, so it can't be a u-joint or drive shaft? Thoughts?
3. How the heck do I change the locks to stop unlocking every time I stop in traffic? I have iDrive and it was set up to lock when door are closed and lock when driving. Do not see any setting for unlocking, though, on the screens.
Nice car!

The door-locking feature is programmed at the dealer level. Have them change it for you.

Not sure about the other noises, except to say some BMW's do make certain squeals, rattles and metallic noises when cold .. mine has for years!

The lull could be a software issue. It's under warranty, have it checked thoroughly.

Enjoy, she looks really nice.
__________________

2000 Mercedes Benz E320 (daily driver)
2007 Infiniti M35x (wife's)
2006 330 cic ZHP 6sp (current)
2005 Z4 3.0 sp nav x-leather (retired)
2000 323i PP (best car, ever - retired)
Reply With Quote
  #4  
Old 09-17-2013, 11:19 AM
Z4golfer's Avatar
Z4golfer Z4golfer is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: May 2010
Posts: 334
Mein Auto: 2011 Z4 35is
Quote:
Originally Posted by jparnes1 View Post
That rattling sound is coming from the metal gate in the right exhaust. It doesn't open fully until the engine reaches temperature
Mine started doing this soon after I got the car, it was an awful rattle that lasted about a minute after a cold start. When I finally took it to the dealer they just welded it open rather than fix it properly. The car has a nice growl at startup that the the flap is designed to dampen.
__________________


2011 Z4 35is
2014 X3 28i
Reply With Quote
  #5  
Old 09-18-2013, 07:06 PM
John151 John151 is offline
Registered User
Location: Palatine, IL
 
Join Date: Oct 2008
Posts: 31
Mein Auto: Mazda Miata (don't laugh)
Quote:
Originally Posted by F1LOCO View Post
Good to be back to a two seat roadster with twin turbos....

2011 CPO'd with 12500 miles.

Now a couple of questions:
1. Notice on cold morning start up only, a terrible sounding metallic rattle for about 12-20 seconds? CATs? Something else?
Congrats on your acquisition.

My 2011 3.0 makes the same noise when warming up.

As part of the emissions control strategies, modern cars retard the ignition at idle when the engine is cold to heat up the cats faster. This basically sending a very mild back fire down the exhaust. I assume this is what I am hearing on my car. However, I plan to check with the dealer just in case.

I had the same issue on a Volvo XC90 V8 when the heat shield rusted off the resonator - it sounded like those metal drums they play in the Caribbean during warm up.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 11:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms