Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 Roadster, E86 Z4 Coupe, E85 Z4 M Roadster, and E86 Z4 M Coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 08-31-2013, 10:53 PM
Vladi Vladi is offline
Officially Welcomed to the 'Fest
Location: Switzerland
 
Join Date: Jan 2012
Posts: 107
Mein Auto: Z4 M (2007)
Z4 M bixenon problem: moisture killed the ballasts

As I described in this thread http://www.bimmerfest.com/forums/sho...d.php?t=719154 I have a problem with the headlights. They are bi-xenon and took in moisture. First the driver's side one and few months later - the passenger's side one. Each stopped working shortly after taking moisture in. While the passenger's side headlight was still working, I took the ignitor of the already dead driver's side headlight and put it there. It worked. So both ignitors seem to be OK. After removing both headlights yesterday their interiors seem pretty much intact, no traces of moisture damage whatsoever:



So I focused on the ballasts. There they are, below the headlight:



After unplugging them from the headlight, that's what I saw:



Both look like that. There is liquid water INSIDE the ballasts - when I shake them it sounds like one of those pocket bottles, half full

As I already said, all the rest seems to be intact - the parking lights, the turning lights and the low/high beam switch solenoid all work. So I think of buying two new ballasts only and replacing them. What worries me more, though, is where the heck has all this moisture come from? I have to solve this problem otherwise in few months I will end up with another set of dead ballasts. My primary suspect is the lids at the back of the lights:



I have bought a set of new ones (one of them shown on the picture). The rubber ring that's supposed to keep the joint tight deforms with time and, to my opinion, is the source of the moisture in the headlights. And since the ballast is the lowest part of the headlight, it trickles into it and accumulates with time. The intake of moisture is, obviously, with higher rate than the two vents of the assembly can cope with.

Apart from replacing the lids I will use heat-resistant silicone sealant around the new ballasts and the same around the face seam (where the Plexiglas lid is attached to the main body of the light.

So my general question is has any of you had this problem and how did you DIY it?

Best greetings,
Vladi
Reply With Quote
Ads by Google
  #2  
Old 09-21-2013, 11:04 AM
Vladi Vladi is offline
Officially Welcomed to the 'Fest
Location: Switzerland
 
Join Date: Jan 2012
Posts: 107
Mein Auto: Z4 M (2007)
OK, finally got some more time to work on the car.

Ordered new ballasts from e-bay for GBP 89 (USD 143) each (instead of USD 470 at the stealership) plus a new ignitor (around USD 65). Could have saved myself the ignitor purchase but my clumsiness kicked in - dropped one of the original ones on the floor and 3 of the plastic pins that lock it in place at the reflector broke off...

Since replacing any of the incandescent bulbs (that are supposed to last for not more than 200 hours or so) in the lights is WAY more difficult than replacing the xenon bulbs (that are supposed to last forever (at least in theory), I decided to replace all incandescent bulbs. Replacing the turning lights was OK but I found out that replacing the parking light bulbs was a bit trickier. Why? Well, the bulb is a pretty standard ba9s-socket 12 V 10 W halogen bulb (Philips reference 12082) worth USD 12 (here in Switzerland). However, the designers of the headlights have decided to encapsulate the bulb in a very complex-shaped socket and sell it to you for... USD 45 (at the stealership). IDIOTS!!!







I found a way around it by simply piercing two small holes at the socket with my Dremel tool:



Decided to give some LED substitutes a try:



I didn't have much hope that it would work (although the seller of the LEDs swore they are "error-free") and, logically, it didn't work - due to the non-ohmic nature of the LEDs, they were recognised by the system as faulty bulbs so there was the "faulty bulb" alarm on the dashboard. So I switched back to the good old incandescent bulbs.

Next, I put silicone sealant on the joint between the polycarbonate cover and the headlight's body (sorry, didn't take any pics but hope you would figure out what I mean).

Then I put silicone sealant on the ballasts:













So in the end those lights saw more silicone than Pamela Anderson but at least I hope I won't have moisture-killed ballast anymore.

This morning I mounted the lights and the bumper back on the car, took a shower, jumped in the car, lowered the top and spent the rest of the day chasing motorcyclist between France and Switzuerland
Reply With Quote
  #3  
Old 06-24-2014, 01:47 PM
blackrockbob blackrockbob is offline
Registered User
Location: SF Bay
 
Join Date: Jun 2014
Posts: 3
Mein Auto: 2007 Z4 Coupe, 3.0
Quote:
Originally Posted by Vladi View Post
OK, finally got some more time to work on the car.

Ordered new ballasts from e-bay for GBP 89 (USD 143) each (instead of USD 470 at the stealership) plus a new ignitor (around USD 65). Could have saved myself the ignitor purchase but my clumsiness kicked in - dropped one of the original ones on the floor and 3 of the plastic pins that lock it in place at the reflector broke off...

Since replacing any of the incandescent bulbs (that are supposed to last for not more than 200 hours or so) in the lights is WAY more difficult than replacing the xenon bulbs (that are supposed to last forever (at least in theory), I decided to replace all incandescent bulbs. Replacing the turning lights was OK but I found out that replacing the parking light bulbs was a bit trickier. Why? Well, the bulb is a pretty standard ba9s-socket 12 V 10 W halogen bulb (Philips reference 12082) worth USD 12 (here in Switzerland). However, the designers of the headlights have decided to encapsulate the bulb in a very complex-shaped socket and sell it to you for... USD 45 (at the stealership). IDIOTS!!!







I found a way around it by simply piercing two small holes at the socket with my Dremel tool:



Decided to give some LED substitutes a try:



I didn't have much hope that it would work (although the seller of the LEDs swore they are "error-free") and, logically, it didn't work - due to the non-ohmic nature of the LEDs, they were recognised by the system as faulty bulbs so there was the "faulty bulb" alarm on the dashboard. So I switched back to the good old incandescent bulbs.

Next, I put silicone sealant on the joint between the polycarbonate cover and the headlight's body (sorry, didn't take any pics but hope you would figure out what I mean).

Then I put silicone sealant on the ballasts:













So in the end those lights saw more silicone than Pamela Anderson but at least I hope I won't have moisture-killed ballast anymore.

This morning I mounted the lights and the bumper back on the car, took a shower, jumped in the car, lowered the top and spent the rest of the day chasing motorcyclist between France and Switzuerland

Great write up on this
Reply With Quote
  #4  
Old 06-25-2014, 03:09 AM
Mikey48 Mikey48 is offline
Officially Welcomed to the 'Fest
Location: Charleston,S.C.
 
Join Date: Mar 2011
Posts: 414
Mein Auto: BMW Z4 3.0
Hi, I had the exact same thing happen to my 2004 Z4 roadster. The door gasket is what is letting in the moisture. I tried replacing the gasket did not work. I laid a bead of weather stripping adhesive on top of the door gasket and reinstalled the door. It worked ! I had to replace everything in my passenger side headlight globe also. It was very expensive. Good luck.
Reply With Quote
  #5  
Old 06-25-2014, 04:27 AM
Vladi Vladi is offline
Officially Welcomed to the 'Fest
Location: Switzerland
 
Join Date: Jan 2012
Posts: 107
Mein Auto: Z4 M (2007)
Quote:
Originally Posted by Mikey48 View Post
Hi, I had the exact same thing happen to my 2004 Z4 roadster. The door gasket is what is letting in the moisture. I tried replacing the gasket did not work. I laid a bead of weather stripping adhesive on top of the door gasket and reinstalled the door. It worked ! I had to replace everything in my passenger side headlight globe also. It was very expensive. Good luck.
Hi Mikey,

Yeah, I suspected the gaskets as the primary suspect. However, I never managed to find the traces of water leaking into the ballasts. That's why I decided to seal every possible weak point that I could seal. BMW, apparently, make their cars for use in the Sahara desert only - they are so sensitive to water and I'm not talking only about moisture intake in the lights... That's a shame!
Reply With Quote
  #6  
Old 06-25-2014, 04:28 AM
Vladi Vladi is offline
Officially Welcomed to the 'Fest
Location: Switzerland
 
Join Date: Jan 2012
Posts: 107
Mein Auto: Z4 M (2007)
Thank you Bob, hope such writeups help the community.
Reply With Quote
  #7  
Old 07-18-2014, 02:16 PM
chickdr chickdr is offline
Officially Welcomed to the 'Fest
Location: Atlanta, GA
 
Join Date: Mar 2009
Posts: 1,031
Mein Auto: '06 M Roadster Imola/Blk
Quote:
Originally Posted by Mikey48 View Post
Hi, I had the exact same thing happen to my 2004 Z4 roadster. The door gasket is what is letting in the moisture. I tried replacing the gasket did not work. I laid a bead of weather stripping adhesive on top of the door gasket and reinstalled the door. It worked ! I had to replace everything in my passenger side headlight globe also. It was very expensive. Good luck.
I wonder if the door is warped? It seems like a new gasket should have fixed the issue unless it is leaking elsewhere.
Reply With Quote
  #8  
Old 07-18-2014, 09:32 PM
Vladi Vladi is offline
Officially Welcomed to the 'Fest
Location: Switzerland
 
Join Date: Jan 2012
Posts: 107
Mein Auto: Z4 M (2007)
Quote:
Originally Posted by chickdr View Post
I wonder if the door is warped? It seems like a new gasket should have fixed the issue unless it is leaking elsewhere.
I checked the doors - they were not warped at all. So if the problem was coming from there, it must have been the gaskets. Unfortunately BMW don't sell the gasket only. And the doors' price was not high so I preferred to buy them and replace them instead of wasting time searching for possible substitues of those gaskets.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 07:30 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms