Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F07 Gran Turismo (2010 - Current)

F07 Gran Turismo (2010 - Current)
The 5 Series Gran Turismo -- now available in the USA as a 535i, 550i and 550i xDrive model.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-04-2013, 09:34 AM
vkosty vkosty is offline
Registered User
Location: Solano, CA
 
Join Date: Aug 2013
Posts: 31
Mein Auto: X5 E70
2010 550iGT rear seat controls stopped working on both sides

Got the certified GT an after about 1000 miles the controls on both rear seats (it's a 4-seat version) stopped working.
I have 2 child seats installed on those seats, so just browsing through the posts here it may be a disconnected wire.
The seats controls inside the trunk are fully operable, so are the front seats.
Any advice would be highly appreciated before I start poking in there or worse yet - take the car to the dealer.
I will check if the dealers certification includes electrical.
Thanks in advance
Reply With Quote
Advertisement
  #2  
Old 10-04-2013, 08:27 PM
Fish23's Avatar
Fish23 Fish23 is offline
Officially Welcomed to the 'Fest
Location: Ottawa, Ontario, Canada
 
Join Date: Apr 2012
Posts: 591
Mein Auto: BMW 535xi GT
Re: 2010 550iGT rear seat controls stopped working on both sides

Isn't your GT still under its original warranty? If so, take
It back to the dealer and let him poke around in there last no cost to you.
The correct operation of the seats is certainly covered under the warranty which is bumper-to-bumper. Let us know how it turns out and what the cause of the problem was.

Sent from BimmerApp mobile app
Reply With Quote
  #3  
Old 10-04-2013, 09:06 PM
vkosty vkosty is offline
Registered User
Location: Solano, CA
 
Join Date: Aug 2013
Posts: 31
Mein Auto: X5 E70
Quote:
Originally Posted by Fish23 View Post
Isn't your GT still under its original warranty? If so, take
It back to the dealer and let him poke around in there last no cost to you.
The correct operation of the seats is certainly covered under the warranty which is bumper-to-bumper. Let us know how it turns out and what the cause of the problem was.

Sent from BimmerApp mobile app
Unfortunately it's no longer under the original warranty. The dealership is asking $199 just to diagnoze
Reply With Quote
  #4  
Old 10-05-2013, 12:48 AM
jadnashuanh jadnashuanh is online now
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Jun 2011
Posts: 810
Mein Auto: 535ix-drive GT
Take a USB drive and backup your profile from the car (or not, if you don't mind resetting everything), then pull the battery connection for awhile, then replace and see if it starts working again. You can then reinstall your profile which will restore your preferences such as seat position, radio stations, etc. SOmetimes, a hard reset helps. IF the rear seat controls are similar to those in the front, I had a chance to look at mine after I broke the passenger's side (I was playing with the roof rack and stepped on it, broke it off while on the threshold) - it's a few microswitches and a little circuit board. It only sends signals to the main computer, which then directs the motors to do their thing...the switches do not directly switch power to anything.

My guess is that circuit board is just a CANBUS interface, and every request is sent as a message to the main computer. SOmehow, it may have decided that option was not installed, and may never scan for that control function, and a hard reset might cause it to reinitialize just like a WIN computer doesn't like to run constantly if something goes wrong, the only real fix is to reboot!
Reply With Quote
  #5  
Old 10-05-2013, 07:53 AM
Fish23's Avatar
Fish23 Fish23 is offline
Officially Welcomed to the 'Fest
Location: Ottawa, Ontario, Canada
 
Join Date: Apr 2012
Posts: 591
Mein Auto: BMW 535xi GT
2010 550iGT rear seat controls stopped working on both sides

I ha assumed that there was warranty left but, since there isn't, then I am inclined to agree with jad that it is likely in the control system and not the mechanical components. His suggestion is what I would try if I had your problem. Good luck.


Sent from BimmerApp mobile app
Reply With Quote
  #6  
Old 10-05-2013, 07:57 AM
vkosty vkosty is offline
Registered User
Location: Solano, CA
 
Join Date: Aug 2013
Posts: 31
Mein Auto: X5 E70
Quote:
Originally Posted by jadnashuanh View Post
Take a USB drive and backup your profile from the car (or not, if you don't mind resetting everything), then pull the battery connection for awhile, then replace and see if it starts working again. You can then reinstall your profile which will restore your preferences such as seat position, radio stations, etc. SOmetimes, a hard reset helps. IF the rear seat controls are similar to those in the front, I had a chance to look at mine after I broke the passenger's side (I was playing with the roof rack and stepped on it, broke it off while on the threshold) - it's a few microswitches and a little circuit board. It only sends signals to the main computer, which then directs the motors to do their thing...the switches do not directly switch power to anything.

My guess is that circuit board is just a CANBUS interface, and every request is sent as a message to the main computer. SOmehow, it may have decided that option was not installed, and may never scan for that control function, and a hard reset might cause it to reinitialize just like a WIN computer doesn't like to run constantly if something goes wrong, the only real fix is to reboot!

Thanks a lot.
Since I am entirely new to BMWs, if I back-up the profile, I will not have to re-enter any codes when I restore it, or will I?

Last edited by vkosty; 10-05-2013 at 07:59 AM.
Reply With Quote
  #7  
Old 10-05-2013, 03:26 PM
jadnashuanh jadnashuanh is online now
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Jun 2011
Posts: 810
Mein Auto: 535ix-drive GT
Some stuff is actually stored in the key fob, so depending on which one is used to open the car, certain stuff can be set, but mostly the memory in it is used to store fault codes which is why the dealer puts it into his machine (usually) when you talk to the service writer. If you backup your profile, most stuff can be restored. The user manual covers most of that. Depending on options, you may have more than one USB port in the car - I know the one in the glove box works, I do not know if the others will deal with profiles or not. I don't have enough presets to where I generally worry about it, but some people have LOTS.
Reply With Quote
  #8  
Old 10-06-2013, 08:44 AM
vkosty vkosty is offline
Registered User
Location: Solano, CA
 
Join Date: Aug 2013
Posts: 31
Mein Auto: X5 E70
Quote:
Originally Posted by jadnashuanh View Post
Some stuff is actually stored in the key fob, so depending on which one is used to open the car, certain stuff can be set, but mostly the memory in it is used to store fault codes which is why the dealer puts it into his machine (usually) when you talk to the service writer. If you backup your profile, most stuff can be restored. The user manual covers most of that. Depending on options, you may have more than one USB port in the car - I know the one in the glove box works, I do not know if the others will deal with profiles or not. I don't have enough presets to where I generally worry about it, but some people have LOTS.
Having hard time locating the battery om this thing. I did try disconnecting the "+" contact under the hood for about a minute. Didn't do the trick
How long should I have waited?
Reply With Quote
  #9  
Old 10-06-2013, 12:09 PM
vkosty vkosty is offline
Registered User
Location: Solano, CA
 
Join Date: Aug 2013
Posts: 31
Mein Auto: X5 E70
Found the battery in the trunk. Disconnected the negative for 30 minutes. Incidentally learned not to close the trunk when without power and how to open if you do. The back seat problem is still there.
Can live without the option, but it bugs me.
Guess going to the dealership.
Reply With Quote
  #10  
Old 10-07-2013, 05:28 PM
vkosty vkosty is offline
Registered User
Location: Solano, CA
 
Join Date: Aug 2013
Posts: 31
Mein Auto: X5 E70
Well this turned out to be just as dumb as I was afraid it would be.
The driver safety button which prevents children from opening windows also blocks seat control. My SA didn't know either. The only consolation is that they haven't charged me anything and washed my car.
Reading the manual does help.
Reply With Quote
  #11  
Old 10-08-2013, 02:44 AM
daders's Avatar
daders daders is online now
There is no spoon
Location: DFW, TX
 
Join Date: Jul 2011
Posts: 728
Mein Auto: 2010 F07 550i, 2009 B8 A4
Quote:
Originally Posted by vkosty View Post
Well this turned out to be just as dumb as I was afraid it would be.
The driver safety button which prevents children from opening windows also blocks seat control. My SA didn't know either. The only consolation is that they haven't charged me anything and washed my car.
Reading the manual does help.
Who would have thought? Good to know it wasn't a "problem" and they didn't charge you the diagnostic either!

I read through our manual (just a few short weeks ago) and don't recall mention of that feature, but by that time it's more like skimming a history text book before a test.
__________________
There's no need to panic until it is time to panic.
Reply With Quote
  #12  
Old 10-08-2013, 07:37 PM
jadnashuanh jadnashuanh is online now
Officially Welcomed to the 'Fest
Location: NH
 
Join Date: Jun 2011
Posts: 810
Mein Auto: 535ix-drive GT
I have the rear window shades and there's a lockout for those as well as the rear window controls...I guess it's not out of line to prevent the children from playing with the seats, too! Moving them with the seatbelts on could get dangerous in certain situations, so I'm not surprised other than I didn't think of it!
Reply With Quote
  #13  
Old 11-15-2014, 01:44 PM
daders's Avatar
daders daders is online now
There is no spoon
Location: DFW, TX
 
Join Date: Jul 2011
Posts: 728
Mein Auto: 2010 F07 550i, 2009 B8 A4
So glad this thread is here and I recalled the topic as I was trying not to freak out because our rear seat controls mysteriously stopped working. I just recalled we had the dog in the back on a short trip and he somehow got his paw on the sunscreen control thus causing them to go up and down a few times until I recalled I can thwart this via the master on/off switch for driver.

Guess what I'm trying to say is thanks for taking the time to post the cause as it relieved me of unnecessary concern!
__________________
There's no need to panic until it is time to panic.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > F07 Gran Turismo (2010 - Current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms