Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 10-25-2013, 07:20 AM
tyqre tyqre is offline
Registered User
Location: MA
 
Join Date: Oct 2013
Posts: 2
Mein Auto: X5 2006
X5 Speedometer not working

My2006 X5 has been having some electrical problems the past few days. My battery mysteriously died 2 days ago, had it jumped, everything worked fine. The next day when I went to start my car the instrument panel wasn't working at all. I replaced the instrument panel fuze and that fixed everything except the speedometer. Is there another fuze I should check for the speedo? I tried checking other fuzes that I thought where related but no luck. No lights/warnings come on the dash.
Reply With Quote
Advertisement
  #2  
Old 10-25-2013, 07:30 AM
bimwad bimwad is offline
Registered User
Location: MA
 
Join Date: Apr 2009
Posts: 63
Mein Auto: 2009 750i | 2010 X5
Usually jumping the car is not a great idea as the current surge could damage other sensors. I would suggest checking the battery voltage first. If it is less than 12V then you may need to replace the battery first. As the battery weakens it shuts down modules as a protective measure.
__________________
TIA
Mohamed
'09 F01 750i sport | premium sound | Cold weather package | Rear Wood Shelf | Bluetooth Audio
'10 E70 X5 xdrive30i sport | rear shades | rear climate | iPod/USB | Sat Radio | DVD in Motion activated
'03 E53 X5 3.0 | Premium | Rear Climate | Xenons | Privacy Glass
Reply With Quote
  #3  
Old 10-25-2013, 07:46 AM
tmvE39/E53/Z32's Avatar
tmvE39/E53/Z32 tmvE39/E53/Z32 is offline
Officially Welcomed to the 'Fest
Location: Seattle --> Atlanta
 
Join Date: Dec 2010
Posts: 1,900
Mein Auto: 03 540, 06 E53 4.8, Z32TT
Might just be coincident, the wheel speed sensor that control the speedometer went bad.
__________________

2000 Dinan S1 //M5 (my DD), 06 DINAN E53 4.8iS (wife's DD), 90 Straman Z32TT (my pride & joy ride)
Gone, but not forgotten: 01 E53 3.0i, 01 525i Sport, 03 DINAN 540i MSport and 91 Z32TwinTurbo
Reply With Quote
  #4  
Old 10-25-2013, 07:59 AM
tyqre tyqre is offline
Registered User
Location: MA
 
Join Date: Oct 2013
Posts: 2
Mein Auto: X5 2006
Alright, ill have to run out and get volt meter. If thats not the case ill have to get the wheel speed sensor checked.
Reply With Quote
  #5  
Old 10-25-2013, 08:06 AM
QSilver7's Avatar
QSilver7 QSilver7 is online now
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 6,173
Mein Auto: 1997 740iL / 2006 X5 4.4
Ditto...the speedometer receives it's info from the left wheel speed sensor...which sends data to the ABS control module...which then forwards that data to the IKE (instrument cluster electronics).

If you would have mentioned you had other warnings (ABS/DSC/Traction Control/etc)...it could be the signs of an ABS module beginning to fail. But since you say there's no other warning and the speedometer is not registering anything...then that points in the direction that the initial signal (from the rear left wheel speed sensor) is not sending data. I'd check there first...and "check" doesn't necessarily mean spend money replacing it...but test it to see if it is sending data first (before replacing it).

If you do a google search for "BMW trifecta Bluebee"...you should find one of her exhaustive posts on how to test the speed sensors and ABS module for this common malady found on the e39/e53/e46/e38.

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms