Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)

E89 Z4 (2009 - current)

Reply
 
Thread Tools Display Modes
  #1  
Old 10-28-2013, 11:55 AM
F1LOCO F1LOCO is offline
Registered User
Location: Sunnyland
 
Join Date: Sep 2013
Posts: 18
Mein Auto: 2011 Z4 s35i
Polling iDrive owners...

So the question is, is the CPO Platinum Wrap worth the price? It seems it only adds the stereo/navigation to the coverage. Granted I priced the iDrive display and seems $2K is the going rate. So has anyone out there had problems with the iDrive display failing? Can't imagine the head unit would actually fail, but wonder about the constant open/closing of the iDrive display.
Reply With Quote
Ads by Google
  #2  
Old 10-28-2013, 01:07 PM
hawkfury hawkfury is offline
Registered User
Location: Philadelphia, PA
 
Join Date: Aug 2013
Posts: 6
Mein Auto: 2013 Z4 28i
My display mechanism is acting very poorly. Within the past week, it has started having trouble opening and closing; sometimes not opening at all. I have been planning on going into the dealership in the next week or so anyway to purchase an extended warranty. Because of the malfunction I am currently experiencing, I will be purchasing the platinum. I will let you know how everything was handled after I bring it in.
Reply With Quote
  #3  
Old 10-28-2013, 01:17 PM
F1LOCO F1LOCO is offline
Registered User
Location: Sunnyland
 
Join Date: Sep 2013
Posts: 18
Mein Auto: 2011 Z4 s35i
What year and how many miles?
Reply With Quote
  #4  
Old 10-28-2013, 01:21 PM
hawkfury hawkfury is offline
Registered User
Location: Philadelphia, PA
 
Join Date: Aug 2013
Posts: 6
Mein Auto: 2013 Z4 28i
Sorry, I thought I included that. '13 with 9K.
Reply With Quote
  #5  
Old 10-28-2013, 01:59 PM
Fripp1964 Fripp1964 is offline
If in doubt...go flat out
Location: AlaBimmer
 
Join Date: Apr 2009
Posts: 147
Mein Auto: 2011 Space Grey Z4
'11 with 32k...no issues with mine
Reply With Quote
  #6  
Old 10-28-2013, 04:59 PM
rmorin49's Avatar
rmorin49 rmorin49 is online now
Officially Welcomed to the 'Fest
Location: Hagerstown, MD,
 
Join Date: Jan 2007
Posts: 4,052
Mein Auto: 2011 335d
When I bought my extended warranty I specifically went with the Platinum so all of my electronics would be covered. However, so far I am having no issues. 2010 with 12K miles.
__________________

Colonel (Ret) US Army / Hagerstown, MD
1985 M635 Euro Alpine White/Pacific Blue (Fun Car)
2010 Z4 s30i Alpine White/Beige
(Road Trip Car)

2013 Audi A6 Ibis White/Nougat (Daily Driver)
2013 Audi A4(Ret)
2011 335d (Ret)
2009 335i vert (Ret)
2007 335i vert (Ret) ED 04-13-10
2000 740iL (Ret)
1998 328iC (Ret)
1990 535i (Ret)
1988 635CSi (Ret)
Reply With Quote
  #7  
Old 10-29-2013, 03:55 AM
F1LOCO F1LOCO is offline
Registered User
Location: Sunnyland
 
Join Date: Sep 2013
Posts: 18
Mein Auto: 2011 Z4 s35i
Did I understand it incorrectly, or does the Platinum merely add stereo/entertainment/NAV only? Of course at about 1/3 the cost of a new display alone (let alone install time), it could be good insurance.
Reply With Quote
  #8  
Old 10-29-2013, 12:23 PM
Z4golfer's Avatar
Z4golfer Z4golfer is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: May 2010
Posts: 334
Mein Auto: 2011 Z4 35is
No problems so far. 2011 with 33,000 miles.
__________________


2011 Z4 35is
2014 X3 28i
Reply With Quote
  #9  
Old 01-04-2014, 10:30 AM
Z4golfer's Avatar
Z4golfer Z4golfer is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: May 2010
Posts: 334
Mein Auto: 2011 Z4 35is
Interestingly just a couple of weeks after posting that my display was problem free I had a problem. One afternoon I started my car and the screen was just a solid red color. I turned off the car and restarted but the same thing happened and then would go black after a few minutes. I called the dealer and set up an appointment for the following day since the car is still under warranty. Later that day when I got in and started the car the display was functioning normally. Since the dealer was also going to replace one of the daytime running lights I kept the appointment.
When I arrived I explained what had happened and also showed him a picture I had taken of the red screen. Although the screen seemed to function normally at the service department, they did tell me it was faulty and it would be replaced. None were available in the U.S. But there were 73 in Germany and they set up an appointment for the end of December. On the 27th they replaced the screen and did some software reprogramming, the only noticeable difference is that it's a little quieter opening and closing than the last one. The sales advisor told me it would have been about $2,700 if the car wasn't under warranty.
__________________


2011 Z4 35is
2014 X3 28i
Reply With Quote
  #10  
Old 01-06-2014, 09:21 AM
skier's Avatar
skier skier is offline
Officially Welcomed to the 'Fest
Location: Arizona
 
Join Date: Oct 2004
Posts: 1,065
Mein Auto: '11 Z4 35is
22K miles, 30 months, 2011 35is - no problems with iDrive display.
__________________

Travel Photos

Join BMW CCA
Reply With Quote
  #11  
Old 01-08-2014, 05:37 AM
Garylytton Garylytton is offline
Registered User
Location: Ga
 
Join Date: Nov 2013
Posts: 12
Mein Auto: Z4
2011 - 12k miles with no issues
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E89 Z4 (2009 - current)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 11:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms