Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 11-07-2013, 02:28 PM
Darknachos Darknachos is offline
Registered User
Location: LA
 
Join Date: Nov 2013
Posts: 1
Mein Auto: E38 740i
E38 Engine Warm , oil flickers when switchting from Park to Reverse.

I am baffled by this issue, any input would greatly be appreaciated.


When i first turn on my e38 740I on a cold engine start, I can switch from Park to Drive to Reverse, and its good to Go. Run with all its horsepower it has, no problems. Once the car is warm and has been running for about 30mins to an hour, and I shift into reverse. The oil light will flicker rapidly and switch gears, on a few occasions the car has shut off when going into reverse. If it shuts off, i just have to restart the engine then switch gears again so it can go in reverse.

No other symtons... No check engine light.... no nothing.... (BTW Oil is good and full)

I switch the Camshaft sensor for a new one, because i thought it would be buggy... but its still the same...



On a side note, my SRS light came on, its says left side airbag sensor fault.
Where is this sensor at? I want to clean the contacts....

Last edited by Darknachos; 11-07-2013 at 04:59 PM.
Reply With Quote
Ads by Google
  #2  
Old 11-08-2013, 04:22 AM
ou18 ou18 is offline
Playing Mechanic At Home
Location: Boca Raton FL
 
Join Date: Sep 2010
Posts: 804
Send a message via AIM to ou18 Send a message via Yahoo to ou18
Mein Auto: 1997 740 IL
I did a quick google search, and some have reported its an oil pressure issue that causes the light to flicker, HOWEVER, these same people have reported the flicker going away when throttle is pressed...

Does this occur for you?
__________________

1997 Black 740IL (w\ badass Phone in console)
Reply With Quote
  #3  
Old 11-08-2013, 08:07 AM
wiredantz wiredantz is offline
Registered User
Location: Los Angeles
 
Join Date: Oct 2011
Posts: 2
Mein Auto: 740I
Oil light flickers only when the engine has been running, warm, and only for a 1 sec or 2 when switching from P to Reverse. Then goes away. Sometimes when switching from P to R then engine shuts off.

when the engine is warm:
If I am on drive and come to a complete stop, then switch to Reverse the idle needle will jump to 1 and go back down to zero. If I am on P and go to reverse, the Idle needle will dip below zero and go back to 0.

Last edited by wiredantz; 11-08-2013 at 08:53 AM.
Reply With Quote
  #4  
Old 11-10-2013, 11:51 AM
Podmore Podmore is offline
Officially Welcomed to the 'Fest
Location: Adelaide South Australia
 
Join Date: Feb 2008
Posts: 151
Mein Auto: 2001 BMW 735i
Mmmmmm there's a challenge for we armchair diagnosticians!

At first blush the symptoms would seem to indicate a damaged transmission wiring harness causing a transient short circuit or bridging between two different circuits.

If a poorly functioning oil pump (or worn bearings or low oil level etc) was contributing to low oil pressure then the oil light would come on at idle every time, not just when engaging reverse. Also, likely to get a Low Oil warning from the Check Cluster.

The dip in the tachometer when shifting gears is also a clue, but I'm not sure what that clue is pointing to!

So as with all good diagnostic tests, begin a process of elimination and start by checking the condition of the wiring harness to the trans - especially the connector contacts.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 07:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms