Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 11-09-2013, 06:50 AM
JOSEMESATOBON JOSEMESATOBON is offline
Registered User
Location: MIAMI
 
Join Date: Nov 2013
Posts: 6
Mein Auto: BMW 2006 X5
hid bulb in my 2006 x5

Would anyone can help me on how to replace a hid bulb in my headlamps? I was able to remove de bad bulb but couldn't put it back in place. at the base of the bulb there is a metal box that by twisted it should lock in place. Any help would be appreciated and if you have pictures much better.
Reply With Quote
Ads by Google
  #2  
Old 11-18-2013, 09:04 PM
AJR1982 AJR1982 is online now
Officially Welcomed to the 'Fest
Location: Spokane
 
Join Date: Jan 2013
Posts: 178
Mein Auto: 525i 2002 & x5 2002
If you're talking about the Xenon lamps then they will slide in two directions. You'll notice two bumps that need to align with the inserts and try again.
Reply With Quote
  #3  
Old 11-19-2013, 07:41 AM
FanofX5 FanofX5 is offline
Registered User
Location: Columbia, Mo
 
Join Date: Nov 2013
Posts: 1
Mein Auto: 2006 X5 3.0
Are you having a problem getting the high voltage connector to snap back on? I went through this recently and could not get the connector to turn.

Look inside the connector, there will be a plastic ring. Make sure the notches on the plastic ring line up with the notches on the metal connector. It should slip right on if they are lined up.
Reply With Quote
  #4  
Old 11-21-2013, 01:22 PM
JOSEMESATOBON JOSEMESATOBON is offline
Registered User
Location: MIAMI
 
Join Date: Nov 2013
Posts: 6
Mein Auto: BMW 2006 X5
thank you very much, it was a matter of alignment of the ballast.
Reply With Quote
  #5  
Old 11-21-2013, 01:28 PM
JOSEMESATOBON JOSEMESATOBON is offline
Registered User
Location: MIAMI
 
Join Date: Nov 2013
Posts: 6
Mein Auto: BMW 2006 X5
IT IS NICE TO KNOW ABOUT ALL YOU GUYS OUTTHERE ALWAYS READY TO HELP. my bmw x5 2006 has developed this weird air conditioned problem: Sometimes after starting the engine, the A/C refuse to work and all of the sudden the compressor kicks in and everything is fine, it cools just fine. what can be causing the compressor not to start normally? I would appreciate any help.
Reply With Quote
  #6  
Old 11-21-2013, 02:06 PM
puddinboo puddinboo is offline
Officially Welcomed to the 'Fest
Location: on earth
 
Join Date: Jul 2013
Posts: 363
Mein Auto: 2003 BMW X5
I would start with a new thread for your a/c you will get more responses .
__________________
2003 X5 3.0i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms