Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E60 M5 (2006 - 2010)

E60 M5 (2006 - 2010)

Reply
 
Thread Tools Display Modes
  #1  
Old 12-27-2013, 12:03 PM
kanass69 kanass69 is offline
Registered User
Location: UAE
 
Join Date: Dec 2013
Posts: 1
Mein Auto: E60 M5
Would really appreciate some help

HEy Guys

Long time reader first time poster!! I am the lucky and proud owner of a E60 M5, year 2006. I live in Dubai and so far the car has behaved nicely!!

However, for the past week or so, i have had an electrical issue that the mechanics havent been able to fix. Basically, when i try and start the car, i get all the normal indications, re lights, HUD..when i turn the key, i get just a clicking sound and no start. There are no codes, no warning lights but the HUD indications go blank as i turn the key, then when i release they come back. If i jump the start the car subsequently, it runs fine for that day. However, if i leave the car for a day without driving it, the same problem returns. The BMW boys, made me change the battery and they also had the car for a few days but couldnt find the fault. I am now not really feeling confident with them, as they are charging me!!

Was wondering if anyone else has had the same issue or may have some ideas on areas i should check? The mecahnics reckon the battery drain when car is switched off is 0.250..not sure if that is an indication of anything as i am not possessing many brain cells!!

Any help or advice would be greatly appreciated

Cheers and thanks alot...
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E60 M5 (2006 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms