Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - 2014)

X6 E71 / E72 (2008 - 2014)
The BMW X6 luxury crossover went on sale in April 2008 as a 2009 model year. BMW referes to the X6 as a Sports Activity Coupe (SAC) as it combines the attributes of an SUV (high ground clearance, xDrive and all-weather ability) with the stance, styling and roof line shape of a coupe. The E71 X6 was built off the E70 X5 (2007 - 2013) platform at BMW's Spartanburg, SC plant. Total worldwide sales were just over 235,000, sold mostly to the BRIC countries. US total sales was 34,082 vehicles.

Reply
 
Thread Tools Display Modes
  #1  
Old 01-08-2014, 01:44 PM
AskylitDrive's Avatar
AskylitDrive AskylitDrive is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Oct 2013
Posts: 134
Mein Auto: 2012 BMW X6 35i
Car won't Start!

Hey my fellow x6 owners . So this morning i get out and start my car to warm it up before i go to work and the car fires up but as it is going through the start up process, it shuts back down... It was doing its normal revs in the start but as it was coming down, it just shuts down completely. I tried a few more times and it does the same thing. My initial thought was that it had to do with my battery, either it was too cold, or the battery couldn't recharge itself. The msg that pops up though when it shuts down is "the ignition is on"... Does anyone know whats wrong with the car?? Im from Toronto, Canada. Weather was as low as -20 yesterday. Thanks in advance!
Reply With Quote
Advertisement
  #2  
Old 01-09-2014, 05:53 PM
Bubbs Bubbs is offline
Registered User
Location: Syracuse
 
Join Date: Aug 2012
Posts: 71
Mein Auto: 2011 335i xDrive, 2014 X1
Try some dry gas.


Sent from BimmerApp mobile app
__________________
2011 335i
2014 X1
Reply With Quote
  #3  
Old 01-23-2014, 02:51 PM
G750i G750i is offline
Account Under Review
Location: Westchester, NY
 
Join Date: Dec 2012
Posts: 40
Mein Auto: 750li
Quote:
Originally Posted by AskylitDrive View Post
Hey my fellow x6 owners . So this morning i get out and start my car to warm it up before i go to work and the car fires up but as it is going through the start up process, it shuts back down... It was doing its normal revs in the start but as it was coming down, it just shuts down completely. I tried a few more times and it does the same thing. My initial thought was that it had to do with my battery, either it was too cold, or the battery couldn't recharge itself. The msg that pops up though when it shuts down is "the ignition is on"... Does anyone know whats wrong with the car?? Im from Toronto, Canada. Weather was as low as -20 yesterday. Thanks in advance!
Not sure what happened - can you update us on what you found out? I think its your battery too
Reply With Quote
  #4  
Old 01-25-2014, 04:09 PM
AskylitDrive's Avatar
AskylitDrive AskylitDrive is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Oct 2013
Posts: 134
Mein Auto: 2012 BMW X6 35i
Quote:
Originally Posted by G750i View Post
Not sure what happened - can you update us on what you found out? I think its your battery too
Ya. When roadside assistant came to my house, they boosted the car because the weather was too cold. At the same time i was doing a lot of short driving so the battery wasn't charged at a good level so when i tried to start the car, there wasn't enough juice to fully start the car. Its been 2 weeks since it happened and i haven't got that problem again even when the weather outside is still -20. So my conclusion is, make sure your charge is at a good level or buy from Canadian tire a charger to charge battery over night


Sent from BimmerApp mobile app
__________________

Previous Cars:
1998 BMW 328i -Gone
2006 BMW X3 25i -Gone
2006 BMW X3 30i -Gone
2005 BMW X5 3.0 -Gone
2010 Lexus IS 250 F-Sport -Gone
Current Cars:
2014 BMW 335i Xdrive
2012 BMW X1 28i
2012 BMW X6 35i
2011 Mercedes Benz C300 4matic
Reply With Quote
  #5  
Old 01-27-2014, 10:48 AM
Kzang's Avatar
Kzang Kzang is offline
Officially Welcomed to the 'Fest
Location: NJ
 
Join Date: Apr 2006
Posts: 4,880
Mein Auto: 2013 X5 35i Premium
Check the X5 forums.. many are experiencing similar problems.
__________________
2013 X5 35i Premium, Space Gray, Cinnamon Brown Leather, Dark Bamboo wood trim, Conv. Pkg, CWP, Multi-contour seats, Running board, BMW App. Space saver tire.
Previous Cars
2010 535i - Deep Sea Blue w/ NBD Leather, Bamboo Anthracite WT, Sport Auto Trans w/ Paddle shifter, Sports Pkg, PP, CWP, Nav, HD Radio, Ipod.
2007 525i - Black Sapphire Metallic, Black Nevada Leather, Premium package, CWP, 6MT.
Reply With Quote
Reply

Bookmarks

Tags
battery, car won't start, too cold


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X6 E71 / E72 (2008 - 2014)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms