Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)

X5 E53 (1999 - 2006)
The X5 SAV Forum

Reply
 
Thread Tools Display Modes
  #1  
Old 02-04-2014, 02:38 PM
s14DK s14DK is offline
Registered User
Location: Toronto
 
Join Date: Aug 2013
Posts: 26
Mein Auto: x5
4x4 and Ebrake light

How's it going guys,
I accidentally posted this in the x3 forum so here it goes:

I have the same 4x4 light + Ebrake light on at all times since yesterday (2004 e53 3.0i)
So I took off the actuator to see if the gear was chewed up or not, and to my surprise it wasn't. I ended up rotating the gear just to be extra sure, installed her back and both lights are still ON. There was never any clicking either so im pretty sure the gear is good.

My question is, should I swap out speed sensors or try the steering position sensor?
I have a regular ODB2 scanner, it can only tell me so much. Anyone know where I can get a scanner or even the software for bmw vehicles.

Cheers guys, any input will be greatly appreciated!
Reply With Quote
Advertisement
  #2  
Old 02-07-2014, 04:30 PM
AJR1982's Avatar
AJR1982 AJR1982 is online now
Officially Welcomed to the 'Fest
Location: Spokane
 
Join Date: Jan 2013
Posts: 206
Mein Auto: 525i 2002 & x5 2002
Can you take a picture of the lights you are seeing? I've never see 4x4 and e-brake lights on at the same time.
Reply With Quote
  #3  
Old 02-07-2014, 05:45 PM
s14DK s14DK is offline
Registered User
Location: Toronto
 
Join Date: Aug 2013
Posts: 26
Mein Auto: x5
i wish i could, the lights just went out yesterday after i reset my battery for 20 minutes after the left and right steering reset procedure.

everything went away and hasn't come back after a whole days worth of driving. my creator c110 scanner comes in soon as well
Reply With Quote
  #4  
Old 02-07-2014, 05:51 PM
puddinboo puddinboo is offline
Officially Welcomed to the 'Fest
Location: on earth
 
Join Date: Jul 2013
Posts: 368
Mein Auto: 2003 BMW X5
hows your battery and alt?
__________________
2003 X5 3.0i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E53 (1999 - 2006)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:18 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms