Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E90/E92/E93 M3 (2008 - 2014)

E90/E92/E93 M3 (2008 - 2014)
4th generation E90 M3 sedan, E92 M3 coupe and E93 M3 convertible. The last of the naturally aspirated M3s, powered by a 4.0 liter V8 making 414hp and 295 lb-ft of torque.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-06-2014, 01:30 PM
MMME30W's Avatar
MMME30W MMME30W is offline
Super Moderator
Location: On The Move
 
Join Date: Jul 2003
Posts: 14,156
Mein Auto: 2009 W906
Occasional stall at idle/stoplights

Hey all, I am away on travel but Mrs. MMME30W reported that she had some issues using the car this past weekend.

Apparently she experienced unexpected stall / engine dieing on her a few (3?) times. She said she could sometimes keep it running with the throttle.

She said she only filled up with Chevron and Shell highest octane.

I get back Saturday and was wondering, has anyone seen a similar problem?

Car is an 09 E92, with original battery. I have the Dinan tune, if it matters.

Could the battery be acting up? Or just batch of bad gas causing drivability issues?

Just had an oil service done locally at a Reeves in Tampa, car had no reported issues.




Sent from BimmerApp mobile app
__________________
“Character is doing the right thing when nobody’s looking. There are too many people who think that the only thing that’s right is to get by, and the only thing that’s wrong is to get caught.”

- J.C. Watts Jr.

Last edited by MMME30W; 02-06-2014 at 01:31 PM.
Reply With Quote
Advertisement
  #2  
Old 02-06-2014, 08:28 PM
kscarrol kscarrol is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: Sep 2005
Posts: 533
Mein Auto: 2011 E90 M3
Yes, having a similar issue with my '11 E90. I also fill up with Shell but thought initially it might be bad gas. Have tried the Chevron station as well but still having very occasional issues. Varying idle, particularly with the AC on. RPM's bounce up and down resulting in a stall occasionally though on a couple of occasions the idle has dropped enough that my DCT put itself in neutral but the engine did not stall. Have read about idle control valve issues with these cars but have yet to bring it to the dealer. Due for a regular service very soon so will mention it them and see if the car is throwing any codes...
Reply With Quote
  #3  
Old 02-07-2014, 07:01 AM
mawana's Avatar
mawana mawana is offline
Officially Welcomed to the 'Fest
Location: DFW, TX
 
Join Date: Nov 2006
Posts: 2,028
Mein Auto: e46 ZHP, e90 M3
No codes? Most likely the Idle Control Device acting up or Throttle Actuators - there are two of them!
__________________
"Common sense is the collection of prejudices acquired by age 18." ~ Albert Einstein
BMWCCA 405578
Reply With Quote
  #4  
Old 02-07-2014, 08:39 AM
MMME30W's Avatar
MMME30W MMME30W is offline
Super Moderator
Location: On The Move
 
Join Date: Jul 2003
Posts: 14,156
Mein Auto: 2009 W906
Hmmmm, ok.

The idle control valve was replaced by PO as a warranty item in '10 I think.

Thanks I'll look into that after I get home Saturday.


Sent from BimmerApp mobile app
__________________
“Character is doing the right thing when nobody’s looking. There are too many people who think that the only thing that’s right is to get by, and the only thing that’s wrong is to get caught.”

- J.C. Watts Jr.
Reply With Quote
  #5  
Old 02-07-2014, 03:53 PM
kscarrol kscarrol is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: Sep 2005
Posts: 533
Mein Auto: 2011 E90 M3
Quote:
Originally Posted by mawana View Post
No codes? Most likely the Idle Control Device acting up or Throttle Actuators - there are two of them!
I don't own a reader (probably should get one) so I'll try to get my dealer to pull any codes when I bring the car in. Knowing my dealer they will drive it, state they can't replicate the issue and do nothing...
Reply With Quote
  #6  
Old 02-09-2014, 09:55 AM
MMME30W's Avatar
MMME30W MMME30W is offline
Super Moderator
Location: On The Move
 
Join Date: Jul 2003
Posts: 14,156
Mein Auto: 2009 W906
Filled up with a tank of Shell 93 at a station I frequent.

So far not a bobble.


Sent from BimmerApp mobile app
__________________
“Character is doing the right thing when nobody’s looking. There are too many people who think that the only thing that’s right is to get by, and the only thing that’s wrong is to get caught.”

- J.C. Watts Jr.
Reply With Quote
  #7  
Old 02-09-2014, 11:38 AM
kscarrol kscarrol is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: Sep 2005
Posts: 533
Mein Auto: 2011 E90 M3
Good, just hope it stays away! Mine comes and goes so I can't tie it to a specific gas station though I almost exclusively use the Shell near my house. When tis issue started I thought perhaps the gas was old or they had received a bad batch. Used Chevron for the next 3-4 fill-ups and seemed better but the weather was cooler so I was not running my AC. As soon as it warmed up and I turned on the AC the issue returned, but again only occasionally...
Reply With Quote
  #8  
Old 02-10-2014, 05:43 PM
Jim in Oregon Jim in Oregon is offline
Officially Welcomed to the 'Fest
Location: Eugene, Oregon
 
Join Date: Dec 2001
Posts: 548
Mein Auto: 2009 E92 M3 Coupe
I have a 2009 E92 with Dinan software and so far no problems except for initial cold start (20ºF) weather the idle fluctuates up and down for 30 seconds before smoothing out. I run nothing but 76 (92 octane) and still on my original battery but use a trickle charger on it in the garage all the time now to keep the battery at full charge. Hopefully will last a couple more years. The problem could stem from the winter gas and/or ethanol mixture these days. Just give some nice 100 octane gas for about $4/gallon and I'll be happy.
Reply With Quote
  #9  
Old 02-10-2014, 06:42 PM
kscarrol kscarrol is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: Sep 2005
Posts: 533
Mein Auto: 2011 E90 M3
My issue is not the cold start, happens long after the car is fully warmed up. I suppose it could be the winter gas mix but it has been happening for more than a couple months. Not well versed on winter gas, need to do some research. Dealer is busy so car not going in until the 20th, we'll see if the car is throwing any codes...
Reply With Quote
  #10  
Old 02-20-2014, 09:10 AM
kscarrol kscarrol is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: Sep 2005
Posts: 533
Mein Auto: 2011 E90 M3
OK, car is at the dealer and I will report back once I hear something. I described the issue and asked them see if the car was throwing any codes as it was unlikely that a tech would experience my issue on a short test drive. Don't want the car coming back with the tech saying "could not replicate". Still not sure they will really do anything but I will follow up. Hell just given that I dropped the car off at 7:30 and have not heard back by now hopefully means they are really looking it over! Otherwise car is in for basic service, oil and air filter change so it should have been done by now for just those service items...
Reply With Quote
  #11  
Old 03-08-2014, 01:23 PM
TeaRex714's Avatar
TeaRex714 TeaRex714 is offline
Officially Welcomed to the 'Fest
Location: Houston, Texas
 
Join Date: Oct 2006
Posts: 418
Mein Auto: 2008 E90 M3
Is the problem showing up right after a fill-up, or at some random points through the tank of gas?
__________________
2008 M3 Sedan Alpine White / Fox Red
Reply With Quote
  #12  
Old 03-08-2014, 01:38 PM
kscarrol kscarrol is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: Sep 2005
Posts: 533
Mein Auto: 2011 E90 M3
Random points. It has occurred after a fill-up but running errands this afternoon with a half tank and it did it again. No stall, just the fluctuating idle. And of course no codes being thrown and the service tech could not replicate so nothing done at the dealer.... I will now start carrying my cellphone around and have it ready at stop lights so that I can film the issue before bringing it back in. It really more of an annoyance but I'd like to make sure that if something needs to be fixed, it gets done before the warranty expires in October!
Reply With Quote
  #13  
Old 03-08-2014, 02:23 PM
TeaRex714's Avatar
TeaRex714 TeaRex714 is offline
Officially Welcomed to the 'Fest
Location: Houston, Texas
 
Join Date: Oct 2006
Posts: 418
Mein Auto: 2008 E90 M3
I had a bad stalling problem after every fill-up for a good while and it ended up being the purge valve. Eventually I got a CEL (along with the Check Gas Cap message) saying I had an Evap system leak. It's possible that your purge valve is going out, but it's hard to put your finger on that until the problem is more regular. The dealer wanted to charge a RIDICULOUS amount to replace it (about $850), so I went to their parts counter, got the part for about $89, and replaced it in my garage in about three hours. It only took that long because I'd never had the intake plenum off before, so there was a little learning curve taking that off and putting it back on. I'd say maybe an hour and fifteen now...
__________________
2008 M3 Sedan Alpine White / Fox Red
Reply With Quote
  #14  
Old 03-09-2014, 03:25 PM
kscarrol kscarrol is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: Sep 2005
Posts: 533
Mein Auto: 2011 E90 M3
OK, finally caught on video. This is from this afternoon right after filling up. I drove 0.6 miles back to my house and started filming. The full video is 2 minutes but the action didn't start until more than a minute in so I have edited this version for posting. Apologies in advance for the crappy iPhone video!

Reply With Quote
  #15  
Old 03-12-2014, 08:29 AM
kscarrol kscarrol is offline
Officially Welcomed to the 'Fest
Location: New Orleans
 
Join Date: Sep 2005
Posts: 533
Mein Auto: 2011 E90 M3
OK, stopped by my dealer this morning to show them the video. Head service tech watched then asked if I have any software on the car (I don't). His first response was that he would change the idle control valve. I wouldn't mind getting that done before my warranty expires in Oct given the troubles folks have had but then I mentioned the gas purge valve and he said yes, it could be that as well, that sometimes they stick open... I'll bring it back to them at a later date for the work and follow up.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > M Series > E90/E92/E93 M3 (2008 - 2014)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms