Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 11-21-2011, 05:28 PM
runner999 runner999 is offline
Registered User
Location: Mass
 
Join Date: Jan 2011
Posts: 16
Mein Auto: E83 X3
Lights going crazy

I went to start my 2007 X3 tonight and the headlights went on than off in high beams, left turn signals were blinking and could not be canceled, dash lights went dim and bright on their own. I shut the engine off and pulled the key and opened, closed and remotely locked the doors but the headlights stayed on and the rear fog light which I don't have programed or have a switch for was on. Lights eventually went out on their own.

No work was done on the car recently and has been fine up to this. My only thought is a faulty lighting control module if this makes sense. Any ideas or experiences for same would be appreciated.
Reply With Quote
Advertisement
  #2  
Old 11-22-2011, 04:12 AM
x3oiler x3oiler is offline
Officially Welcomed to the 'Fest
Location: Melbourne Australia
 
Join Date: Jun 2009
Posts: 171
Mein Auto: Touareg TDI
First check the battery, Low voltage after starting can cause havoc with the car electronics. re battery check - does the magic eye in the battery show green?
__________________
VW Touareg V6 TDI 4Motion with a smooth as AISIN 8 speed auto gearbox that WORKS!
X3 3.0d 2006 (MY07) sold
Reply With Quote
  #3  
Old 11-22-2011, 09:35 AM
runner999 runner999 is offline
Registered User
Location: Mass
 
Join Date: Jan 2011
Posts: 16
Mein Auto: E83 X3
That was it, no green eye and the battery is the original (4 years old). I set off to the dealer and 6 miles in things started to work again. So I bought another battery from the dealer instead of leaving it this morning and swapped it out myself. Strange things are still happening like the mirrors initially retracted on and off ramdomly and the windows won't go down yet. I'm wondering if this is due to the new battery not being fully charged and things will come around once the battery is completely charged.
Reply With Quote
  #4  
Old 04-01-2012, 08:19 AM
PSUEng PSUEng is offline
Officially Welcomed to the 'Fest
Location: SE
 
Join Date: Oct 2010
Posts: 384
Mein Auto: 2007 X3
Any resolve on this? I had the left turn signal and high beam thing happen on my 2007 last week. And the parking lights will sporadically come on, then go off. I have the original battery, but no fault lights on the cluster. Seems this happens after a short startup and move the car in the driveway, then turn off.

I've never had this happen on my E46.
Reply With Quote
  #5  
Old 04-01-2012, 08:33 AM
UncleJ UncleJ is offline
Officially Welcomed to the 'Fest
Location: Silicon Valley
 
Join Date: May 2006
Posts: 6,566
Mein Auto: '06 X3
Over on the new X3 board "Selbyman" writes about a similar problem under "Possessed X3 lights flashing...." with his sister's new 28i. Might not be the same thing though it sounds similar.
Reply With Quote
  #6  
Old 04-01-2012, 08:54 AM
runner999 runner999 is offline
Registered User
Location: Mass
 
Join Date: Jan 2011
Posts: 16
Mein Auto: E83 X3
It was a combination of things. The main issue was the battery nearing end of life, it just wasn't able to store enough charge to start the engine and provide the needed current for other electrical systems. The give-away was after the X3 was driven a few miles down the road, everything (lights, turn signals, flashers, mirrors etc) started to operate as it should.

The second and most unfortunate thing that may have coincidently occurred due to the faulty battery was the electrically folding mirrors. Even after I replaced the battery with a new BMW battery which I might add was cheaper than an aftermarket battery after my BMW CCA discount at the dealer was the folding mirrors still sporadically would fold in and out while driving. Also the side windows didn't always work. A scheduled visit to the dealer found that the passenger side mirror module was faulty and needed to be replaced under the CPO warranty. Magically that one mirror module was the issue for the mirrors and side windows. Go figure.

Last edited by runner999; 04-01-2012 at 09:05 AM.
Reply With Quote
  #7  
Old 04-01-2012, 07:33 PM
Rock'n R Rock'n R is offline
Registered User
Location: Utah
 
Join Date: Jan 2008
Posts: 47
Mein Auto: 2004 X3 3.0
I might have some insight to your electrical gremlins. A couple of weeks ago my wifes 2004 325i started behaving like it was possessed. Interior lights going on and off while she drove. Haha, one night we looked like a driving disco tech. Anyways, her brake lights would sometimes stay on, cruise indicator light would stay on, power seats wouldn't work. There were a lot of stange electrical gremlins going on. Changed the battery and still these electrical gremlins would show up. Finally we took her car into the dealer and they diagnosed it with a faulty ignition switch. Everything is perfect now. I hope this helps.
Reply With Quote
  #8  
Old 01-27-2013, 03:02 AM
ncord ncord is offline
Officially Welcomed to the 'Fest
Location: ontario canada
 
Join Date: Nov 2009
Posts: 175
Mein Auto: 2006 X3
What did the dealer charge you for the battery
Reply With Quote
  #9  
Old 01-27-2013, 06:01 AM
runner999 runner999 is offline
Registered User
Location: Mass
 
Join Date: Jan 2011
Posts: 16
Mein Auto: E83 X3
Quote:
Originally Posted by ncord View Post
What did the dealer charge you for the battery
Surprisingly, it wasn't to bad after my BMW Car Club membership discount and ended up costing ~$145 USD. I put it in myself (very easy) and my 2007 X3 didn't require battery registration.

Last edited by runner999; 01-27-2013 at 07:43 AM.
Reply With Quote
  #10  
Old 01-27-2013, 07:25 AM
John320 John320 is offline
Officially Welcomed to the 'Fest
Location: Ontario,Canada
 
Join Date: Apr 2008
Posts: 198
Mein Auto: 2008 X3.0si
to ncord - Here in Canada ( Budds BMW Hamilton) I got one last month # 61-21-7-586-962 Battery from Exide: list $246.11 but sold it to me for $176.00 -that was in the parts store, and just put it in myself in the parking lot, and gave them the old one back.
Reply With Quote
  #11  
Old 05-01-2013, 04:43 PM
DKBX3 DKBX3 is offline
Registered User
Location: Marion, Ohio USA
 
Join Date: May 2013
Posts: 4
Mein Auto: BMWX3
Did anyone ever find out what was causing your X3 to behave that way? My 2007 X3 parking lights come on randomly & my dealership is no help. I am constantly worried my lights will randomly come on while my vehicle sits in the parking lot at work, then I'll come out to a dead battery. I asked the service associate if it could be my battery & he said it tested fine. I seriously doubt if they even tested it. I want to scream!!
Reply With Quote
  #12  
Old 05-02-2013, 03:47 AM
runner999 runner999 is offline
Registered User
Location: Mass
 
Join Date: Jan 2011
Posts: 16
Mein Auto: E83 X3
Quote:
Originally Posted by DKBX3 View Post
Did anyone ever find out what was causing your X3 to behave that way? My 2007 X3 parking lights come on randomly & my dealership is no help. I am constantly worried my lights will randomly come on while my vehicle sits in the parking lot at work, then I'll come out to a dead battery. I asked the service associate if it could be my battery & he said it tested fine. I seriously doubt if they even tested it. I want to scream!!
I would find another dealer. I know it's expensive to have those guys work on our vehicles but they have the diag equipment which should show the recorded faults in your X3.
Reply With Quote
  #13  
Old 05-02-2013, 05:57 AM
DKBX3 DKBX3 is offline
Registered User
Location: Marion, Ohio USA
 
Join Date: May 2013
Posts: 4
Mein Auto: BMWX3
My husband hooked the battery up to a charger last night and it was practically dead. Kept it on charger for 6 hours & it still wasn't fully charged. I took my X3 to the BMW dealership where I originally purchased it & basically paid $120 for a car wash yesterday. Getting the battery tested today for a bad cell.
Reply With Quote
  #14  
Old 02-28-2014, 09:04 AM
cloudboy cloudboy is offline
Registered User
Location: Massachusetts
 
Join Date: Apr 2013
Posts: 8
Mein Auto: X3 2008
I had the same thing happen to me - left turn signal wouldn't shut off, high beams on. If I turned the car off the side marker lights and angel eye lights would stay on. then, after a bit, turn signals wouldn't work at all.

Took it to the dealer, they quickly diagnosed it as the ride height sensor. Replaced, no more problems 9at least with THAT bit), but it cost me $340.
Reply With Quote
  #15  
Old 03-01-2014, 07:05 AM
DKBX3 DKBX3 is offline
Registered User
Location: Marion, Ohio USA
 
Join Date: May 2013
Posts: 4
Mein Auto: BMWX3
Thanks cloudboy. The dealer finally fixed the problem after trying different things & charging me almost $2000. They originally changed the lighting control module, which worked for awhile. Two days later it happened again so they changed the lighting control switch. I had done my homework & suggested the light leveling sensor, but they blew me off. Several months after that it happened again so they finally tested the light leveling sensor. Amazing. That was the problem. It's been a bit frustrating, but I've had it paid off for a couple years, so we're keeping it. The only problem now is that annoying tick that seems to be standard in freezing temps with the X3. Overall, a nice vehicle though.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 02:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms