Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)

E85 / E86 Z4 (2003-2008)
E85 Z4 convertible and E86 Z4 coupe talk with our BMW gurus here.

Reply
 
Thread Tools Display Modes
  #1  
Old 03-19-2014, 01:53 PM
mickibarry mickibarry is offline
mickibarry
Location: California
 
Join Date: Mar 2014
Posts: 2
Mein Auto: 2005 Z4
Soft top

The button to open and close my soft top just stopped working...had just used it and when I got back in my car to open it wouldn't work. Anyone have this happen? I don't think it's the motor because it never made any unusual noise when opening. Do you think it is electrical? Any help would be appreciated.
Reply With Quote
Ads by Google
  #2  
Old 03-19-2014, 03:29 PM
fastgaas fastgaas is offline
Registered User
Location: Palo Alto, CA
 
Join Date: Oct 2010
Posts: 33
Mein Auto: 2004 Z4
The most obvious thing is the disable switch has been activated by moving the shelf in the trunk. If the shelf is moved up (large boxes in the trunk perhaps?) the the top automatically disables the top lowering so you don't "crush" the pocket with the top. Sometime the switch just goes bad or the shelf goes out of alignment. I would move the shelf up and down and see if it's locking into the center slot.

Other than that there are a series of safety items that prevent the top from going. Make sure things are secure. You can manually open the top by enguaging the release in the trunk and lifting or closing.... might be good to get things going.

Typically when the top releases to open, but does not move and red light flashes means the motor is dead.

Try searching the you will find lots more information.
-H
Reply With Quote
  #3  
Old 03-19-2014, 03:31 PM
mickibarry mickibarry is offline
mickibarry
Location: California
 
Join Date: Mar 2014
Posts: 2
Mein Auto: 2005 Z4
Thank you! I will try all of your suggestions...much appreciated.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > Z Series > E85 / E86 Z4 (2003-2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 12:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms