Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E21 (1975 - 1983)

E21 (1975 - 1983)

Reply
 
Thread Tools Display Modes
  #1  
Old 04-14-2014, 05:38 PM
Tbar2 Tbar2 is offline
Registered User
Location: Sparks, NV
 
Join Date: Apr 2014
Posts: 1
Mein Auto: 1981 BMW 320i
1981 320i help needed

Hello all, I'm new to the site but I was really hoping to get some help with a couple different electrical problems I've been having w/ my 1981 320i.

1st: When I try to use the passenger side blinker it does not work, and will blow the fuse. The driver side blinker works fine and all the lights work properly when the 4-ways are on. All the bulbs are good, every fuse is new and are correct, I've replace the hazard switch, flash and intermittent washer relays, and both the turn signal and washer switches in the column.

2nd: When I turn on the headlights the low beams do not work, however, the marker lights all work and when I flip on the high beams all 4 headlights work just fine. as noted above, all the fuses have been replaced as well as the hazard switch. I have also replaced the low beam relay.

I feel like I have replaced everything that is logical to replace and have tested to try and find a short anywhere in these systems and haven't found any evidence of such a short. I really like this little car but chasing these problems is pretty frustrating. I will sincerely appreciate any and all help! Thank you.

Cheers.

Last edited by Tbar2; 04-14-2014 at 06:29 PM. Reason: left out important details
Reply With Quote
Advertisement
Reply

Bookmarks

Tags
320i, e21, electrical, help advice needed, troubleshooting


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 3 Series / 4 Series > E21 (1975 - 1983)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 10:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms